The Cave > Általános témák > Téma részletei
Ser Hammy 2013. jan. 23. @ du. 8:01
Yet another Double Fine game, yet another black screen.
Seriously, this is the second or third Double Fine game I buy on steam that won't work on my laptop. All I get when I try to run them is a black screen, a mouse cursor and some sounds.. And I ONLY get this problem with Double Fine games, weird huh? Anyone else experiencing this?
114/14 megjegyzés mutatása
< >
Barrowman! 2013. jan. 23. @ du. 8:52 
I'm having the same problem! Very frustrating.
Syphonfire 2013. jan. 24. @ du. 2:40 
Go to the games properties in steam, select set launch options and type "-window" without brackets. You can restore fullscreen when ingame.
Ser Hammy 2013. jan. 24. @ du. 3:10 
Tried that, didn't help.
Snake 2013. márc. 19. @ du. 10:09 
Do this: Alt + Enter, when the game is in window mode, change the settings of the video to 60HZ, the game has 150HZ for default.
uraeus 2013. márc. 26. @ du. 1:45 
I am having a similar issue with The Cave. I am running it under Linux using the Intel drivers. But once I am i nthre character selection screen I can't see the characters, instead all I have is the mouse pointer and the character names pop up, but not the actual characters. Been like this since launch, but I figured it would eventually get sorted, but nothing has happened so far.
global_warming 2013. márc. 27. @ du. 8:42 
Black Screen is usually incompatible /unsupported resolution or refresh rate. I am betting your 'laptop' with its funky widescreen shape/strange native resolution probably has something to do with it.
Ser Hammy 2013. márc. 27. @ du. 8:54 
My "strange" native laptop screen resolution is 1920x1080, and again, doublefine games are the only ones I have had problems with. What I had to do to fix the problem was to change the laptop resolution to 1600x900, and that worked for some reason.
global_warming 2013. márc. 27. @ du. 10:00 
Standard resolutions 10 years ago were 640/480, 800/600, 1024/768, 1280/1024, 1600/1200. I am really not sure the reasoning behind all the variated aspect ratios, especiall with laptops these days... it seems that as time goes on they get more and more obscure. Even worse with movies and their 'widescreen' formats. Watch a DVD from 10 years ago and it fills the whole screen... today's DVD's your lucky if it covers a narrow strip across your TV.
uraeus 2013. ápr. 1. @ du. 12:49 
My laptop resolution is 1600x900 so that isn't my problem, and as far as I can tell there is no discreet graphics card in this system even if the spec page claims there should be.
global_warming 2013. ápr. 1. @ du. 8:38 
Its not the 1600 by 900 that fixed it, its that he changed his desktop resolution to a compatible aspect ratio as the one the game was trying to start in. Whats happening is the game is detecting what it thinks your default settings should be, and then trying to start the game in a compatible resolution. If your native desktop resolution's aspect ratio is some strange number like 16:9 and the game tries to start in a more 'standard' resolution aspect ratio, that can and will cause the video card to 'lose the signal', which results in a black screen, as if your monitor was not even connected. Change your desktop resolution to something that is 4:3 or something and then the game should start fine w/o losing the video signal.
Legutóbb szerkesztette: global_warming; 2013. ápr. 1. @ du. 8:48
uraeus 2013. ápr. 2. @ de. 1:12 
Tried changing resolution and even tried an external screen, but no luck.
I had a similar issue with Crusader Kings 2 in the beginning, but it was resolved by a patch which removed some double underscores from some macros in the shader code, as the Intel drivers didn't like it and it was not approved by the OpenGL spec to use double underscores in the shader code macro names.

Grepping in the shaders directory gives me a match for __ in both Cave.fxo and Mesh.fxo.
global_warming 2013. ápr. 2. @ de. 1:55 
Interesting.. not sure why that would cause the loss of the video signal though. Seems like something like that would crash the game and bring up an error message. As far as I know, the intel online graphics accelerator is not meant for much more than watching video. You may have gotten lucky to get Crusader kings to work... being thats a strategy game with not much action. I highly doubt you'd be able to get any recently released action type game to work with that.
Legutóbb szerkesztette: global_warming; 2013. ápr. 2. @ de. 1:58
uraeus 2013. ápr. 2. @ de. 2:56 
The Intel driver is actually quite good these days. Valve and Intel worked together on L4D2 for instance making sure that game would run well on the open source Intel driver. So I am not saying that you can't get better performance with a top of the line NVidia card and the proprietary driver, but for many games the Intel driver is good enough, and I am sure that the Cave is not that extreme in its graphics use.
global_warming 2013. ápr. 2. @ du. 8:31 
Ah forgot this was the Cave forum and not Brutal Legend... true....I absolutely agree from looking at the screenshots on the Cave ... pretty much a joke that a side scrolling game like that wouldn't work with any graphics driver at all.
114/14 megjegyzés mutatása
< >
Laponként: 15 30 50