Rocksmith® 2014 Edition - Remastered

Rocksmith® 2014 Edition - Remastered

View Stats:
alexlf Oct 22, 2013 @ 4:13pm
[Solved] Windows 8.1 Real Tone Cable Issues (USB Connection Problems)
I've been trying to hook up my Real Tone cable to my new laptop, but get a yellow triangle under device manager when I do, combined with the error message:

This device cannot start. (Code 10)

The I/O request was canceled.

I've tried uninstalling the driver and reinstalling, rebooting, manually installing the drivers, different USB ports, a usb hub, a powered USB hub, and a USB extension cable, all to no avail. I know the cable works since I can hook it up to my old laptop and it works fine. My only thoughts are that it must be some compatibility problem with windows 8.1(maybe that it's a 64 bit install?) I currently am wondering if it is because of the "ASUS USB Charger +" thing that's installed.

Anyone have any ideas on a solution? Thanks!

UPDATE:
Alright, I finaly managed to get it working consistantly! I just had to disable the xHCI option in the bios! I don't remember exactly what the setting was, but it had xHCI in it :P. Anyways, now the cable works every time I plug it in! Major thanks to Adeptus Minor for finding this out!
Last edited by alexlf; Oct 22, 2013 @ 8:30pm
< >
Showing 1-15 of 15 comments
Mxxpower Oct 22, 2013 @ 4:19pm 
My cable used to only detect on my usb 2.0 ports, not the 3.0 ones.
alexlf Oct 22, 2013 @ 4:37pm 
Originally posted by Mxxpower:
My cable used to only detect on my usb 2.0 ports, not the 3.0 ones.

Unfortunately my laptop only has USB 3.0 ports, but the USB hub I tried was USB 2.0 and it had the same problem. Thanks for the reply though!
Tieteense Oct 22, 2013 @ 5:04pm 
Mine was detected on both USB 3.0 and 2.0 ports, but it's taking ages to install and in-game tuner shows perfectly tuned string on the PS3 version of Rocksmith as being offset by -200, and oscilating.
Gentleman T-Bone Oct 22, 2013 @ 5:27pm 
I hate to admit it since I really liked Windows 8, but I'm recommending people to be a bit more cautious about the 8.1 update. It seems to have problems with certain drivers and a few machines I've seen with it have become a bit less stable. Be ready to roll back before you install 8.1 just in case.
Mean Mr. Mustard Oct 22, 2013 @ 6:21pm 
It takes me a dozen, somtimes two dozen, attempts to get Windows 8/8.1 to recognize my cable. It will eventually work sometimes when the sun and moons align.

That said my research has found that it may be related to Windows' drivers for certain Intel USB 3.0 chipsets that cause a large number of USB devices to fail. Unfortunately I haven't found a solid work-around for the issue. One site had a tutorial for forcing Windows 8 to use Intel's own Windows 7 drivers. I tried this but it didn't help me out much.

The cable itself works fine on Windows 7, and I'm honestly tempted to just wipe Windows 8 and load Windows 7, it gives a lot fewer headaches.
alexlf Oct 22, 2013 @ 6:49pm 
Thank you very much for the info everyone, it looks like rolling back to 7 may be the way to go for now. A shame really, I was just starting to warm up to windows 8 too.
Last edited by alexlf; Oct 22, 2013 @ 6:50pm
Zolon Oct 22, 2013 @ 8:15pm 
I had HORRIBLE issues with my first Realtone cable (From XBox 360 Guitar Bundle) and my laptop. Windows 8 on ASUS G75V All USB ports are 3.0. Updated my drivers, and did some tweaks. Nothing. I eventually found if I unplugged and plugged it in over and over, eventually it would work.

Fed up with that, I ordered a new cable (Amazon). Also ordered a USB 3.0/2.0 powered Hub. When they arrived, I plugged the new cable into the laptop. It worked. No issues. I can unplug it, plug it into a different port, and .. it works.. It would seem the old cable has issues, and yet the new one just.. works.

Which shows me, you can't blame windows on this one.
alexlf Oct 22, 2013 @ 8:28pm 
Alright, I finaly managed to get it working consistantly! I just had to disable the xHCI option in the bios! I don't remember exactly what the setting was, but it had xHCI in it :P. Anyways, now the cable works every time I plug it in! Major thanks to Adeptus Minor for finding this out!
Adeptus Minor Oct 22, 2013 @ 9:22pm 
Awesome to hear that worked for you, have fun man!
Punk Runnerer Dec 9, 2013 @ 10:40am 
I got it to work by right clicking the sound icon in the bottom left, clicked on "Playback Devices" then went into properties then under levels tab, turned it up to 100. Might have to do it every time though.
CobalticBlue Feb 16, 2014 @ 11:01pm 
I started a new thread for my problem, I should of posted here. Sorry.
I have the same issue with cable and my laptop. Everything worked fine under 8 but cable but get code 10 error under 8.1. My BIOS doesn't have an option to disable xHCI.
However I was able to get it to work if I plug the cable in via a powered hub.
I have found 2 lines of investigation that I will look into
1 - windows 8.1 introduced some additional USB power saving features which a reportedly causing problems for some devices.
2 - my reading suggests that from 8.1 the USB drivers for my chip set are now supplied by Intel rather than Microsoft.
I have seen a few reg tweaks that can be done to disable the power saving features. I will report back if I get it working without the hub.
JPMorgan Jul 15, 2014 @ 7:38am 
Same code 10 error with my asus q550lf laptop. Never got it to work, regardless of which of the 3 usb 3.0 ports I tried. Disabled the xHCI in the bios, now it works every time. Before, I had tried reverifying rocksmith and rocksmith 2014, reinstalled the USB driver, the realtone usb driver, always showed up with the yellow triangle/error. Running windows 8.1, all current updates.

Laptop runs both older and newer rocksmith, handles the cable without issue. Many thanks to the original poster, as rocksmith was one of the main programs I purchased this laptop for!

Last edited by JPMorgan; Jul 15, 2014 @ 7:06pm
Placebo33 Apr 18, 2015 @ 12:20pm 
Hi ! I've got the same problem, but i'm on Windows 7 64bits with an Asus , with this ♥♥♥♥♥♥ xHCI option ! But I can't DISABLE it !!! The Bios let me choose between Smart Auto or Enabled only ! Someone of you can help me ?
Buck Apr 19, 2015 @ 11:04am 
Originally posted by Placebo33:
Hi ! I've got the same problem, but i'm on Windows 7 64bits with an Asus , with this ♥♥♥♥♥♥ xHCI option ! But I can't DISABLE it !!! The Bios let me choose between Smart Auto or Enabled only ! Someone of you can help me ?

necro'ing old threads is frowned upon, but that said -

Your board may or may not even have a USB 3.0 controller/ports.

Either way, even if it does, just use a USB 2.0 port, or get a USB 2.0 powered hub.
Last edited by Buck; Apr 19, 2015 @ 11:04am
Placebo33 May 4, 2015 @ 2:20pm 
I try to solve the problem, not with a powered hub usb 2.0 (i bought it for nothing, sick !)but in updating my bios to latest version. After that, i can disable xHCI and finally play to Rocksmith after a 2 months privation
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Date Posted: Oct 22, 2013 @ 4:13pm
Posts: 15