Salamanderrake Dec 6, 2012 @ 2:08pm
Feature Request: Use the systems mouse icon theme.
Stop having steam modiy the system mouse by using the sysem mouse icon instead of its own.
Showing 1-12 of 12 comments
< >
ʕ•ᴥ•ʔ Dec 6, 2012 @ 2:13pm 
Arch Linux. Gnome 3.6. Latest Steam build, Dec 5 2012. I don't have such a problem.
Salamanderrake Dec 6, 2012 @ 2:21pm 
Sorry I should have posted my system specs, thank you.
Gentoo AMD64
Latest Steam Build Dec 5.
Enlightenment 0.17
I have the reversed mouse icon issue.
Bob The Nob Dec 6, 2012 @ 2:24pm 
Debian Linux, Mate 1.4.2, Steam Build Dec 2; No such issues.
mruuh Dec 6, 2012 @ 3:11pm 
I am seeing the inverted arrow cursor (pointing northeast), which, if I'm not mistaken, is used when some cursor shape is missing. I too would prefer to have my usual cursor, as set by my desktop environment.
Curiously enough, if I hover over an URL or a button, cursor uses correct system shape of a pointing hand.
Last edited by mruuh; Dec 6, 2012 @ 3:11pm
Tele42 Dec 6, 2012 @ 3:31pm 
Gentoo AMD64, same Steam build, default mouse theme for Cinnamon over Gnome 3.4. No problem seen here.
YUMRUK Dec 6, 2012 @ 3:34pm 
Originally posted by mruuh:
I am seeing the inverted arrow cursor (pointing northeast), which, if I'm not mistaken, is used when some cursor shape is missing. I too would prefer to have my usual cursor, as set by my desktop environment.
Curiously enough, if I hover over an URL or a button, cursor uses correct system shape of a pointing hand.

Fix is described here: https://wiki.archlinux.org/index.php/Steam#Mouse_Cursor_Overwritten
simskog95 Dec 7, 2012 @ 9:52am 
I'm using KDE and I had this problem with a strange cursor. but after changing from stock cursor the problem disepeard. Altough the cursor I'm using has animation, and while inside the steam window it never stops moving.
Al@rm Dec 12, 2012 @ 11:16am 
ArchLinux with KDE. I have the same problem.
I think, that it isn't good to change theme or try to fix a problem on the client side.
It will be better, if steam use kde system settings
Thaodan Dec 13, 2012 @ 1:59pm 
Yes very annoying, please fix it.
RussianNeuroMancer Dec 17, 2012 @ 3:11am 
Kubuntu 12.10, same problem.
Zeikcied Dec 18, 2012 @ 1:13pm 
Originally posted by YUMRUK:
Originally posted by mruuh:
I am seeing the inverted arrow cursor (pointing northeast), which, if I'm not mistaken, is used when some cursor shape is missing. I too would prefer to have my usual cursor, as set by my desktop environment.
Curiously enough, if I hover over an URL or a button, cursor uses correct system shape of a pointing hand.

Fix is described here: https://wiki.archlinux.org/index.php/Steam#Mouse_Cursor_Overwritten
That fix seems to only be for GNOME. I found a fix that works for KDE users here: http://www.david-montero.es/?p=145
The Wounded Dec 23, 2012 @ 2:46am 
If you have this issue it seems to be because steam "NEEDS" the pointer with the name arrow, you can prevent this from happening by making a symlink in your mouse cursor theme directory from the main arrow file to a link named arrow and it will not overwrite the main arrow next time you boot your system and start up steam.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50