Steam for Linux

Steam for Linux

MrHanMan Jun 10, 2014 @ 2:27pm
HiDPI Support
I run Linux on my Macbook Pro Retina, and the steam interface is tiny. When will the linux version get HiDPI support?
< >
Showing 1-8 of 8 comments
Dusk of Oolacile Jun 10, 2014 @ 2:29pm 
How did you end up posting this in the linux section?
MrHanMan Jun 10, 2014 @ 2:39pm 
... because it's a Linux question?
Dusk of Oolacile Jun 10, 2014 @ 2:57pm 
Is it? Both the windows and mac versions support it, but the linux cliend does not? Then indeed it is. Forgive my ignorance.
MrHanMan Jun 10, 2014 @ 9:48pm 
Thanks, but I've done that already. HiDPI is working fine in Gnome, but the application also has to support it through GTK. Most apps do, but Steam doesn't. Neither does Chrome, for that matter.
kummo666 Jul 26, 2014 @ 7:57pm 
Hey MrHanMan, I'm trying to get linux working properly on my mbpr, but gnome looks terrible, and I cant find the way to configure it. Would you mind to share information on how to get the scaling to work?
Pocket Aug 5, 2014 @ 11:58pm 
I'm surprised the Windows version supports retina, given that Gaben hates Windows 8 and everything associated with it.
Poupine Aug 6, 2014 @ 8:47am 
Hey

I have recently purchased a 13.3" gaming laptop with a native resolution of 3200x1800. After playing around with xrandr to get an acceptable display, I found the following settings to work best:
Do not specify the size or DPI of your screen in xorg but rather use xrandr --output "Screen" --scale .5x.5 when you launch X (add it to your xinitrc)
The problem with this setup is that games launched from steam seem to dislike the scaling. I found out that with xrandr scaled at .5 and the game set to run at anything higher than 1080p, I could not use the mouse in-game.
My workaround for this is simple: for each game you want to launch, go to the launch properties and c/c:
xrandr --output $screen$ --scale 1x1; %command%; xrandr --output $screen$ --scale .5x.5

where $screen$ is your screen ID as given by xrandr -q. What it does is simple: scale back to 1x1, launch the game, scale to half again when exiting the game.


Now it could be that this works only in my case. However, I'm open to feedback on this solution and if it does indeed work for others, I will most likely write some automation tools to avoid the c/c of the same command over and over again.

Cheers
< >
Showing 1-8 of 8 comments
Per page: 15 30 50