ILikePizza555 2012년 12월 9일 오후 1시 33분
A Little bit of insight to the tf2 black screen problem.
I modified the steam.desktop file to show the terminal for when steam starts up. When you you run a game from steam like this, it will also show the game's console output. So, I start tf2, and I get these error messages:

http://pastebin.com/3PRdLZpN

then, after the traditional valve sound finishes playing, my console gets spammed with errors such as these:

http://pastebin.com/04KcHQuh

To me it looks like shaders are failing to compile. Could this be what's causing the black screens?

I'm using 64-bit Ubuntu 12.10 with 6-GB of RAM, and an i3 processor (no other GPU's).
My glxinfo: http://pastebin.com/qcJNQuX7
The mesa packages I have installed: http://pastebin.com/jAzqnET0
15개 중 1-15 표시중
< >
Sage 2012년 12월 9일 오후 2시 13분 
Try installing ia32-libs. Also your glxinfo makes me jealous :).
play3man 2012년 12월 9일 오후 2시 30분 
I have exactly the same error and yes, shaders fails to compile. But It must fix Valve by support for older intel GPUs... And I'm sad, that it seems that Valve just ignoring us or something... :(
play3man님이 마지막으로 수정; 2012년 12월 9일 오후 2시 30분
ILikePizza555 2012년 12월 9일 오후 9시 42분 
I already have ia32-libs from trying to get my printer drivers to work. If I didn't have them, then tf2 wouldn't even play sounds.

Also, I remember that there was a way to "simulate" some openGL 3.0 features on GPU's that only have support for openGL 2.1. It requires some CPU power though. I wish I knew exactly what it was.
SUSEd 2012년 12월 9일 오후 11시 15분 
Bug with shader compilation failure is fixed. Why it still appears to you?
try
env LANG=C steam
jesaa 2012년 12월 10일 오전 2시 27분 
I have the same error. I started steam with "env LANG=C steam" from the terminal.
jesaa님이 마지막으로 수정; 2012년 12월 10일 오전 2시 27분
cumulus0007 2012년 12월 10일 오전 10시 50분 
The probliem lies in the faulty OpenGL 3 support for somewhat older Intel GPUs, such as the 4500mhd. GLSL 1.3 is required for TF2 to run on Linux, and as glxinfo will tell you, it's stuck at 1.2. The same counts for their Windows drivers, but this isn't a problem on said platform since it runs in DX mode.
cumulus0007님이 마지막으로 수정; 2012년 12월 10일 오전 10시 51분
jesaa 2012년 12월 10일 오후 12시 37분 
So is there any chance for a fix? Maybe an new Driver?
jesaa님이 마지막으로 수정; 2012년 12월 10일 오후 12시 38분
play3man 2012년 12월 10일 오후 1시 11분 
Chance is, but it seems that Valve play with us a game or I don't know... :D

I will buy some games for support and thanks, right then there will be support for older intel GPUs...
play3man님이 마지막으로 수정; 2012년 12월 10일 오후 1시 11분
Refactor 2012년 12월 11일 오후 9시 11분 
I am having the same type of errors on the Intel GMA965 series. Launching TF2 produces a list of OpenGL checks, as follows:

http://pastebin.com/y8QGgMhJ

The Valve video sound plays (on a blank screen), then I don't even know how many thousands of lines of code flash by, all similar to your inital list. Curiously, it pauses about halfway through and shows the following bit:

http://bayimg.com/HahicAaEb

Sorry for the screenshot, I couldn't get the text selected for a copy paste in time. Anywho, at the bottom of the screencap note that it says:

Could not load program cache file glshaders.cfg
Could not find user GL shader cache file

Does this mean I'm missing some component of OpenGL?
ILikePizza555 2012년 12월 13일 오후 5시 28분 
Refactor님이 먼저 게시:
I am having the same type of errors on the Intel GMA965 series. Launching TF2 produces a list of OpenGL checks, as follows:

http://pastebin.com/y8QGgMhJ

The Valve video sound plays (on a blank screen), then I don't even know how many thousands of lines of code flash by, all similar to your inital list. Curiously, it pauses about halfway through and shows the following bit:

http://bayimg.com/HahicAaEb

Sorry for the screenshot, I couldn't get the text selected for a copy paste in time. Anywho, at the bottom of the screencap note that it says:

Could not load program cache file glshaders.cfg
Could not find user GL shader cache file

Does this mean I'm missing some component of OpenGL?

The problem is, as stated before, the shaders are failing to compile because Intel has not provided us with openGL 3.0 and GLSL 1.3. Also, that text in your screen is normal; it's source starting up.
ILikePizza555 2012년 12월 14일 오후 5시 01분 
I think I found a fix. Add this ppa to your software sources, and then update.


sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

and it'll install all the drivers and packages you need; along with the latest linux kernel. Cool.


Edit:
Okay I installed the packages and stuff, but it still hasn't updated the GLSL version. This is my new glxinfo:

http://pastebin.com/UKNfYcyG
ILikePizza555님이 마지막으로 수정; 2012년 12월 14일 오후 5시 19분
piranna 2012년 12월 28일 오후 3시 18분 
Anybody knows what's the Intel drivers mail list to complain them? I have the same problem...
slyon 2012년 12월 29일 오전 6시 52분 
@piranna Several possible ways are listed here:
http://intellinuxgraphics.org/feedback.html
slyon님이 마지막으로 수정; 2012년 12월 29일 오전 6시 53분
piranna 2013년 1월 14일 오전 1시 42분 
slyon님이 먼저 게시:
@piranna Several possible ways are listed here:
http://intellinuxgraphics.org/feedback.html

Thanks, this is the link with the info about how to send bugs:

https://01.org/linuxgraphics/documentation/how-report-bugs-0

We should fill it to them and show that we are a lot of users that have the problem.
ZaPPy 2013년 3월 14일 오후 4시 09분 
ILikePizza555님이 먼저 게시:
I think I found a fix. Add this ppa to your software sources, and then update.


sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

and it'll install all the drivers and packages you need; along with the latest linux kernel. Cool.


Edit:
Okay I installed the packages and stuff, but it still hasn't updated the GLSL version. This is my new glxinfo:

http://pastebin.com/UKNfYcyG
Didn't seem to work when I tried this. Still black screen with sound.
15개 중 1-15 표시중
< >
페이지당: 15 30 50