Steam for Linux > Intel Graphics Cards > Λεπτομέρειες θέματος
The Spectator Engi 9 Δεκ, 2012 @ 1:33μμ
A Little bit of insight to the tf2 black screen problem.
I modified the steam.desktop file to show the terminal for when steam starts up. When you you run a game from steam like this, it will also show the game's console output. So, I start tf2, and I get these error messages:

http://pastebin.com/3PRdLZpN

then, after the traditional valve sound finishes playing, my console gets spammed with errors such as these:

http://pastebin.com/04KcHQuh

To me it looks like shaders are failing to compile. Could this be what's causing the black screens?

I'm using 64-bit Ubuntu 12.10 with 6-GB of RAM, and an i3 processor (no other GPU's).
My glxinfo: http://pastebin.com/qcJNQuX7
The mesa packages I have installed: http://pastebin.com/jAzqnET0
Εμφάνιση 1-15 από 15 σχόλια
< >
8 Dimensional Octagon 9 Δεκ, 2012 @ 2:13μμ 
Try installing ia32-libs. Also your glxinfo makes me jealous :).
play3man 9 Δεκ, 2012 @ 2:30μμ 
I have exactly the same error and yes, shaders fails to compile. But It must fix Valve by support for older intel GPUs... And I'm sad, that it seems that Valve just ignoring us or something... :(
Τελευταία επεξεργασία από play3man; 9 Δεκ, 2012 @ 2:30μμ
The Spectator Engi 9 Δεκ, 2012 @ 9:42μμ 
I already have ia32-libs from trying to get my printer drivers to work. If I didn't have them, then tf2 wouldn't even play sounds.

Also, I remember that there was a way to "simulate" some openGL 3.0 features on GPU's that only have support for openGL 2.1. It requires some CPU power though. I wish I knew exactly what it was.
SUSEd 9 Δεκ, 2012 @ 11:15μμ 
Bug with shader compilation failure is fixed. Why it still appears to you?
try
env LANG=C steam
jesaa 10 Δεκ, 2012 @ 2:27πμ 
I have the same error. I started steam with "env LANG=C steam" from the terminal.
Τελευταία επεξεργασία από jesaa; 10 Δεκ, 2012 @ 2:27πμ
cumulus0007 10 Δεκ, 2012 @ 10:50πμ 
The probliem lies in the faulty OpenGL 3 support for somewhat older Intel GPUs, such as the 4500mhd. GLSL 1.3 is required for TF2 to run on Linux, and as glxinfo will tell you, it's stuck at 1.2. The same counts for their Windows drivers, but this isn't a problem on said platform since it runs in DX mode.
Τελευταία επεξεργασία από cumulus0007; 10 Δεκ, 2012 @ 10:51πμ
jesaa 10 Δεκ, 2012 @ 12:37μμ 
So is there any chance for a fix? Maybe an new Driver?
Τελευταία επεξεργασία από jesaa; 10 Δεκ, 2012 @ 12:38μμ
play3man 10 Δεκ, 2012 @ 1:11μμ 
Chance is, but it seems that Valve play with us a game or I don't know... :D

I will buy some games for support and thanks, right then there will be support for older intel GPUs...
Τελευταία επεξεργασία από play3man; 10 Δεκ, 2012 @ 1:11μμ
Refactor 11 Δεκ, 2012 @ 9:11μμ 
I am having the same type of errors on the Intel GMA965 series. Launching TF2 produces a list of OpenGL checks, as follows:

http://pastebin.com/y8QGgMhJ

The Valve video sound plays (on a blank screen), then I don't even know how many thousands of lines of code flash by, all similar to your inital list. Curiously, it pauses about halfway through and shows the following bit:

http://bayimg.com/HahicAaEb

Sorry for the screenshot, I couldn't get the text selected for a copy paste in time. Anywho, at the bottom of the screencap note that it says:

Could not load program cache file glshaders.cfg
Could not find user GL shader cache file

Does this mean I'm missing some component of OpenGL?
The Spectator Engi 13 Δεκ, 2012 @ 5:28μμ 
Αναρτήθηκε αρχικά από Refactor:
I am having the same type of errors on the Intel GMA965 series. Launching TF2 produces a list of OpenGL checks, as follows:

http://pastebin.com/y8QGgMhJ

The Valve video sound plays (on a blank screen), then I don't even know how many thousands of lines of code flash by, all similar to your inital list. Curiously, it pauses about halfway through and shows the following bit:

http://bayimg.com/HahicAaEb

Sorry for the screenshot, I couldn't get the text selected for a copy paste in time. Anywho, at the bottom of the screencap note that it says:

Could not load program cache file glshaders.cfg
Could not find user GL shader cache file

Does this mean I'm missing some component of OpenGL?

The problem is, as stated before, the shaders are failing to compile because Intel has not provided us with openGL 3.0 and GLSL 1.3. Also, that text in your screen is normal; it's source starting up.
The Spectator Engi 14 Δεκ, 2012 @ 5:01μμ 
I think I found a fix. Add this ppa to your software sources, and then update.


sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

and it'll install all the drivers and packages you need; along with the latest linux kernel. Cool.


Edit:
Okay I installed the packages and stuff, but it still hasn't updated the GLSL version. This is my new glxinfo:

http://pastebin.com/UKNfYcyG
Τελευταία επεξεργασία από The Spectator Engi; 14 Δεκ, 2012 @ 5:19μμ
piranna 28 Δεκ, 2012 @ 3:18μμ 
Anybody knows what's the Intel drivers mail list to complain them? I have the same problem...
slyon 29 Δεκ, 2012 @ 6:52πμ 
@piranna Several possible ways are listed here:
http://intellinuxgraphics.org/feedback.html
Τελευταία επεξεργασία από slyon; 29 Δεκ, 2012 @ 6:53πμ
piranna 14 Ιαν, 2013 @ 1:42πμ 
Αναρτήθηκε αρχικά από slyon:
@piranna Several possible ways are listed here:
http://intellinuxgraphics.org/feedback.html

Thanks, this is the link with the info about how to send bugs:

https://01.org/linuxgraphics/documentation/how-report-bugs-0

We should fill it to them and show that we are a lot of users that have the problem.
ZaPPy 14 Μαρ, 2013 @ 4:09μμ 
Αναρτήθηκε αρχικά από ILikePizza555:
I think I found a fix. Add this ppa to your software sources, and then update.


sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

and it'll install all the drivers and packages you need; along with the latest linux kernel. Cool.


Edit:
Okay I installed the packages and stuff, but it still hasn't updated the GLSL version. This is my new glxinfo:

http://pastebin.com/UKNfYcyG
Didn't seem to work when I tried this. Still black screen with sound.
Εμφάνιση 1-15 από 15 σχόλια
< >
Ανά σελίδα: 15 30 50