Steam for Linux > Intel Graphics Cards > รายละเอียดกระทู้
Redsandro 6 ธ.ค. 2012 @ 7:57pm
Issue Report: Cogs (supported game) at 1 FPS
Intel HD 4000 here.

I don't have many Linux supported games, but Cogs is one of the supported 3d ones.
However, it 'runs' (read: lags like crazy) at approximately 1 FPS, although I can play everything and crazier (Doom 3) on this HD 4000 fine (in Windows).

I am running Linux Mint 14 Cinnamon (Ubuntu 12.10), and I already got the packages that are mentioned here and there:

libgl1-mesa-glx is already the newest version.
libgl1-mesa-glx:i386 is already the newest version.
libgl1-mesa-dri is already the newest version.
libgl1-mesa-dri:i386 is already the newest version.
libgl1-mesa-dri:i386 set to manually installed.

Note that after the installation of steam.deb, but before updating, Steam Client pops up a weird window with a transparent body and in the middle a request to enter your password for installing some kind of required package. Any kind of weird popup that is different from expected password dialogs (e.g. gdebi) is what we all learn through knowledge and pain something that should never be acknowledged. So I answered cancel. I don't know what I cancelled, and I don't know if I already have that or how do fix that manually.
ได้รับการแก้ไขครั้งสุดท้ายโดย Redsandro; 14 ธ.ค. 2012 @ 1:51pm
กำลังแสดง 1-10 จาก 10 ความเห็น
< >
Redsandro 6 ธ.ค. 2012 @ 8:06pm 
Darwinia goes supersmooth. Maybe an issue after all, with Cogs engine together with Intel HD graphics?
play3man 6 ธ.ค. 2012 @ 10:34pm 
I had cogs for a while and it was really too slow. I have Intel GMA 4500M
kekstee 7 ธ.ค. 2012 @ 3:24am 
It is a problem between the engine and mesa. Not new either, I ran into this with the humble bundle release. This topic in their official forums has some more information:

http://forum.lazy8studios.com/index.php?topic=532.0

tl;dr: mesa should fix it vs game devs should fix it
maybe the mesa patches/workarounds still work
Redsandro 8 ธ.ค. 2012 @ 5:45pm 
Thanks for the hint!

This is a weird issue, devs on both sides can't agree who to blame. Windows version on wine runs fine. I'm not planning on manually patching drivers for a single game though. :)
Oktoras 8 ธ.ค. 2012 @ 10:57pm 
I have Fedora 18 beta, Intel HD graphics on Sandy Bridge. Cogs works with playable framerate, but it is not completely smooth.
kigucdoshu 9 ธ.ค. 2012 @ 12:47am 
I had to disable shadows, then it ran smoothly on my HD4000.
kirrun 9 ธ.ค. 2012 @ 1:09am 
โพสต์ดั้งเดิมโดย kekstee:
http://forum.lazy8studios.com/index.php?topic=532.0

Huh, that's funny. Seems that we are not going to play Cogs on Linux =(. On my Acert 4810TG (with Intel video activated) it's just completely unplayable.
Refactor 11 ธ.ค. 2012 @ 9:16pm 
Having the same problem, Ubuntu 12.04 & Intel GMA965. It's playable, but ain't no way I'm gonna win those time challenge stars!
Redsandro 14 ธ.ค. 2012 @ 1:50pm 
Only someone big like Valve has the power and the knowledge to point a finger and place blame or request a fix or fix this themselves.

Hence I dub this an issue report.
cai 25 ก.ย. 2013 @ 8:48am 
i have the same problem. game devs must fix it.
กำลังแสดง 1-10 จาก 10 ความเห็น
< >
ต่อหน้า: 15 30 50