play3man 6 dec, 2012 @ 1:14pm
FIXED - Issue Report: Black Screen in TF2 and "What Valve's people think about this issue?"
This issue has been solved with patch to mesa drivers from Chris Forbes - Thank you!

So if you want play Source games on your Intel GPU simply add this ppa to your software source:

https://launchpad.net/~xorg-edgers/+archive/ppa

Original post:

INTEL HD IRONLAKE (2010), INTEL GMA4500M(HD) AND LESS
----------------------------------------------------------------------------------------------------------------
Team Fortress 2. Black Screen. Intel GPU = Problem isn't in Steam, Source Engine or in the game, problem is your hardware. This is, i think, the most common answer I read on this forum. But I didn't find at least one regular answer from someone from Valve Linux Team. So I will be glad, when I will see here finally one good view of point from some Valve Team guy on this problem! :)

So, I can run this game on Windows 7 pretty well. I tried (within the realms of possibility) everything and I still have Black Screen. Yes, this problem is (propably) in drivers, but it will be fixed? Who can fix it? Canonical? Intel? Or "You"? Thanks for the answer and I'm sorry, if it sounded cheeky... :) :D

My system info - http://pastebin.com/u1vzjBUa
Error log - http://pastebin.com/uY2jhhWC
Video - http://www.youtube.com/watch?feature=player_embedded&v=iv-AsGiO3lU

This is duplicate of - http://steamcommunity.com/app/221410/discussions/1/846938351013172007/
---------------------------------------------------

Valve! Propably the real problem is in OpenGL version, but isn't any way to run Source Engine games on older versions of OpenGL? TF2 works on Windows only with DirectX 8, why on Linux is need at least OpenGL 3.0? I'll be thankfull when you look at this problem.. Thanks!

---------------------------------------------------

Latest answer

Ursprungligen skrivet av Frank:
I've looked at the threads mentioned and discussed this with several members of the team.
These reports are mainly (if not completely) related to Intel and AMD graphics cards and their associated drivers. This means that AMD and Intel are the best people for fixing these issues. AMD has indicated that they are interested in addressing these issues by opening a public forum[devgurus.amd.com] where their customers can discuss these issues. Intel also has forums where issues can be reported.
As for NVidia, I would say it's very likely that the recent work done by their driver developers is the reason NVidia-related issue reports have not been as high. One note with NVidia - there are Optimus issues that we are currently investigating. We hope to have a fix (or fixes) in the near future.
We wish we had a better answer for AMD and Intel card owners but this is the best we can do from our side.
Senast ändrad av play3man; 19 maj, 2013 @ 8:35am
Visar 1-15 av 104 kommentarer
< >
Yulike 6 dec, 2012 @ 1:28pm 
I have the same problem as you on my other laptop. It's the original Intel HD Graphics (Just above your GMA4500) and have tried everything. All Valve games work with this Chipset under Windows 7. So I would love to see this issue resolved.
ZeXx86 6 dec, 2012 @ 1:37pm 
I am not sure, but why your sound volume changed during start? For intel graphics card it could be a problem when something appear on the screen with composite manager and it could "steal" opengl accelerated context of the game. Could you test it under for example Gnome Classic (No Effects)? You can easily install it (gnome-shell package I guess) and switch to this one in Login screen.

You can also try to start Steam with this command: LC_NUMERIC="POSIX" steam
Senast ändrad av ZeXx86; 6 dec, 2012 @ 1:38pm
play3man 6 dec, 2012 @ 1:57pm 
Ursprungligen skrivet av ZeXx86:
I am not sure, but why your sound volume changed during start? For intel graphics card it could be a problem when something appear on the screen with composite manager and it could "steal" opengl accelerated context of the game. Could you test it under for example Gnome Classic (No Effects)? You can easily install it (gnome-shell package I guess) and switch to this one in Login screen.

You can also try to start Steam with this command: LC_NUMERIC="POSIX" steam

Gnome Classic - I will try

That command doesn't work
ZeXx86 6 dec, 2012 @ 2:15pm 
It should work, be sure you copied it exactly, it is also case sensitive.
play3man 6 dec, 2012 @ 2:33pm 
Ursprungligen skrivet av ZeXx86:
It should work, be sure you copied it exactly, it is also case sensitive.

Sorry, I mean didn't help :D My bad...
Senast ändrad av play3man; 6 dec, 2012 @ 2:40pm
play3man 6 dec, 2012 @ 2:59pm 
With Gnome Classic still black screen
Yulike 6 dec, 2012 @ 3:26pm 
I don't think our particular graphics chips support OpenGL 3, guess we'll have to hope for OpenGL 2.1 support... Unlikely.
Letalis Sonus 6 dec, 2012 @ 3:55pm 
Full OpenGL 3.0 support isn't needed for TF2, if it is lacking an OpenGL extension it will tell you that with a message dialog.
Yulike 6 dec, 2012 @ 5:29pm 
Then I'm clueless, I've had an extension error before but resolved that with an update. Any other ideas?
play3man 6 dec, 2012 @ 10:24pm 
Ursprungligen skrivet av /home/CJ UK:
Then I'm clueless, I've had an extension error before but resolved that with an update. Any other ideas?

My GPU support only <2.1

I really hope that Valve will tell us if OpenGL is the real reason of black screen and when yes, if it's there any hope to be added support for older OpenGL to Source Engine...
remm 7 dec, 2012 @ 2:25am 
I'd say only sandy and ivy are supported at the moment (and probably will ever be supported). All the others are probably going to be too slow anyway ...

It does say when an extension is missing (like S3TC for me, it's just been added in mesa I think).
Senast ändrad av remm; 7 dec, 2012 @ 2:27am
Letalis Sonus 7 dec, 2012 @ 4:07am 
Ursprungligen skrivet av remm:
(like S3TC for me, it's just been added in mesa I think).
S3TC support needs an external library. Previously Mesa used a proper S3TC implementation, for people that want to simply ignoe the patent issues. That recent addition is another library with a slightly different algorithm that is supposed to not have those patent issues, they call it S2TC.
piranna 7 dec, 2012 @ 4:13am 
As far as I know from the "open" forums and some tests I did there (hi @play3man ;-) ) it seems is a problem related with the drivers (at least for my Intel integrated 4 series) since they only support OpenGL Shading Language 1.20 and Team Fortress 2 requires 1.30.

Solutions? Valve rewrite the shaders for OGSL 1.20, or we fill the Intel driver mailing list with messages requesting support for OGDL 1.30, just that.
play3man 7 dec, 2012 @ 4:23am 
Ursprungligen skrivet av piranna:
As far as I know from the "open" forums and some tests I did there (hi @play3man ;-) ) it seems is a problem related with the drivers (at least for my Intel integrated 4 series) since they only support OpenGL Shading Language 1.20 and Team Fortress 2 requires 1.30.

Solutions? Valve rewrite the shaders for OGSL 1.20, or we fill the Intel driver mailing list with messages requesting support for OGDL 1.30, just that.

Ok, but I will appreciate when Valve will help us with that. (When they're trying, I'm so glad, but I want to know about that... for our calm..)
Senast ändrad av play3man; 7 dec, 2012 @ 4:25am
=WPI= BZab[PL] 7 dec, 2012 @ 7:33am 
http://i48.tinypic.com/28a55jq.png
HD series too here ;) 12.04LTS
Visar 1-15 av 104 kommentarer
< >
Per sida: 15 30 50