DarkKnightCZ May 10, 2013 @ 4:26pm
HL2 EP1 is too dark
hi, after installing HL2:EP1 onto lenovo with hybrid graphic card (intel HD3000 + nvidia G610m), game runs fine, but everything is dark (i suspect problem with shader)

console log
Error: Material "___fillrate_0" uses unknown shader "FillRate"
Error: Material "___debugnormalmap_1" uses unknown shader "DebugNormalMap"
Error: Material "___debugdrawenvmapmask_2" uses unknown shader "DebugDrawEnvmapMask"
Error: Material "___debugdepth_3" uses unknown shader "DebugDepth"
Error: Material "___debugdepth_4" uses unknown shader "DebugDepth"
Error: Material "debug/debugluxels" uses unknown shader "DebugLuxels"
Error: Material "models/humans/female/pupil_r" uses unknown shader "Eyeball"
Error: Material "models/humans/female/pupil_l" uses unknown shader "Eyeball"

i tried optimus, but it fails to start

screenshots
ingame[imageshack.us]
video config[imageshack.us]
brightness level[imageshack.us] (there is likely the problem => font is dark)



system
Debian 3.8.5-1~experimental.1 x86_64 GNU/Linux

OpenGL version string: 3.0 Mesa 8.0.5
OpenGL shading language version string: 1.30
OpenGL extensions:
GL_ARB_multisample, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_copy_texture,
GL_EXT_polygon_offset, GL_EXT_subtexture, GL_EXT_texture_object,
GL_EXT_vertex_array, GL_EXT_compiled_vertex_array, GL_EXT_texture,
GL_EXT_texture3D, GL_IBM_rasterpos_clip, GL_ARB_point_parameters,
GL_EXT_draw_range_elements, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_separate_specular_color,
GL_EXT_texture_edge_clamp, GL_SGIS_generate_mipmap,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod, GL_ARB_framebuffer_sRGB, GL_ARB_multitexture,
GL_EXT_framebuffer_sRGB, GL_IBM_multimode_draw_arrays,
GL_IBM_texture_mirrored_repeat, GL_3DFX_texture_compression_FXT1,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add, GL_ARB_transpose_matrix,
GL_EXT_blend_func_separate, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_secondary_color, GL_EXT_texture_env_add,
GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
GL_INGR_blend_func_separate, GL_NV_blend_square, GL_NV_light_max_exponent,
GL_NV_texgen_reflection, GL_NV_texture_env_combine4, GL_S3_s3tc,
GL_SUN_multi_draw_arrays, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_EXT_framebuffer_object,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_MESA_window_pos, GL_NV_packed_depth_stencil,
GL_NV_texture_rectangle, GL_NV_vertex_program, GL_ARB_depth_texture,
GL_ARB_occlusion_query, GL_ARB_shadow, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_window_pos, GL_ATI_envmap_bumpmap,
GL_EXT_stencil_two_side, GL_EXT_texture_cube_map, GL_NV_depth_clamp,
GL_NV_vertex_program1_1, GL_APPLE_packed_pixels,
GL_APPLE_vertex_array_object, GL_ARB_draw_buffers,
GL_ARB_fragment_program, GL_ARB_fragment_shader, GL_ARB_shader_objects,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ATI_draw_buffers,
GL_ATI_texture_env_combine3, GL_ATI_texture_float, GL_EXT_shadow_funcs,
GL_EXT_stencil_wrap, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
GL_ARB_depth_clamp, GL_ARB_fragment_program_shadow,
GL_ARB_half_float_pixel, GL_ARB_point_sprite, GL_ARB_shading_language_100,
GL_ARB_sync, GL_ARB_texture_non_power_of_two, GL_ARB_vertex_buffer_object,
GL_ATI_blend_equation_separate, GL_EXT_blend_equation_separate,
GL_OES_read_format, GL_ARB_color_buffer_float, GL_ARB_pixel_buffer_object,
GL_ARB_texture_compression_rgtc, GL_ARB_texture_float,
GL_ARB_texture_rectangle, GL_EXT_packed_float, GL_EXT_pixel_buffer_object,
GL_EXT_texture_compression_dxt1, GL_EXT_texture_compression_rgtc,
GL_EXT_texture_rectangle, GL_EXT_texture_sRGB,
GL_EXT_texture_shared_exponent, GL_ARB_framebuffer_object,
GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample,
GL_EXT_packed_depth_stencil, GL_APPLE_object_purgeable,
GL_ARB_vertex_array_object, GL_ATI_separate_stencil, GL_EXT_draw_buffers2,
GL_EXT_gpu_program_parameters, GL_EXT_texture_array,
GL_EXT_texture_integer, GL_EXT_texture_sRGB_decode, GL_EXT_timer_query,
GL_OES_EGL_image, GL_MESA_texture_array, GL_ARB_copy_buffer,
GL_ARB_depth_buffer_float, GL_ARB_half_float_vertex,
GL_ARB_map_buffer_range, GL_ARB_texture_rg, GL_ARB_texture_swizzle,
GL_ARB_vertex_array_bgra, GL_EXT_separate_shader_objects,
GL_EXT_texture_swizzle, GL_EXT_vertex_array_bgra,
GL_NV_conditional_render, GL_ARB_ES2_compatibility,
GL_ARB_draw_elements_base_vertex, GL_ARB_explicit_attrib_location,
GL_ARB_fragment_coord_conventions, GL_ARB_provoking_vertex,
GL_ARB_sampler_objects, GL_ARB_seamless_cube_map,
GL_ARB_shader_texture_lod, GL_EXT_provoking_vertex, GL_EXT_texture_snorm,
GL_MESA_texture_signed_rgba, GL_ARB_robustness, GL_EXT_transform_feedback



anyone has an idea, what can i try? :) thanks
Last edited by DarkKnightCZ; May 10, 2013 @ 4:27pm
Showing 1-15 of 15 comments
< >
JobDestroyer May 10, 2013 @ 5:10pm 
Same problem with Portal, Half-Life 2, and assumedly others.

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

RussianNeuroMancer May 10, 2013 @ 10:45pm 
> Mesa 8.0.5
Too old. You need Mesa 9 that available in latest Ubuntu/Kubuntu, openSUSE, Fedora, etc.
Debian stable is not best choice for gaming on FOSS drivers.
DarkKnightCZ May 11, 2013 @ 2:26am 
well, even debian experimental has mesa 8, but i will try to compile latest mesa, thanks
MachinaeWolf Jul 16, 2013 @ 1:34pm 
Yeah I'm out of luck on debian (debian testing) with the same issue :/ I would try to compile the latest mesa but I have issues with the 3.9 and beyond (if I try to change the brightness it does but it's delayed/laggy and the fn + volume keys aren't working at all) I don't have that issue on the 3.2.0-4-amd64 kernel though.

Edit: found out I had to add asus_nb_wmi to the /etc/modules and then it works fine, time to try building that mesa :)

Edit2: updated my libgl1-mesa-glx and libgl1-mesa-dri and problems are solved :)
Last edited by MachinaeWolf; Jul 17, 2013 @ 2:02pm
akveth Sep 23, 2013 @ 8:46pm 
Same problem in Linux Mint 13 LTS.... So do I need to manually complie the lastest Mesa version? :S
Kroneg Jan 11 @ 6:06am 
Sorry to necro a thread, but I have the same problem with Linux Mint 16, checked Mesa and it's version 9.2.1. Would love to get this fixed - Steam support is the final cord to cut me off Win/MS.
fedaykin Jan 18 @ 10:14am 
I am having the same problem on Linux Mint 16 amd64 on a Lenovo Edge E430 (Intel i5-3210M with the Intel HD4000 video adapter).
miyamotodan Jan 29 @ 2:22pm 
Same problem intel i7 - HD4600 Adapter
Linux Mint 16
Last edited by miyamotodan; Jan 29 @ 2:23pm
akveth Feb 26 @ 9:12pm 
I solved it by changing from Linux Mint to Elementary OS...
miyamotodan Mar 14 @ 3:32pm 
I solved it by changing from linux mint to Linux Ubuntu
sllvershadow Mar 15 @ 7:22am 
This is how you can fix the problem on Linux Mint:
sudo apt-get install driconf
Start the program and enable 'S3TC texture compression'
Last edited by sllvershadow; Mar 15 @ 7:25am
akveth Apr 28 @ 10:21am 
Originally posted by sllvershadow:
This is how you can fix the problem on Linux Mint:
sudo apt-get install driconf
Start the program and enable 'S3TC texture compression'
I actually tried to do that, but does not work me.
Last edited by akveth; Apr 28 @ 10:21am
Atheror Jun 11 @ 2:22pm 
Originally posted by sllvershadow:
This is how you can fix the problem on Linux Mint:
sudo apt-get install driconf
Start the program and enable 'S3TC texture compression'
Al fin una solución!!!!

Muchas gracias... No cambiaría a Mint sólo por eso como hicieron más arriba.
thewalkingdead™ Jul 3 @ 6:59am 
im having the same problem but in windows 7 help me
kevbob Sep 10 @ 9:57pm 
Originally posted by sllvershadow:
This is how you can fix the problem on Linux Mint:
sudo apt-get install driconf
Start the program and enable 'S3TC texture compression'
This worked for me on Linux Mint 17 (and intel graphics driver installed from 01.org)

Thank you so much. I'm off to waste 10 hours playing through portal!
Showing 1-15 of 15 comments
< >
Per page: 15 30 50