Steam for Linux

Steam for Linux

Daifuco Aug 13, 2013 @ 9:45am
Im getting quite a bit of input lag with nvidia
I have a new laptop with optimus (as I read on this forum forum, the worst idea in gaming hardware since the Sega 32X).
I installed ubuntu 13.04, bumblebee 3.2.1 and the nvidia drivers 325.15(from a non stable ppa).

I can run the games either with the intel harddare or the nvidia 740m. THe problem is that when I use the nvidia I notice an input lag, it is not a massive input lag, but it is quite obvious and annoying when playing games. Specially platformers and 3d shoters.

Is there any reason why this happens? It is not a massive input lag, but it IS there. And when I use the intel HD4000 the graphics are obviously worse but the input lag is gone.

please help. I just dumped my windows partition and now I am beginning to regret it.
< >
Showing 1-4 of 4 comments
R3450N Aug 13, 2013 @ 10:11am 
It's because you are using the latest Nvidia drivers from a non-stable PPA. What else do you expect? Clearly the input lag is related to your Nvidia driver because your intel card is not experiencing the same issue. I highly recommend installing the nvidia drivers that are bundled with Bumblebee because they are tested and are thus stable.

Have you checked the bumblebee.conf file and ensured it's using your driver rather than its own? Use
gksudo gedit [path/to/*.conf]
gutigen o) Aug 14, 2013 @ 9:02am 
Have you turned off VSYNC in both Nvidia Settings and in game?
Daifuco Aug 18, 2013 @ 4:35am 
well, because I have to use bumblebee I dont have an easy access to the nvidia settings, is there any option I can put when running the games to force the vsync?
Daifuco Aug 22, 2013 @ 1:34pm 
gutigen you were right, the problem was related to the vsync. with primus by default it is on. If I add vblank_mode=0 optirun -b primus %command% to the game option it runs well.

Mystery solved!
< >
Showing 1-4 of 4 comments
Per page: 15 30 50