Berserker......... Aug 11, 2013 @ 7:31am
hi...I need little help for Bumblebee...what wrong I did please help...thax in advance
I am new to Linux , Nvidia driver version 325.15
I have installed Bumblebee using following commands asunder

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update && sudo apt-get install bumblebee virtualgl linux-headers-`uname -r` mesa-utils

sudo su -c "useradd -G bumblebee USERNAME"

edit bumblee configuration file using command

sudo nano /etc/bumblebee/bumblebee.conf


## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver=nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-325
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-325:/usr/lib32/nvidia-325
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-325/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia


and configure the Nvidia Xorg settings asunder

Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "true"
Option "AutoAddGPU" "false"
EndSection
Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "ProbeAllGpus" "false"
BusID "PCI:01:00:0"
Option "NoLogo" "false"
Option "UseEDID" "true"
Option "UseDisplayDevice" "none"
Option "ConnectedMonitor" "DFP"
EndSection




Showing 1-8 of 8 comments
< >
Apocryphus Aug 11, 2013 @ 7:39am 
So... what's the problem?
Berserker......... Aug 11, 2013 @ 7:49am 
optirun -vvv glxspheres
[ 3785.003780] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 3785.004194] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 3785.004205] [DEBUG]Socket closed.
[ 3785.004217] [ERROR]Could not connect to bumblebee daemon - is it running?
Berserker......... Aug 11, 2013 @ 7:50am 
it not starting
Apocryphus Aug 11, 2013 @ 8:02am 
How did you install the Nvidia drivers?
Berserker......... Aug 11, 2013 @ 8:08am 
download run file from nvidia site
ctrl+alt+F1
i learned how install driver :)
Last edited by Berserker.........; Aug 11, 2013 @ 8:09am
Apocryphus Aug 11, 2013 @ 8:31am 
Originally posted by ashish_m:
download run file from nvidia site
ctrl+alt+F1
i learned how install driver :)

From this raw analysis of your problem, I think it's the latest Nvidia drivers that are causing your problem in Bumblebee. I recommend purging Bumblebee along with all its dependencies off your computer and starting over. You don't have to install all those dependencies because they are done for you. Also, it's advised that you install the drivers supplied by Bumblebee for testing purposes. Have you tried installing 'bumblebee-nvidia'? Run
optirun glxspheres
and see if that solved the problem.

One thing to take into account is that you shouldn't install the latest Nvidia drivers unless you know what you're doing. Bumblebee is enough to do the job for you. I suggest doing a clean installation and follow a clear set of instructions.
Berserker......... Aug 11, 2013 @ 8:41am 
thax for ur reply

i tried bumblebee -nvidia ...but it installing old nvidia driver
sudo apt-get install bumblebee bumblebee-nvidia

The following NEW packages will be installed:
bumblebee-nvidia nvidia-304 nvidia-current nvidia-settings-304


please can you post command for latest bumblebee-nvidia driver
Last edited by Berserker.........; Aug 11, 2013 @ 8:42am
Apocryphus Aug 11, 2013 @ 9:01am 
Originally posted by ashish_m:
thax for ur reply

i tried bumblebee -nvidia ...but nvidia is old
sudo apt-get install bumblebee bumblebee-nvidia

The following NEW packages will be installed:
bumblebee-nvidia nvidia-304 nvidia-current nvidia-settings-304


please can you post command for latest bumblebee-nvidia driver

That's the whole point; the Nvidia drivers you installed aren't really stable because they were released only this month. I highly suggest removing the latest driver and installing the 304 drivers which Bumblebee recommends. The best solution is for you to uninstall the latest Nvidia drivers and install the 304 nvidia drivers. This also involves changing the bumblebee.conf file.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50