mhin kie Feb 16, 2013 @ 12:08pm
TF2 - optimus: optirun works, primusrun doesn't
Hi,

I'm trying to get TF2 running on my Samsung NP550P5C (Nvidia GT 650 M). I have installed bumblebee and I'm using the experimental-310 drivers. Glxspheres works fine with optirun and primusrun, but tf2 only works with optirun.
I'm starting TF2 (with optirun) using this script:
#!/bin/bash
# hl2.sh modified for TF2 and optirun
# http://steamcommunity.com/groups/LinuxOptimus

GAMEROOT=$(cd "${0%/*}" && echo $PWD)
STEAMPATH=$(readlink ~/.steampath)
export LD_LIBRARY_PATH="${GAMEROOT}"/bin:$LD_LIBRARY_PATH
if [ ! -z ${STEAMPATH} ]; then
export LD_LIBRARY_PATH="$(dirname ${STEAMPATH})":$LD_LIBRARY_PATH
fi
ulimit -n 2048
export __GL_THREADED_OPTIMIZATIONS=1
cd "$GAMEROOT"
if [ ! -f steam_appid.txt ]; then
echo "440" > steam_appid.txt
fi
LD_LIBRARY_PATH=~/Steam/ubuntu12_32:$LD_LIBRARY_PATH optirun ./hl2_linux -game tf -steam "$@"

I tried using the same script and changing the last line to use primusrun instead of optirun, but TF2 fails with this error:
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'...
Terminal-Output:
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system DOES NOT support the OpenGL extension GL_ARB_sync.
This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I hope you can help me solve my Problem...
Thanks in advance,
Alex

Edit: I'm running Ubuntu 12.04 64bit
Last edited by mhin kie; Feb 16, 2013 @ 12:11pm
Showing 1-1 of 1 comments
< >
mhin kie Feb 16, 2013 @ 4:04pm 
OK, after purging and reinstalling primus, and adjusting the primusrun script TF2 starts now, but crashes after selecting a class. I disabled multicore rendering (because I read somewhere, that this helps), and it worked. I'm now having ~10 fps more with primus and multicore rendering disabled, than with optirun and multicore rendering enabled.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50