handuel 2013 年 01 月 30 日 @ 上午 10 時 42 分
[TF2] Could not find required OpenGL entry point 'glColorMaskIndexedEXT'| Either your video card is unsupported, or your OpenGL driver needs to be updated
I get this error when trying to play TF2, my graphics card is the nvidia GeForce 6150SE, and I am running the 304 version of the driver. Can I fix this?
顯示 1-14,共 14 則回應
< >
handuel 2013 年 01 月 30 日 @ 上午 10 時 46 分 
Update, I get this when running from terminal:
Game update: AppID 520 "Team Fortress 2 Beta", ProcID 5487, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
zeekyboogydoog 2013 年 02 月 1 日 @ 下午 5 時 29 分 
I believe you'll want to install the 310 driver.
TheFreeCandyGiver 2013 年 02 月 20 日 @ 下午 1 時 20 分 
I have the same exact problem.
TheFreeCandyGiver 2013 年 02 月 20 日 @ 下午 1 時 21 分 
I also have the same graphics card.
sirmonkey-BLUR 2013 年 02 月 20 日 @ 下午 5 時 22 分 
same problem, kubuntu (installed today) and ati amd 6950 ... am running amd64 x86_64 system
TheFreeCandyGiver 2013 年 02 月 20 日 @ 下午 5 時 50 分 
Type into the ubuntu sowftware center "Nvidia-e" if you have an invidia graphics card.
Install Experimental driver 310 if your are on 64 bit OS
Install Experimental driver 310 i386 if your on 32 bit OS
Then type into the search "drviers"
You will need your root password to chenge to the experimental driver
Restart computer then tf2 should open.
Kano 2013 年 02 月 22 日 @ 上午 9 時 15 分 
310 driver would not work with his gfx card/onboard solution. But some seemed to get it running with a hack.
handuel 2013 年 03 月 5 日 @ 下午 1 時 16 分 
Kano 發表:
310 driver would not work with his gfx card/onboard solution. But some seemed to get it running with a hack.
Yeah, that's why I've not installed it, as I know other people with my setup who couldn't get it to work. What's this hack you speak of?
Fibbles 2013 年 03 月 17 日 @ 上午 10 時 05 分 
I posted this to the big glColorMaskIndexedEXT thread in General a couple of weeks ago. I can't be bothered to go find the thread so I'm reposting the solution here. It should allow you to play Source games on nVidia 6xxx and 7xxx series cards.

---------------------------------------

I've gone through all of the different threads here and compiled all the tips into a short walk-through. Big thanks to RunningRiot, cientista, TipoDaMascara and Dafydd.

If you're running a 64bit distro you'll need the package libc6-dev-i386 installed. If you're using Mint, Ubuntu or one of its derivatives that's as simple as pasting the following into the terminal:
sudo apt-get install libc6-dev-i386

Now paste the following into the terminal. It will download 2 files onto your computer and then compile one of them.
wget http://dl.dropbox.com/s/5h8n4ivfbgq98bl/strstr.c && gcc -fPIC -DPIC -O2 -m32 -c strstr.c && ld -m elf_i386 -shared -o strstr.so strstr.o && mkdir ~/bin && cd bin/ && wget http://dl.dropbox.com/s/t7rlsvp26h50vro/hl2debug && chmod +x ~/bin/hl2debug

Now paste the following into the terminal. It will open your .profile in a simple text editor. If you're using something other than Ubuntu, replace 'gedit' with the name of your text editor. For example on Xubuntu this would be 'leafpad'.
cd $home && gedit .profile

Paste these 2 lines at the bottom of the file. Save it, then close the editor.
export PATH=$HOME/bin:$PATH
export GAME_DEBUGGER="hl2debug"

Log out of your current session and then log back in to load everything up.

Start steam through the terminal using the following command:
steam

I've tested this with CS:S and TF2, both work. It has been recommended elsewhere on the Steam forums to run the games with the -novid and -nojoy flags. The games also default to the highest graphics settings when first run. You'll probably want to turn those down if you're on an old card.

Happy gaming :)
czukcza 2013 年 07 月 22 日 @ 上午 11 時 41 分 
That's works at TF2 on Ubuntu_v12.04 LTS and GeForce 6600!!! Thx!!!
Gay Space Lobster 2013 年 07 月 28 日 @ 下午 12 時 58 分 
Fibbles, what if you're running a 32 bit system? Will the same instructions still work? Or will we need a different package?
handuel 2013 年 08 月 27 日 @ 上午 8 時 29 分 
Cuddly, if you're on 32bit you don't need the package, the rest of the instructions work without it. That package is needed only for 64bit users to make the instructions work.
Occi 2013 年 11 月 7 日 @ 上午 9 時 34 分 
I encountered this error when I recently updated my Nvidia graphics driver on Linux (the proprietary ones on Debian testing). Restarted my machine and the error was gone.
sylwke3100 2013 年 12 月 26 日 @ 上午 7 時 18 分 
Work's in L4D2 for GeForce 7200GS/7300SE
顯示 1-14,共 14 則回應
< >
每頁: 15 30 50