KuramaYoko 9. Dez. 2012 um 5:56 Uhr
X Server won't start after update to nvidia beta driver
I just had this problem: when I rebooted my computer it would give some errors and present me to the tty terminal. When I tried 'startx' it failed.

I gave a quick look at the /var/log/xorg.0.conf file and it said the nvidia kernel module couldn't be loaded.

I will present here the solution I found in case someone else needs it:

    [1]First remove the broken driver by running
    sudo apt-get purge nvidia*
    sudo rm /etc/X11/xorg.conf
    [2]Then reinstall the recommended and stable driver
    sudo apt-get install nvidia-current
    [3]Then reboot
    sudo reboot

You will have to reinstall the beta driver and try again.
Hope this helps other people. ;)
Zuletzt bearbeitet von KuramaYoko; 9. Dez. 2012 um 6:01 Uhr
Beiträge 1-8 von 8
< >
[L.o.N]Stylophonic 9. Dez. 2012 um 12:19 Uhr 
won't work.. because this will install driver version 295.40 on my ubuntu 12.04lts system
thedarknite 9. Dez. 2012 um 14:14 Uhr 
Assuming your drivers were working prior to installing the experimental drivers
sudo apt-get remove nvidia-experimental-304 nvidia-settings-experimental-304
or
sudo apt-get remove nvidia-experimental-310 nvidia-settings-experimental-310
will remove just the experimental drivers.
You can then try reinstalling them with
sudo apt-get install nvidia-experimental-310 nvidia-settings-experimental-310
then rebooting
[Linux] VanitasVitae [PoorPixel] 10. Dez. 2012 um 15:27 Uhr 
I'm confused... Do I have to use both, the experimantal AND the nvidia-current at the same time? The additional drivers msnu sais, the experimental driver is activated but not in use. what can I do?
KuramaYoko 12. Dez. 2012 um 5:06 Uhr 
Ursprünglich geschrieben von VanitasVitae GER:
I'm confused... Do I have to use both, the experimantal AND the nvidia-current at the same time? The additional drivers msnu sais, the experimental driver is activated but not in use. what can I do?
No, you can only use one driver at a time.
In my solution I activated the nvidia-current so that I could resume my desktop interface. From there I had to choose to activate the beta driver again.
[Linux] VanitasVitae [PoorPixel] 12. Dez. 2012 um 5:52 Uhr 
Ok, thank you
Aaron 12. Dez. 2012 um 8:32 Uhr 
Did you happen to run nvidia-bug-report.sh or save your kernel log? If the kernel module can't be loaded, there should have been a message there about why not.
KuramaYoko 12. Dez. 2012 um 8:43 Uhr 
Ursprünglich geschrieben von Aaron:
Did you happen to run nvidia-bug-report.sh or save your kernel log? If the kernel module can't be loaded, there should have been a message there about why not.
No, I did not run nvidia-bug-report.sh but I looked at the log X generated.
It had a lot of info about my computer there and many warnings. I will check later more carefully trying to find more info on the problem.
f70pp1 30. Jan. 2013 um 17:13 Uhr 
I'm used to my ATI desktop PC and so my NVidia powered laptop drives me crasy, but this helped me out. Thx
Beiträge 1-8 von 8
< >
Pro Seite: 15 30 50