Steam for Linux > NVidia Graphics Cards > รายละเอียดกระทู้
Nova ツ 23 พ.ค. 2013 @ 1:54pm
[SOLVED] [Optimus/Primus] Could not find required OpenGL entry point 'glGetError'| Either your video card is unsupported, or your OpenGL driver needs to be updated
I successfuly installed Primus with bumblebee on my Ubuntu 12.04 64Bits, i can reach 278 fps with "vblank_mode=0 primusrun glxspheres", but when i try to launch Team Fortress 2 with primusrun %command% (actually OPTIMUS_PREFIX witch correspond to primusrun in etc/environment ) i get this error:

"Could not find required OpenGL entry point 'glGetError'| Either your video card is unsupported, or your OpenGL driver needs to be updated"

I'm running with a Intel and a nVidia GeForce GT 630M - 2Gb, using the nvidia drivers 310-experimental.

And I can start the game with optirun, but it's very laggy and i don't run tf2 with high graphics settings :/

Hoping someone can help me ^^
ได้รับการแก้ไขครั้งสุดท้ายโดย Nova ツ; 25 พ.ค. 2013 @ 4:50am
กำลังแสดง 1-14 จาก 14 ความเห็น
< >
TheSniperFan 24 พ.ค. 2013 @ 8:55am 
I remember having this error a while back.
It wasn't fixed by me though. I'd say try a different driver version.
Nova ツ 24 พ.ค. 2013 @ 10:33am 
i'll try that with the last 319.17
TheSniperFan 24 พ.ค. 2013 @ 2:48pm 
I'll check what version I have later. I'm in Windows right now.
TheSniperFan 24 พ.ค. 2013 @ 3:47pm 
I have:
Nvidia 319.17
Bumblebee 3.2.1
Nova ツ 25 พ.ค. 2013 @ 2:14am 
can you tell me from were did you install your drivers ? seems there's no version available from xorg-edgers for my ubuntu 12.04 64 bits :(

(Getting this error :
Package nvidia-319 is not available, but exists in the database.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package nvidia-319 has no installation candidate)

BTW I'm running with Bumblebee Version: 3.2.1-1~preciseppa3
ได้รับการแก้ไขครั้งสุดท้ายโดย Nova ツ; 25 พ.ค. 2013 @ 3:19am
Nova ツ 25 พ.ค. 2013 @ 2:54am 
Well i just installed nvidia drivers 319.23 from here: http://www.ubuntuupdates.org/package/xorg-edgers/precise/main/base/nvidia-319

Downloaded the 64bits package for nvidia-319 and nvidiasettings-319, i intalled the deb packages with software center and... it get worse x). Now bumblebee is dead. RUnning optirun glxspheres:

[ 191.312202] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 191.312313] [ERROR]Could not connect to bumblebee daemon - is it running?

But i have to say that i edited the config file in /etc/bumblebee/bumblebee.conf to get this:

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-319
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-319:/usr/lib32/nvidia-319
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-319/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

and i did the same for Primusrun in /usr/bin/primusrun


EDIT: Now i reinstalled bumblebee and primus with default 304.88 driver. everything seems to work now. but i'm still getting the same error in steam with primus
ได้รับการแก้ไขครั้งสุดท้ายโดย Nova ツ; 25 พ.ค. 2013 @ 3:13am
TheSniperFan 25 พ.ค. 2013 @ 3:42am 
Firstly, I don't use Ubuntu anymore.
Secondly, I now remember having to edit my bumbmebee.conf too.
It was the "XorgModulePath" line that pointed to the wrong directory.
Mine goes like this now:

XorgModulePath=/usr/lib/nvidia/xorg/,/usr/lib/xorg/modules

Does bumblebee work for you at all? (glxspheres for example)
Nova ツ 25 พ.ค. 2013 @ 3:58am 
Now i managed to install 319.23 drivers correctly... ppa was disabled x) (i enabled it with synaptic), i reedited primus and bumblebee config files and it seems to work:

nova@N53SM-Ubuntu:~$ optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
117.302022 frames/sec - 130.909056 Mpixels/sec
130.286428 frames/sec - 145.399654 Mpixels/sec
125.686615 frames/sec - 140.266263 Mpixels/sec
127.413727 frames/sec - 142.193719 Mpixels/sec
130.689596 frames/sec - 145.849589 Mpixels/sec
127.309368 frames/sec - 142.077255 Mpixels/sec

______________________

nova@N53SM-Ubuntu:~$ vblank_mode=0 primusrun glxspheres
Polygons in scene: 62464
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Visual ID of window: 0xa0
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
198.223976 frames/sec - 221.217958 Mpixels/sec
201.684920 frames/sec - 225.080371 Mpixels/sec
221.869379 frames/sec - 247.606227 Mpixels/sec
221.996363 frames/sec - 247.747941 Mpixels/sec
224.855281 frames/sec - 250.938493 Mpixels/sec
223.483882 frames/sec - 249.408012 Mpixels/sec

But still getting the same error with primus on steam :/
Nova ツ 25 พ.ค. 2013 @ 4:15am 
And now i get this message when i launch steam:

Your currently installed video driver package, ligl1-mesag-dri, has a new version: 9.0-ubunt1.
We recommend upgrading your system to this new driver package.

sould i do this upgrade ?
Nova ツ 25 พ.ค. 2013 @ 4:48am 
I fixed it ! :)

I just replaced the "primusrun" command in steam by "optirun --brigde primus' in the TF2 Launch Options and it worked ^^ i didn't know this command, i found it on Bumblebee website, and tf2 runs well :)

Anyway thanks for your help !
ได้รับการแก้ไขครั้งสุดท้ายโดย Nova ツ; 25 พ.ค. 2013 @ 4:49am
TheSniperFan 25 พ.ค. 2013 @ 4:56am 
"optirun --bridge primus" (or "optirun -b primus") is the same as "primusrun".
"optirun -b virtualgl" is the same as "optirun".
They merged both commands together so that instead of having two seperate commands, you have one with the option to chose either primus or virtualgl.
Nova ツ 25 พ.ค. 2013 @ 5:49am 
I don't know where the mistery is :d but TF2 don't run with "primusrun" in my case x)
TheSniperFan 25 พ.ค. 2013 @ 11:13am 
Maybe it's outdated, since it has been replaced.
Zoli 26 มี.ค. @ 1:54pm 
i installed the 32bit version of virtualgl, and it works now!

apt-get install virtualgl:i386
ได้รับการแก้ไขครั้งสุดท้ายโดย Zoli; 26 มี.ค. @ 1:58pm
กำลังแสดง 1-14 จาก 14 ความเห็น
< >
ต่อหน้า: 15 30 50