Steam for Linux

Steam for Linux

Baes 2013年5月23日下午1:54
[SOLVED] [Optimus/Primus] Could not find required OpenGL entry point 'glGetError'| Either your video card is unsupported, or your OpenGL driver needs to be updated
I successfuly installed Primus with bumblebee on my Ubuntu 12.04 64Bits, i can reach 278 fps with "vblank_mode=0 primusrun glxspheres", but when i try to launch Team Fortress 2 with primusrun %command% (actually OPTIMUS_PREFIX witch correspond to primusrun in etc/environment ) i get this error:

"Could not find required OpenGL entry point 'glGetError'| Either your video card is unsupported, or your OpenGL driver needs to be updated"

I'm running with a Intel and a nVidia GeForce GT 630M - 2Gb, using the nvidia drivers 310-experimental.

And I can start the game with optirun, but it's very laggy and i don't run tf2 with high graphics settings :/

Hoping someone can help me ^^
最后由 Baes 编辑于; 2013年5月25日上午4:50
< >
正在显示第 1 - 15 条,共 15 条留言
TheSniperFan 2013年5月24日上午8:55 
I remember having this error a while back.
It wasn't fixed by me though. I'd say try a different driver version.
Baes 2013年5月24日上午10:33 
i'll try that with the last 319.17
TheSniperFan 2013年5月24日下午2:48 
I'll check what version I have later. I'm in Windows right now.
TheSniperFan 2013年5月24日下午3:47 
I have:
Nvidia 319.17
Bumblebee 3.2.1
Baes 2013年5月25日上午2:14 
can you tell me from were did you install your drivers ? seems there's no version available from xorg-edgers for my ubuntu 12.04 64 bits :(

(Getting this error :
Package nvidia-319 is not available, but exists in the database.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package nvidia-319 has no installation candidate)

BTW I'm running with Bumblebee Version: 3.2.1-1~preciseppa3
最后由 Baes 编辑于; 2013年5月25日上午3:19
Baes 2013年5月25日上午2:54 
Well i just installed nvidia drivers 319.23 from here:

Downloaded the 64bits package for nvidia-319 and nvidiasettings-319, i intalled the deb packages with software center and... it get worse x). Now bumblebee is dead. RUnning optirun glxspheres:

[ 191.312202] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 191.312313] [ERROR]Could not connect to bumblebee daemon - is it running?

But i have to say that i edited the config file in /etc/bumblebee/bumblebee.conf to get this:

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing and the
# default Xorg modules path

and i did the same for Primusrun in /usr/bin/primusrun

EDIT: Now i reinstalled bumblebee and primus with default 304.88 driver. everything seems to work now. but i'm still getting the same error in steam with primus
最后由 Baes 编辑于; 2013年5月25日上午3:13
TheSniperFan 2013年5月25日上午3:42 
Firstly, I don't use Ubuntu anymore.
Secondly, I now remember having to edit my bumbmebee.conf too.
It was the "XorgModulePath" line that pointed to the wrong directory.
Mine goes like this now:


Does bumblebee work for you at all? (glxspheres for example)
Baes 2013年5月25日上午3:58 
Now i managed to install 319.23 drivers correctly... ppa was disabled x) (i enabled it with synaptic), i reedited primus and bumblebee config files and it seems to work:

nova@N53SM-Ubuntu:~$ optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
117.302022 frames/sec - 130.909056 Mpixels/sec
130.286428 frames/sec - 145.399654 Mpixels/sec
125.686615 frames/sec - 140.266263 Mpixels/sec
127.413727 frames/sec - 142.193719 Mpixels/sec
130.689596 frames/sec - 145.849589 Mpixels/sec
127.309368 frames/sec - 142.077255 Mpixels/sec


nova@N53SM-Ubuntu:~$ vblank_mode=0 primusrun glxspheres
Polygons in scene: 62464
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Visual ID of window: 0xa0
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
198.223976 frames/sec - 221.217958 Mpixels/sec
201.684920 frames/sec - 225.080371 Mpixels/sec
221.869379 frames/sec - 247.606227 Mpixels/sec
221.996363 frames/sec - 247.747941 Mpixels/sec
224.855281 frames/sec - 250.938493 Mpixels/sec
223.483882 frames/sec - 249.408012 Mpixels/sec

But still getting the same error with primus on steam :/
Baes 2013年5月25日上午4:15 
And now i get this message when i launch steam:

Your currently installed video driver package, ligl1-mesag-dri, has a new version: 9.0-ubunt1.
We recommend upgrading your system to this new driver package.

sould i do this upgrade ?
Baes 2013年5月25日上午4:48 
I fixed it ! :)

I just replaced the "primusrun" command in steam by "optirun --brigde primus' in the TF2 Launch Options and it worked ^^ i didn't know this command, i found it on Bumblebee website, and tf2 runs well :)

Anyway thanks for your help !
最后由 Baes 编辑于; 2013年5月25日上午4:49
TheSniperFan 2013年5月25日上午4:56 
"optirun --bridge primus" (or "optirun -b primus") is the same as "primusrun".
"optirun -b virtualgl" is the same as "optirun".
They merged both commands together so that instead of having two seperate commands, you have one with the option to chose either primus or virtualgl.
Baes 2013年5月25日上午5:49 
I don't know where the mistery is :d but TF2 don't run with "primusrun" in my case x)
TheSniperFan 2013年5月25日上午11:13 
Maybe it's outdated, since it has been replaced.
Zoli 2014年3月26日下午1:54 
i installed the 32bit version of virtualgl, and it works now!

apt-get install virtualgl:i386
最后由 Zoli 编辑于; 2014年3月26日下午1:58
Ted 2014年9月22日下午7:16 
For those who wants to use primus, the trick is almost the same :
apt-get install primus:i386
< >
正在显示第 1 - 15 条,共 15 条留言
每页显示数: 15 30 50