Steam for Linux > NVidia Graphics Cards > Detalhes do Tópico
UnearthlyTrance 18 Mai, 2013 às 5:13
OpenGL GLX context is not using direct rendering, which may cause performance problems.
Hi,

I'm using Ubuntu 13.04 64-bit on my system and this error occured today. I tested the nvidia x-org file and the nvidia config also says that openGL works fine.

I followed the troubleshooting guide but nothing seemed to work. I also added the username to the video group but this didn't work too. It seems that this is a problem with my graphic drivers and steam which cannot access to the 32 bit libraries.

How can i fix this?

I'm using the Nvidia 304.88 driver as this was the only one who gave me the message that openGL rendering is enabled. The newest (310 and 313) didn't give me any openGL enabled messages.

Please help.
Última alteração por UnearthlyTrance; 18 Mai, 2013 às 5:34
A mostrar 1-15 de 101 comentários
< >
UnearthlyTrance 18 Mai, 2013 às 5:15 
Output of glxinfo | grep OpenGL if that helps:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 460 SE/PCIe/SSE2
OpenGL version string: 4.2.0 NVIDIA 304.88
OpenGL shading language version string: 4.20 NVIDIA via Cg compiler
OpenGL extensions:
Ace 18 Mai, 2013 às 6:43 
try to use latest drivers from this ppa https://launchpad.net/~xorg-edgers/+archive/ppa
version 319.17 at this moment
Última alteração por Ace; 18 Mai, 2013 às 7:48
UnearthlyTrance 18 Mai, 2013 às 14:45 
Doesn't work. 319.17 gives me "direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)"
MasterGeek 18 Mai, 2013 às 20:30 
I had this exact same problem on Ubuntu 13.04 (Raring) 64-bit. After a lot of monkey business, I finally solved the problem. The key is that steam (and any other 32-bit program, for that matter) need to load the 32-bit libGL.so library. However, the nvidia driver packages in Ubuntu Raring 64-bit (such as nvidia-304, nvidia-304-updates, nvidia-319, etc.) don't properly configure ldconfig to use the nvidia version of libGL.so for 32-bit programs (like steam and tf2). So steam and games like tf2 will end up loading some other non-nvidia graphics library. This causes steam to warn you about not using direct rendering (because you're using software rendering instead) and games like tf2 to fail to start altogether. Fortunately, the fix for this is really simple:

1.) In /usr/lib, there is a directory called something like nvidia-304 or nvidia-304-updates or nvidia-319 etc., which holds the nvidia OpenGL libraries.

If that directory is called nvidia-304, for instance, you'd want to, as root, edit the file /usr/lib/nvidia-304/alt_ld.so.conf (which you'll notice is currently blank) and add the lines:

/usr/lib32/nvidia-304
/usr/lib/nvidia-304

If that directory is something else, like /usr/lib/nvidia-304-updates you'd want to edit the file /usr/lib/nvidia-304-updates/alt_ld.so.conf as root and add the lines:

/usr/lib32/nvidia-304-updates
/usr/lib/nvidia-304-updates

And if your directory is /usr/lib/nvidia-<something else>, you'd want to edit /usr/lib/nvidia-<something else>/alt_ld.so.conf as root and add the lines:

/usr/lib32/nvidia-<something else>
/usr/lib/nvidia-<something else>

You get the idea...

2.) In the linux terminal, run the command:

sudo ldconfig

Then type in your password for your linux user account (you need to be an administrator, of course (in the sudo group, in other words)).

3.) Restart steam. You'll notice that there's no warning about not using direct rendering anymore. You'll also be able to play games like tf2 again.

Of course, this is a bug with the nvidia driver packages in Ubuntu 13.04 (Raring) 64-bit. And as such, I've filed a bug report: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1181651
If you have this problem, too, and it was fixed with these directions please go to the bug report and say it affects you, too. The more people who confirm the bug, the more likely the nvidia driver packages will be fixed by the people who maintain them. :)
Última alteração por MasterGeek; 18 Mai, 2013 às 20:35
UnearthlyTrance 19 Mai, 2013 às 16:46 
Doesn't work for me :/ Still get the same error with openGL.
UnearthlyTrance 19 Mai, 2013 às 16:55 
Can I somehow find out which Library steam is loading? Or better: NOT loading?
MasterGeek 19 Mai, 2013 às 18:04 
Originalmente postado por Unearthly Trance:
Doesn't work for me :/ Still get the same error with openGL.

Wierd. Well, first I'd check to make sure your kernel drivers are correctly installed. You should first run this comand to make sure you have the required packages for dkms to run:

sudo apt-get install linux-generic

Then (assuming you're using the nvidia-319 package and you've already installed it) you need to run this command:

sudo dpkg-reconfigure nvidia-319

Which will give you output looking somewhat like this:

Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-319
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Loading new nvidia-319-319.17 DKMS files...
Building only for 3.8.0-19-generic
Building for architecture x86_64
Building initial module for 3.8.0-19-generic
Done.

nvidia_319:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.8.0-19-generic/updates/dkms/

depmod....

DKMS: install completed.
Processing triggers for initramfs-tools ...

Now, when it says "Building initial module for <your linux kernel version>", MAKE SURE it says "Done." after it. If it doesn't, then something is seriously messed up. Anyway, assuming that it says "Done.", you then want to reboot your computer to load up the new kernel module. Once that's done, follow the instructions from my previous post to fix ldconfig again since dpkg-reconfigure might have un-fixed that... You shouldn't have to reboot a second time assuming you've run sudo ldconfig. Just rebooting Steam after running ldconfig will be enough to load the correct nvidia libGL.so library.

If you're still getting that error message, then you should probably check to see which library steam is loading. While it's difficult to do it directly on steam, you can do it on another 32-bit program that uses libGL.so (which should be the same libGL.so that Steam is loading). Such a program is the 32-bit version of glxinfo. To install the 32-bit version (you probably have the 64-bit version installed currently), run the command:

sudo apt-get install mesa-utils:i386

The :i386 specifies you want the 32-bit version of mesa-utils (which contains glxinfo). To see what version of libGL.so glxinfo and Steam are using, just run the command:

ldd /usr/bin/glxinfo

This will output a list of various .so libraries that glxinfo is using. One of them is libGL.so, so find it and look to the right of the entry to see the full path of the libGL.so glxinfo is actually using. If you see something like:

libGL.so.1 => /usr/lib32/nvidia-319/libGL.so.1 (0x00007fe738da4000)

Then everything should be working properly and you shouldn't get the error message any longer. Notice that the path is in the form /usr/lib32/nvidia-<something>/libGL.so.<version #>, the lib32 and the nvidia-<something> are the important bits to look for.

If it points to anywhere else, then something is still screwed up. Please send me the output of that command and the output of dpkg-reconfigure and I'll see if I can help you.
Última alteração por MasterGeek; 19 Mai, 2013 às 18:13
UnearthlyTrance 20 Mai, 2013 às 3:23 
libGL.so.1 => /usr/lib/i386-linux-gnu/mesa/libGL.so.1 (0xf773f000)

It shows this, not nvidia. So is this maybe the error?

Full output:

ldd /usr/bin/glxinfo
linux-gate.so.1 => (0xf77bd000)
libGL.so.1 => /usr/lib/i386-linux-gnu/mesa/libGL.so.1 (0xf773f000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7609000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7455000)
libglapi.so.0 => /usr/lib/i386-linux-gnu/libglapi.so.0 (0xf743e000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf742c000)
libXdamage.so.1 => /usr/lib/i386-linux-gnu/libXdamage.so.1 (0xf7428000)
libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xf7421000)
libX11-xcb.so.1 => /usr/lib/i386-linux-gnu/libX11-xcb.so.1 (0xf741d000)
libxcb-glx.so.0 => /usr/lib/i386-linux-gnu/libxcb-glx.so.0 (0xf7405000)
libxcb-dri2.so.0 => /usr/lib/i386-linux-gnu/libxcb-dri2.so.0 (0xf7400000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf73de000)
libXxf86vm.so.1 => /usr/lib/i386-linux-gnu/libXxf86vm.so.1 (0xf73d8000)
libdrm.so.2 => /usr/lib/i386-linux-gnu/libdrm.so.2 (0xf73ca000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf73af000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf73aa000)
/lib/ld-linux.so.2 (0xf77be000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf73a6000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf739f000)
MasterGeek 20 Mai, 2013 às 13:38 
This is definitely the error. On my system, if a 32-bit application isn't using the nvidia libraries, it's using that library. Something's not right with your ldconfig setup. My system is working, so if we can compare your configuration to mine we might be able to spot the problem. I've written a script that will dump the information I need to do that. And no, it won't look for any personal information or give you a virus. Save it to a file called ldconfig-settings-dumper.sh in your home directory. cd into your home directory where you saved the script and run it with this command, where <nvidia driver package name> is the name of the nvidia driver package as you would give it to apt-get to install it (like nvidia-304, nvidia-319, nvidia-304-updates, etc.):

sudo bash ldconfig-settings-dumper.sh <nvidia driver package name>

This will take a while as it will run dpkg-reconfigure on your driver so I can see if there was any sort of problem with the driver installation (and that's why the script needs super-user priviledges). The script will not output anything to your shell, as all the output is redirected to a file. Once it finishes, post the contents of the file ldconfig-settings-dumper-output.txt which will appear in the same directory you saved the script into. I've tested the script on my own computer, so it _should_ work.

The script:

#!/bin/bash

OUTPUT_FILE=$PWD/ldconfig-settings-dumper-output.txt

echo "Ubuntu Version:
" > $OUTPUT_FILE
lsb_release -a >> $OUTPUT_FILE 2>&1

echo "

Available Kernels:
" >> $OUTPUT_FILE
ls /boot >> $OUTPUT_FILE

echo "

dpkg-reconfigure $1
" >> $OUTPUT_FILE
dpkg-reconfigure $1 >> $OUTPUT_FILE 2>&1

echo "

apt-get install mesa-utils:i386
" >> $OUTPUT_FILE
apt-get -y install mesa-utils:i386 >> $OUTPUT_FILE 2>&1

echo "

ldd /usr/bin/glxinfo
" >> $OUTPUT_FILE
ldd /usr/bin/glxinfo >> $OUTPUT_FILE

echo "

Now dumping ldconfig settings...
" >> $OUTPUT_FILE
echo "*****/etc/ld.so.conf*****

" >> $OUTPUT_FILE
cat /etc/ld.so.conf >> $OUTPUT_FILE

echo "

*****/etc/ld.so.conf.d directory listing*****

" >> $OUTPUT_FILE
ls -a -l /etc/ld.so.conf.d >> $OUTPUT_FILE

find /etc/ld.so.conf.d -name *.conf -printf "\n\n*****%p*****\n\c" -exec cat '{}' \; >> $OUTPUT_FILE

echo "

*****/usr/lib/$1/alt_ld.so.conf*****

" >> $OUTPUT_FILE
cat /usr/lib/$1/alt_ld.so.conf >> $OUTPUT_FILE



echo '

**************************************************
Now running ldconfig and dumping ldconfig cache...

ldconfig -v 2>&1 | grep GL

' >> $OUTPUT_FILE

ldconfig -v 2>&1 | grep GL >> $OUTPUT_FILE

echo '

ldconfig -p 2>&1 | grep GL

' >> $OUTPUT_FILE

ldconfig -p 2>&1 | grep GL >> $OUTPUT_FILE


echo '

Running ldd /usr/bin/glxinfo again incase that fixed something...

' >> $OUTPUT_FILE

ldd /usr/bin/glxinfo >> $OUTPUT_FILE
UnearthlyTrance 20 Mai, 2013 às 14:20 
Output:

Ubuntu Version:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring


Available Kernels:

abi-3.5.0-27-generic
abi-3.8.0-19-generic
abi-3.8.0-21-generic
config-3.5.0-27-generic
config-3.8.0-19-generic
config-3.8.0-21-generic
grub
initrd.img-3.5.0-27-generic
initrd.img-3.8.0-19-generic
initrd.img-3.8.0-21-generic
memtest86+.bin
memtest86+_multiboot.bin
System.map-3.5.0-27-generic
System.map-3.8.0-19-generic
System.map-3.8.0-21-generic
vmlinuz-3.5.0-27-generic
vmlinuz-3.8.0-19-generic
vmlinuz-3.8.0-21-generic


dpkg-reconfigure nvidia-310-updates

Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-310-updates
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Loading new nvidia-310-updates-310.44 DKMS files...
Building only for 3.8.0-21-generic
Building for architecture x86_64
Building initial module for 3.8.0-21-generic
Done.

nvidia_310_updates:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.8.0-21-generic/updates/dkms/

depmod....

DKMS: install completed.
Trigger für bamfdaemon werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für initramfs-tools werden verarbeitet ...
update-initramfs: Generating /boot/initrd.img-3.8.0-21-generic
Warning: No support for locale: de_DE.utf8


apt-get install mesa-utils:i386

Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
mesa-utils:i386 ist schon die neueste Version.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
gnuchess gnuchess-book libatk-wrapper-java libatk-wrapper-java-jni
libgstreamer-plugins-bad1.0-0 libtiff4 libtiff4:i386 python-wxversion
stellarium-data
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 25 nicht aktualisiert.


ldd /usr/bin/glxinfo

linux-gate.so.1 => (0xf77b2000)
libGL.so.1 => /usr/lib32/nvidia-310-updates/libGL.so.1 (0xf76ae000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7578000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf73c4000)
libnvidia-tls.so.310.44 => /usr/lib32/nvidia-310-updates/tls/libnvidia-tls.so.310.44 (0xf73c0000)
libnvidia-glcore.so.310.44 => /usr/lib32/nvidia-310-updates/libnvidia-glcore.so.310.44 (0xf569e000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf568c000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf5687000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf5664000)
/lib/ld-linux.so.2 (0xf77b3000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf5621000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf561d000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf5616000)


Now dumping ldconfig settings...

*****/etc/ld.so.conf*****


include /etc/ld.so.conf.d/*.conf



*****/etc/ld.so.conf.d directory listing*****


insgesamt 15
drwxr-xr-x 2 root root 1024 Mai 20 01:40 .
drwxr-xr-x 161 root root 9216 Mai 20 23:13 ..
lrwxrwxrwx 1 root root 40 Mai 20 01:40 i386-linux-gnu_GL.conf -> /etc/alternatives/i386-linux-gnu_gl_conf
-rw-r--r-- 1 root root 108 Okt 4 2012 i686-linux-gnu.conf
-rw-r--r-- 1 root root 44 Okt 4 2012 libc.conf
lrwxrwxrwx 1 root root 38 Mai 18 23:43 nvidia_settings.conf -> /etc/alternatives/nvidia_settings_conf
-rw-r--r-- 1 root root 59 Mai 20 18:09 steam.conf
-rw-r--r-- 1 root root 68 Okt 4 2012 x86_64-linux-gnu.conf
lrwxrwxrwx 1 root root 43 Mai 5 00:25 x86_64-linux-gnu_EGL.conf -> /etc/alternatives/x86_64-linux-gnu_egl_conf
lrwxrwxrwx 1 root root 42 Mai 20 01:40 x86_64-linux-gnu_GL.conf -> /etc/alternatives/x86_64-linux-gnu_gl_conf
-rw-r--r-- 1 root root 56 Apr 18 13:19 zz_i386-biarch-compat.conf


*****/etc/ld.so.conf.d/steam.conf*****
/usr/lib32/nvidia-310-updates
/usr/lib/i386-linux-gnu/mesa


*****/etc/ld.so.conf.d/libc.conf*****
# libc default configuration
/usr/local/lib


*****/etc/ld.so.conf.d/i686-linux-gnu.conf*****
# Multiarch support
/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu
/lib/i686-linux-gnu
/usr/lib/i686-linux-gnu


*****/etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf*****
/usr/lib/x86_64-linux-gnu/mesa-egl


*****/etc/ld.so.conf.d/i386-linux-gnu_GL.conf*****
/usr/lib32/nvidia-310-updates
/usr/lib/nvidia-310-updates


*****/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf*****
/usr/lib/nvidia-310-updates
/usr/lib32/nvidia-310-updates


*****/etc/ld.so.conf.d/zz_i386-biarch-compat.conf*****
# Legacy biarch compatibility support
/lib32
/usr/lib32


*****/etc/ld.so.conf.d/x86_64-linux-gnu.conf*****
# Multiarch support
/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu


*****/etc/ld.so.conf.d/nvidia_settings.conf*****
/usr/lib/nvidia-settings-319


*****/usr/lib/nvidia-310-updates/alt_ld.so.conf*****


/usr/lib32/nvidia-310-updates
/usr/lib/nvidia-310-updates


**************************************************
Now running ldconfig and dumping ldconfig cache...

ldconfig -v 2>&1 | grep GL


libGL.so.1 -> libGL.so.310.44
libGL.so.1 -> libGL.so.310.44
libGLU.so.1 -> libGLU.so.1.3.1
libQtOpenGL.so.4 -> libQtOpenGL.so.4.8.4
libGL.so.1 -> libGL.so.1.2.0
libGLEWmx.so.1.8 -> libGLEWmx.so.1.8.0
libGLU.so.1 -> libGLU.so.1.3.1
libGLEW.so.1.8 -> libGLEW.so.1.8.0
libQtOpenGL.so.4 -> libQtOpenGL.so.4.8.4
libGLESv2.so.2 -> libGLESv2.so.2.0.0
libGLESv1_CM.so.1 -> libGLESv1_CM.so.1.1.0
libEGL.so.1 -> libEGL.so.1.0.0
libGLw.so.1 -> libGLw.so.1.0.0


ldconfig -p 2>&1 | grep GL


libQtOpenGL.so.4 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4
libQtOpenGL.so.4 (libc6) => /usr/lib/i386-linux-gnu/libQtOpenGL.so.4
libGLw.so.1 (libc6,x86-64) => /usr/lib/libGLw.so.1
libGLU.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLU.so.1
libGLU.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGLU.so.1
libGLEWmx.so.1.8 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEWmx.so.1.8
libGLEW.so.1.8 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEW.so.1.8
libGLESv2.so.2 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv2.so.2
libGLESv1_CM.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv1_CM.so.1
libGL.so.1 (libc6,x86-64) => /usr/lib/nvidia-310-updates/libGL.so.1
libGL.so.1 (libc6) => /usr/lib32/nvidia-310-updates/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/mesa/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/libGL.so.1
libGL.so (libc6,x86-64) => /usr/lib/nvidia-310-updates/libGL.so
libGL.so (libc6) => /usr/lib32/nvidia-310-updates/libGL.so
libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1


Running ldd /usr/bin/glxinfo again incase that fixed something...


linux-gate.so.1 => (0xf76e7000)
libGL.so.1 => /usr/lib32/nvidia-310-updates/libGL.so.1 (0xf75e3000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf74ad000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf72f9000)
libnvidia-tls.so.310.44 => /usr/lib32/nvidia-310-updates/tls/libnvidia-tls.so.310.44 (0xf72f5000)
libnvidia-glcore.so.310.44 => /usr/lib32/nvidia-310-updates/libnvidia-glcore.so.310.44 (0xf55d3000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf55c1000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf55bc000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf5599000)
/lib/ld-linux.so.2 (0xf76e8000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf5556000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf5552000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf554b000)

One thing to add:

*****/etc/ld.so.conf.d/steam.conf*****
/usr/lib32/nvidia-310-updates
/usr/lib/i386-linux-gnu/mesa


I changed this .conf as it was on a forum as a solution for the problem. I just changed the "/usr/lib32/" to "/usr/lib32/nvidia-310-updates" but it didn't work eitherway. So i can change it back if needed.
UnearthlyTrance 20 Mai, 2013 às 14:56 
Oh and sorry, some things are maybe in german because I have a german OS. If you need something translated, let me know it.
MasterGeek 20 Mai, 2013 às 16:44 
According to the output you gave me, Steam should work now. It says the 32-bit glxinfo is using the correct /usr/lib32/nvidia-310-updates/libGL.so.1 library, so Steam should be using it, too. Also, the nvidia kernel module was built correctly, so as long as you're running your computer with the 3.8.0-21 kernel (should be the default) it should be loaded properly. In all, I'd guess that, if you haven't changed anything after you ran that script, all you need to do is just restart your computer, and Steam will work. :)
Última alteração por MasterGeek; 20 Mai, 2013 às 16:45
MasterGeek 20 Mai, 2013 às 16:46 
Of course, if you've changed something after you ran the script, and Steam is not working, just re-run the script and send me the new output and I'll see what got messed up.
UnearthlyTrance 22 Mai, 2013 às 8:11 
Doesnt work :/

I did the script again, output:

Ubuntu Version:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring


Available Kernels:

abi-3.5.0-27-generic
abi-3.8.0-19-generic
abi-3.8.0-21-generic
config-3.5.0-27-generic
config-3.8.0-19-generic
config-3.8.0-21-generic
grub
initrd.img-3.5.0-27-generic
initrd.img-3.8.0-19-generic
initrd.img-3.8.0-21-generic
memtest86+.bin
memtest86+_multiboot.bin
System.map-3.5.0-27-generic
System.map-3.8.0-19-generic
System.map-3.8.0-21-generic
vmlinuz-3.5.0-27-generic
vmlinuz-3.8.0-19-generic
vmlinuz-3.8.0-21-generic


dpkg-reconfigure nvidia-310-updates

Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-310-updates
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Loading new nvidia-310-updates-310.44 DKMS files...
Building only for 3.8.0-21-generic
Building for architecture x86_64
Building initial module for 3.8.0-21-generic
Done.

nvidia_310_updates:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.8.0-21-generic/updates/dkms/

depmod....

DKMS: install completed.
Trigger für bamfdaemon werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für initramfs-tools werden verarbeitet ...
update-initramfs: Generating /boot/initrd.img-3.8.0-21-generic
Warning: No support for locale: de_DE.utf8


apt-get install mesa-utils:i386

Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
mesa-utils:i386 ist schon die neueste Version.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
gnuchess gnuchess-book libatk-wrapper-java libatk-wrapper-java-jni
libgstreamer-plugins-bad1.0-0 libtiff4 libtiff4:i386 python-wxversion
stellarium-data
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.


ldd /usr/bin/glxinfo

linux-gate.so.1 => (0xf76e6000)
libGL.so.1 => /usr/lib32/nvidia-310-updates/libGL.so.1 (0xf75e2000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf74ac000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf72f8000)
libnvidia-tls.so.310.44 => /usr/lib32/nvidia-310-updates/tls/libnvidia-tls.so.310.44 (0xf72f4000)
libnvidia-glcore.so.310.44 => /usr/lib32/nvidia-310-updates/libnvidia-glcore.so.310.44 (0xf55d2000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf55c0000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf55bb000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf5598000)
/lib/ld-linux.so.2 (0xf76e7000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf5555000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf5551000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf554a000)


Now dumping ldconfig settings...

*****/etc/ld.so.conf*****


include /etc/ld.so.conf.d/*.conf



*****/etc/ld.so.conf.d directory listing*****


insgesamt 15
drwxr-xr-x 2 root root 1024 Mai 20 01:40 .
drwxr-xr-x 161 root root 9216 Mai 22 17:08 ..
lrwxrwxrwx 1 root root 40 Mai 20 01:40 i386-linux-gnu_GL.conf -> /etc/alternatives/i386-linux-gnu_gl_conf
-rw-r--r-- 1 root root 108 Okt 4 2012 i686-linux-gnu.conf
-rw-r--r-- 1 root root 44 Okt 4 2012 libc.conf
lrwxrwxrwx 1 root root 38 Mai 18 23:43 nvidia_settings.conf -> /etc/alternatives/nvidia_settings_conf
-rw-r--r-- 1 root root 141 Mai 20 23:23 steam.conf
-rw-r--r-- 1 root root 68 Okt 4 2012 x86_64-linux-gnu.conf
lrwxrwxrwx 1 root root 43 Mai 5 00:25 x86_64-linux-gnu_EGL.conf -> /etc/alternatives/x86_64-linux-gnu_egl_conf
lrwxrwxrwx 1 root root 42 Mai 20 01:40 x86_64-linux-gnu_GL.conf -> /etc/alternatives/x86_64-linux-gnu_gl_conf
-rw-r--r-- 1 root root 56 Apr 18 13:19 zz_i386-biarch-compat.conf


*****/etc/ld.so.conf.d/steam.conf*****
/usr/lib32/nvidia-310-updates
/usr/lib/i386-linux-gnu/mesa
/usr/lib32
/usr/lib/i386-linux-gnu/mesa

/usr/lib32
/usr/lib/i386-linux-gnu/mesa



*****/etc/ld.so.conf.d/libc.conf*****
# libc default configuration
/usr/local/lib


*****/etc/ld.so.conf.d/i686-linux-gnu.conf*****
# Multiarch support
/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu
/lib/i686-linux-gnu
/usr/lib/i686-linux-gnu


*****/etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf*****
/usr/lib/x86_64-linux-gnu/mesa-egl


*****/etc/ld.so.conf.d/i386-linux-gnu_GL.conf*****
/usr/lib32/nvidia-310-updates
/usr/lib/nvidia-310-updates


*****/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf*****
/usr/lib/nvidia-310-updates
/usr/lib32/nvidia-310-updates


*****/etc/ld.so.conf.d/zz_i386-biarch-compat.conf*****
# Legacy biarch compatibility support
/lib32
/usr/lib32


*****/etc/ld.so.conf.d/x86_64-linux-gnu.conf*****
# Multiarch support
/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu


*****/etc/ld.so.conf.d/nvidia_settings.conf*****
/usr/lib/nvidia-settings-319


*****/usr/lib/nvidia-310-updates/alt_ld.so.conf*****


/usr/lib32/nvidia-310-updates
/usr/lib/nvidia-310-updates


**************************************************
Now running ldconfig and dumping ldconfig cache...

ldconfig -v 2>&1 | grep GL


libGL.so.1 -> libGL.so.310.44
libGL.so.1 -> libGL.so.310.44
libGLU.so.1 -> libGLU.so.1.3.1
libQtOpenGL.so.4 -> libQtOpenGL.so.4.8.4
libGL.so.1 -> libGL.so.1.2.0
libGLEWmx.so.1.8 -> libGLEWmx.so.1.8.0
libGLU.so.1 -> libGLU.so.1.3.1
libGLEW.so.1.8 -> libGLEW.so.1.8.0
libQtOpenGL.so.4 -> libQtOpenGL.so.4.8.4
libGLESv2.so.2 -> libGLESv2.so.2.0.0
libGLESv1_CM.so.1 -> libGLESv1_CM.so.1.1.0
libEGL.so.1 -> libEGL.so.1.0.0
libGLw.so.1 -> libGLw.so.1.0.0


ldconfig -p 2>&1 | grep GL


libQtOpenGL.so.4 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4
libQtOpenGL.so.4 (libc6) => /usr/lib/i386-linux-gnu/libQtOpenGL.so.4
libGLw.so.1 (libc6,x86-64) => /usr/lib/libGLw.so.1
libGLU.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLU.so.1
libGLU.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGLU.so.1
libGLEWmx.so.1.8 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEWmx.so.1.8
libGLEW.so.1.8 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEW.so.1.8
libGLESv2.so.2 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv2.so.2
libGLESv1_CM.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv1_CM.so.1
libGL.so.1 (libc6,x86-64) => /usr/lib/nvidia-310-updates/libGL.so.1
libGL.so.1 (libc6) => /usr/lib32/nvidia-310-updates/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/mesa/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/libGL.so.1
libGL.so (libc6,x86-64) => /usr/lib/nvidia-310-updates/libGL.so
libGL.so (libc6) => /usr/lib32/nvidia-310-updates/libGL.so
libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1


Running ldd /usr/bin/glxinfo again incase that fixed something...


linux-gate.so.1 => (0xf7740000)
libGL.so.1 => /usr/lib32/nvidia-310-updates/libGL.so.1 (0xf763c000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7506000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7352000)
libnvidia-tls.so.310.44 => /usr/lib32/nvidia-310-updates/tls/libnvidia-tls.so.310.44 (0xf734e000)
libnvidia-glcore.so.310.44 => /usr/lib32/nvidia-310-updates/libnvidia-glcore.so.310.44 (0xf562c000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf561a000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf5615000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf55f2000)
/lib/ld-linux.so.2 (0xf7741000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf55af000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf55ab000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf55a4000)
MasterGeek 22 Mai, 2013 às 21:04 
Now you're starting to get me interested...It _still_ is not working??? I smell a rat. Steam should be working, but it's not. I finally figured how out to test directly what libraries that Steam is using. Run the command:

ldd ~/.steam/steam/ubuntu12_32/steamui.so | grep GL

This will definitively tell us which library steam is using (so please post the output of the command). You should also start Steam by running the command:

steam

In a terminal so you can get the output of Steam's startup process. This will also give us some more clues as to what is going wrong. Again, please post the output.

Anyway, I'm fairly certain that the output will say that Steam is loading the correct libraries (and if it doesn't then I've got a lot more to learn about how linux decides which library a program will load). Starting steam in a terminal will just help me confirm what I think is happening: that Steam is loading the correct library but that library cannot access the nvidia graphics hardware because something is wrong with the kernel driver.

Since Steam should be loading the proper libraries (if ldd /usr/bin/glxinfo is anything to go by), I'd bet that it's a problem related to the nvidia kernel driver. If the kernel driver is not properly loaded, Steam will say it's not using direct rendering because it can't access the nvidia graphics hardware. So, I want you to install the latest nvidia-319 driver because I know it works:

sudo apt-get install nvidia-319 nvidia-settings-319

You'll need to restart your computer after this to reload the module. Then you'll need to follow the instructions from my very first post again because installing a new driver version will most likely erase the old configuration. After you run sudo ldconfig after editing the alt_ld.so.conf file, make sure to run ldd /usr/bin/glxinfo (the 32-bit version) to make sure that it's using the nvidia-319 libGL.so library. If it is, then we can safely assume that steam is using it, too. Go ahead and start up Steam in a terminal. Hopefully, the error message will go away after this. If not, then post the terminal output of Steam plus the output of the following commands:

sudo lsmod
sudo modinfo nvidia-319
sudo dkms status

Also, post the information given in Steam by going to the drop-down menu Help and then System Information. All I need is the information under "Video Card".

While you wait for my reply again, some steps you can try to take to fix it yourself is going to the Nvidia X Server Settings program and looking at OpenGL/GLX Information and tweaking the OpenGL Settings and the Antialiasing Settings. The mere act of changing some of these settings (which will regenerate configuration settings for the graphics card) might just fix something. This might be a long shot, but it's certainly worth a try. On top of that, if there's a problem with the driver, on the OpenGL/GLX Information page, the very first entry in the list is Direct Rendering, and it will be set to off. And if there is no problem and everything is working fine, it will be set to on.

P.S.: Sorry about my long-winded posts. I sometimes can talk a lot...
Última alteração por MasterGeek; 22 Mai, 2013 às 21:09
A mostrar 1-15 de 101 comentários
< >
Por página: 15 30 50