Uncrushebol Pigeon May 14, 2013 @ 6:43am
[SOLVED] 'You appear to have OpenGL 1.4.0!' Debian 7 Wheezy x64 - GeForce GTS 250 - 319.xx drivers
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I have the x64 319.xx drivers installed. I've tried setting the LD_LIBRARY_PATH to include the /emul/ia32-linux/usr/lib folder where my OpenGL compatibility libraries are located, but that causes Steam to segfault when it tries to open:

ian@BROHAMMER-DEBIAN:~$ steam-debian
Running Steam on debian 7.0 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1367621987_client)
/home/ian/.local/share/Steam/steam.sh: line 704: 14109 Segmentation fault $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/ian/.local/share/Steam/bootstrap.tar.xz
Running Steam on debian 7.0 64-bit
STEAM_RUNTIME has been set by the user to: /home/ian/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(1367621987_client)
/home/ian/.local/share/Steam/steam.sh: line 704: 14196 Segmentation fault $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

I used this Steam installer: https://github.com/GhostSquad57/Steam-Installer-for-Wheezy/

I'm not sure what else to try. I've seen people say that using the 310 driver helps some problems, should I try that?
Last edited by Uncrushebol Pigeon; May 16, 2013 @ 7:07am
Showing 1-1 of 1 comments
< >
Uncrushebol Pigeon May 16, 2013 @ 7:07am 
I fixed this by uninstalling my Nvidia drivers which I installed from the Nvidia website, and then adding the non-free repos to my apt sources, and then I installed the Nvidia drivers via apt-get. It works now!
Showing 1-1 of 1 comments
< >
Per page: 15 30 50