Reid Dec 15, 2013 @ 12:52pm
new Linux Steam User: libGL.so.1 issue
I just installed a dual boot partition of mint15 64 bit on my desktop and I'm trying to get steam to work properly. I have a moderate amount of experience with linux but not so much experience with linux GPU drivers.

After installing the proprietary NVIDIA drivers (from the NVIDIA-Linux-x86_64-331.20.run file off the website) I attempted to launch steam and got the libGL.so.1 not found error. Nothing I've searched online has fixed the problem. From what I've read it should be in /usr/lib32 but this folder does not exist on my system. I do have a /usr/lib/libGL.so.1

My card is a GTX 650ti boost if that matters.
Showing 1-8 of 8 comments
< >
Junior s2 Camila Dec 19, 2013 @ 9:59pm 
NEVER EVER EVER manually install the drivers.
Sin Dec 20, 2013 @ 4:33am 
You REALLY shouldn't be installing the Nvidia drivers manually unless you really know what you're doing. Installing graphics drivers for your GPU is very easy since it's a native card. You need to purge the nvidia driver you just installed, then go to the Additional Drivers page (search for it on your desktop) and you can install your Nvidia drivers that way.

By the way, you should try installing Linux Mint 16 because that contains better Nvidia drivers.
Kranky K. Krackpot Sr. Dec 21, 2013 @ 2:07am 
Originally posted by Arch Linux - Junior s2 Camila:
NEVER EVER EVER manually install the drivers.
Why? I installed Nvidia from their script for years. Though, you must know how to cook it, because it might go tricky.

Originally posted by Reid:
I just installed a dual boot partition of mint15 64 bit on my desktop and I'm trying to get steam to work properly. I have a moderate amount of experience with linux but not so much experience with linux GPU drivers.

After installing the proprietary NVIDIA drivers (from the NVIDIA-Linux-x86_64-331.20.run file off the website) I attempted to launch steam and got the libGL.so.1 not found error. Nothing I've searched online has fixed the problem. From what I've read it should be in /usr/lib32 but this folder does not exist on my system. I do have a /usr/lib/libGL.so.1

My card is a GTX 650ti boost if that matters.
You're on 64 bit? Did the drivers compile correctly, with no errors? Did you install 32-bit drivers too (Nvidia's installer has this option)?
Junior s2 Camila Dec 21, 2013 @ 2:23am 
Originally posted by Kranky K. Krackpot:
Originally posted by Arch Linux - Junior s2 Camila:
NEVER EVER EVER manually install the drivers.
Why? I installed Nvidia from their script for years. Though, you must know how to cook it, because it might go tricky.
He didn't install from a script, but from the .run file, see:
Originally posted by Reid:
After installing the proprietary NVIDIA drivers (from the NVIDIA-Linux-x86_64-331.20.run file off the website) I attempted to launch steam and got the libGL.so.1 not found error.
It's much better to use xedgers in that case. But I don't recommend that either, it breaks easily.
Last edited by Junior s2 Camila; Dec 21, 2013 @ 2:24am
Kranky K. Krackpot Sr. Dec 21, 2013 @ 2:27am 
Originally posted by Arch Linux - Junior s2 Camila:
Originally posted by Kranky K. Krackpot:
Why? I installed Nvidia from their script for years. Though, you must know how to cook it, because it might go tricky.
He didn't install from a script, but from the .run file, see:
Originally posted by Reid:
After installing the proprietary NVIDIA drivers (from the NVIDIA-Linux-x86_64-331.20.run file off the website) I attempted to launch steam and got the libGL.so.1 not found error.
It's much better to use xedgers in that case. But I don't recommend that either, it breaks easily.
.run file is a shell script, tt downloads driver's source and binaries, then compiles and installs them. It also installs nvidia-settings and nvidia-installer tool to handle all that stuff.
Of course, if you're going to install anything on your own, you must read that ♥♥♥♥in' manual close enough and be ready to face the consequenses... Manual installation must be considered as the last resort (or a bleeding-edge geek's play).
Last edited by Kranky K. Krackpot Sr.; Dec 21, 2013 @ 2:29am
Junior s2 Camila Dec 21, 2013 @ 2:41am 
I thought you were talking about a simple .sh script in which you could open via terminal, then it would download and compile everything.

I never had success with the .run file, no matter the instructions, it would always have libraries problems or Steam telling me my OpenGL is outdated (which is not).

That's why people should NEVER EVER EVER manually install their drivers unless they reeeeeally know what they're doing. Or do like me, install Arch and always have the latest drivers with just "sudo pacman -S nvidia" :)
Reid Dec 22, 2013 @ 10:08am 
Thanks for the answers. I fixed the problem by switching my OS to Ubuntu 12.04 and using the package manager. Drivers are installed and I get good performace in garry's mod.
The Wounded Jan 2 @ 1:24pm 
well for other people with this issue (after manually installing NVIDIA drivers which I do because they seem to provide outdated ones for linux mint)

You need to add /emul32/ to /etc/ld.so.conf run ldconfig and it will work
Showing 1-8 of 8 comments
< >
Per page: 15 30 50