Cluke_84 Jul 30, 2013 @ 4:12am
How to upgrade driver for switchable graphics??
I can't play games such as tf2 and lfd2 due to old driver that is installed from the Ubuntu repos. I'm running

-Linux Lite (the business) Ubuntu 12.04 base
-Graphics cards: Mobility Radeon HD 4200 Series and Radeon HD 6400M Series.
-Current driver: [fglrx] module loaded - fglrx 8.96.4 [Mar 12 2012]

When I activate the experimental drivers X gets broken.

From reading i've done it seems both cards are supported by seperate, newer drivers but only the driver listed supports both :(
If anyone can tell me that its not possible to upgrade drivers or point me in the right direction so I can get to shooting some zombies in the face on linux it would be appreciated :D

Edit: I will have to wait until tomorrow to post the error displayed when trying to run one of these games, don't want to use all bandwidth downloading the games during the day... As far as I can remember the error was along the lines of "opengl texture rgb unsuported"
Last edited by Cluke_84; Jul 30, 2013 @ 4:19am
Showing 1-11 of 11 comments
< >
RussianNeuroMancer Jul 30, 2013 @ 5:20am 
Please at first read this: AMD drivers and HP laptops with PowerXpress.

1. If your laptop is MUX-ed AND if you able to get fixed BIOS from HP - you can just disable 4200 in BIOS and use 6400M with latest version of fglrx driver. Maybe fixed BIOS is already available - check HP web-site.
2. If your laptop is MUX-ed and if you will use latest version of FOSS driver on Ubuntu/Kubuntu 13.04 you can switch between GPU's using vgaswitcheroo, but I think this way of work with hybrid graphics become obsolete and it's better to use DRI_PRIME (works on MUX-ed and MUX-less laptops).
3. Just install/upgrade to Ubuntu/Kubuntu 13.04 with FOSS driver and use DRI_PRIME to offload separate applications on discrete GPU (like this "DRI_PRIME=1 steam"). Best solution IMO.

Please let us know what option you will pick up. If you choice FOSS driver there is some tweaks that may improve user experience (dynamic power management to reduce heat, experimental shader compiler to improve fps).
Cluke_84 Jul 30, 2013 @ 6:01am 
I think I'll go with option 3, though i wont be using u/kubuntu because their gnome and kde are bloated crap imo, so ubuntu 13.04 base with xfce.

I'll update the thread when I have made some progress.

Thanks for your help.
Cluke_84 Jul 30, 2013 @ 8:23am 
I have installed Linux mint 15 xfce(I'm lazy and its nice so far) and installed steam. I have ensured DRI and DDX drivers are installed and exported DRI_PRIME=1 steam as suggested.

Can you point me in the direction of dynamic power management setup? My system is running around 10c hotter than with proprietary drivers and the fan is loud.
RussianNeuroMancer Jul 30, 2013 @ 8:55am 
1. Install updated firmware package[launchpad.net].
2. In file /etc/default/grub change variable GRUB_CMDLINE_LINUX_DEFAULT to "quiet splash radeon.dpm=1"
3. Install Linux 3.11 (end of this list[kernel.ubuntu.com]).
4. Check result[www.botchco.com].
Cluke_84 Jul 30, 2013 @ 9:05am 
Ah ok, I saw dpm was included in 3.11 but wasn't sure if i had to upgrade. Thanks for your help, much appreciated. I'll post what I have done from start to finish when I'm setup, it may be useful to someone.
Cluke_84 Jul 31, 2013 @ 3:27am 
I have upgraded firmware and installed kernel 3.11, the power management works very well and as far as I can see FOSS > proprietary with these improvements in kernel.
I installed lfd2 last night and just tried it, it runs but is not playable. It was lagging(like a CD skipping) at first so I turned down all video settings, this improved performance buyt the game is still not playable.
Where can I get information on the shader compiler? google dosn't give me much. Can anyone recommend any other tweaks that may improve performance?
Thanks.
RussianNeuroMancer Jul 31, 2013 @ 5:12am 
1. At first double check you are using DRI_PRIME right - it should be not in /etc/environment but in command line when you launch Steam. Also check output of "DRI_PRIME=0 glxinfo | grep renderer" and "DRI_PRIME=1 glxinfo | grep renderer".
2. Check if 32-bit version of Mesa is installed (ia32-libs and ia32-libs-multiarch:i386 packages) and working (you can install package mesa-utils:i386 and check glxinfo output again - there shouldn't be things like llvmpipe or softpipe in renderer string).
3. To use experimental shader compiler update system from Xorg Edgers PPA (don't forget to install ppa-purge, just in case) and launch Steam like this: "R600_DEBUG=sb,nollvm" (if you get GPU hang while playing L4D2 add nohyperz)
4. Performance GPU governor instead of ondemand also may help.
Cluke_84 Jul 31, 2013 @ 6:05am 
1. everything is correct and working.
2. I am running 64-bit os, 32-bit mesa is not installed. Do I need to install it?

I'll test 3 and 4 later when I have time.

Where do you get this information? Phoronix?
Thanks for your help
RussianNeuroMancer Jul 31, 2013 @ 6:08am 
Originally posted by Cluke_84:
Do I need to install it?
Yes, you have to install ia32-libs and ia32-libs-multiarch:i386 (all needed dependencies will be pulled automatically) otherwise you are using software rendering in 32-bit applications (so that why you probably have low framerate).

Originally posted by Cluke_84:
Where do you get this information?
Practice, Phoronix, Valve bugtracker and so on.
Cluke_84 Jul 31, 2013 @ 8:12am 
Ok so I installed the libraries with no change in performance, lsof -p lfd2PID does not show the libraries are in use. Do I have to remove steam and reinstall or what is my next step?

Thanks for your time. I will write a guide of what I have done after so others wont have to be spoon feed
RussianNeuroMancer Jul 31, 2013 @ 9:22am 
What output of 32-bit version of glxinfo?
Showing 1-11 of 11 comments
< >
Per page: 15 30 50