Steam for Linux

Steam for Linux

nicaz0id. 2012년 12월 14일 오전 10시 11분
Issue Report: TF2 + fglrx: bad performance using dual monitor setup
Hi,

I use the latest AMD proprietary drivers 12.11 beta 11. TF2 runs fine and fluently when I disable my second monitor in the catalyst control center. However, if I enable my second monitor (TF2 runs on first screen) performance is very bad. The fps rate is very high, though. It is about 75fps, but the games feels like 30fps.

Processor Information: Vendor: AuthenticAMD Speed: 3200 Mhz 6 logical processors 6 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Unsupported SSE42: Unsupported Network Information: Network Speed: Operating System Version: "Fedora release 17 (Beefy Miracle)" (64 bit) Kernel Name: Linux Kernel Version: 3.6.9-2.fc17.x86_64 X Server vendor: Fedora Project X Server release: 11204000 Video Card: Driver: ATI Technologies Inc. ATI Radeon HD 5700 Series Driver Version: 4.2.11995 Compatibility Profile Context Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x1002 DeviceID: 0x68be Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 1080 Primary Display Size: 20,08" x 11,42" (23,07" diag) 51,0cm x 29,0cm (58,6cm diag) Primary VRAM Not Detected Sound card: Audio device: ATI R6xx HDMI Memory: RAM: 7985 Mb Miscellaneous: UI Language: English LANG: de_DE.utf8 Microphone: Not set Total Hard Disk Space Available: 933868 Mb Largest Free Hard Disk Block: 529228 Mb Installed software: Recent Failure Reports: Fri Dec 14 17:55:19 2012 GMT: file ''/tmp/dumps/assert_20121214185513_1.dmp'', upload yes: ''CrashID=bp-32c4cbb3-aa82-48c8-a4e3-3b5132121214''
< >
1-22개 댓글 표시
RussianNeuroMancer 2012년 12월 14일 오전 11시 23분 
Maybe you also can report this to AMD forum? http://devgurus.amd.com/community/steam-linux
GoldenStake 2012년 12월 15일 오후 12시 37분 
You can also try these tf2 work arounds, http://steamcommunity.com/app/221410/discussions/4/846939071127379989/
Playing with the settings didn't do very much for me as i already had poor performance with the lowest settings, but disabling the 12.11 optimizations helped.

Kano님이 먼저 게시:
You can disable the new optimisations as well (no x restart needed):
sudo sed -i s/hl2/hl3/ /etc/ati/atiogl.xml
To revert it:
sudo sed -i s/hl3/hl2/ /etc/ati/atiogl.xml

This worked for me because I had higher frame rates with an older build of the AMD Drivers.
and a lot of people with newer graphics cards had this error:
IDirect3DQuery9::GetData(): Occlusion query flush took 32.843ms!
< >
1-22개 댓글 표시
페이지당 표시 개수: 15 30 50