The Slippery One Dec 8, 2012 @ 6:50pm
Catalyst 11.8 reported?
I'm running 12.10 that's been continuously updated since 9.04, so there may be some cruft, but so far I'm pretty sure I have a fairly clean install. I'm running the absolute latest fglrx drivers that I can get my hands on (without resorting to external PPAs, anyway), but the CCC says my Catalyst is 11.8. Everything else seems pretty much up to date; I have a 4.2.11903 GL context, and all the log entries for the fglrx drivers in Xorg.0.log indicate that I'm running a build from roughly September.

I'm not sure why this would be reporting 11.8 unless it's loading libraries from somewhere in the search path that it shouldn't be (I haven't seen anything like that in Xorg.0.log, but I could have missed it). Does anyone else have this problem? I suspect it may be an issue of the built-up crap in the machine, but I'm not sure yet. I know I had lots of trouble making X in 12.10 behave, especially with Unity; I had to nuke all my window manager config files to make the second head work at all without Xinerama without going totally bonkers and stealing my cursor (it was really bad).

If anyone knows specifically which library is loaded that is reflected by the Catalyst version number, that would really help me scan the log files.
Showing 1-3 of 3 comments
< >
Letalis Sonus Dec 8, 2012 @ 6:56pm 
Originally posted by The Slippery One:
If anyone knows specifically which library is loaded that is reflected by the Catalyst version number, that would really help me scan the log files.
The only version number that is generally available is the one of the fglrx module itself, and that's a totally different one. The Catalyst version is something entirely internal, there is no additional library involved.
Kano Dec 9, 2012 @ 2:11am 
amdcccle parses /etc/ati, one file is not updated/deleted on upgrades. there is a .default file that would be used when the other is not there. it can be only wiped when x is shut down or radeon and not fglrx is running.
The Slippery One Dec 9, 2012 @ 6:54am 
I found that one online and tried it; now I don't get ANY Catalyst version reported. I also verified that when I purge fglrx* and reinstall that the /etc/ati directory is actually completely removed; it doesn't seem to change much. Ah, well. It doesn't really seem to affect anything, it just makes it a little harder to tell what version I'm on (but the big "Testing use only" watermark with the beta drivers is a pretty good indicator :-)).
Showing 1-3 of 3 comments
< >
Per page: 15 30 50