Steam for Linux > AMD Graphics Cards > รายละเอียดกระทู้
Evil Penguin 7 ธ.ค. 2012 @ 8:10am
Catalyst 12.11 beta 11 performance workaround for TF2
I've been messing around with different settings and I've found a few that just kill performance.
If you're experiencing major slow-downs since you upgraded to 12.11 beta 11, try these settings:

Model detail: any setting is fine
Texture detail: any setting is fine

Shader detail: should be set to "low" (you may want to test high to see if it it severely brings down performance or not)

Water detail: any setting is fine
Shadow detail: any setting is fine
Color Correction: any setting is fine

Antialiasing: must be disabled

Filtering: any setting is fine

Wait for vertical sync: must be disabled

Motion Blur: any setting is fine
Multicore Rendering: any setthing is fine

High Dynamic Range: must be disabled (this is a major performance killer for most)

It's important to quit and restart TF2 once you apply the settings.
Performance should now improve.

These settings were tested using:
Ubuntu 12.10 64-bit w/ Gnome 3.6
Radeon HD 7970 (Catalyst 12.11 beta 11)
FX-8150
16GB RAM
ได้รับการแก้ไขครั้งสุดท้ายโดย Evil Penguin; 14 ธ.ค. 2012 @ 5:22am
กำลังแสดง 1-15 จาก 21 ความเห็น
< >
Muffinabus 7 ธ.ค. 2012 @ 10:17am 
I'll give these a try and see what it does to my decent performance. Though I'll probably test out the defaults/recommended options whenever a new update or new drivers come out so I have a basis for performance enhancements.
Espionage724 7 ธ.ค. 2012 @ 10:54am 
I noticed that performance was great on TF2 when playing an offline bot match (100-200). Going to a MvM match though dropped FPS to around single-digit to 40. I noticed console was also spamming a good bit with some D3D9 query.
Kano 7 ธ.ค. 2012 @ 3:23pm 
You can disable the new optimisations as well (no x restart needed):
sudo sed -i s/hl2/hl3/ /etc/ati/atiogl.xml
To revert it:
sudo sed -i s/hl3/hl2/ /etc/ati/atiogl.xml
Evil Penguin 7 ธ.ค. 2012 @ 7:18pm 
โพสต์ดั้งเดิมโดย Kano:
You can disable the new optimisations as well (no x restart needed):
sudo sed -i s/hl2/hl3/ /etc/ati/atiogl.xml
To revert it:
sudo sed -i s/hl3/hl2/ /etc/ati/atiogl.xml
Good to know, but I think it works better with certain settings disabled/lowered than to disable the new optimizations (in this case).

I still get this error from time to time when playing.

IDirect3DQuery9::GetData(): Occlusion query flush took 32.843ms!
I seem to get that error in the console when there's massive frame hiccups.
ได้รับการแก้ไขครั้งสุดท้ายโดย Evil Penguin; 7 ธ.ค. 2012 @ 7:20pm
Kano 7 ธ.ค. 2012 @ 7:26pm 
The framerates are way over 60 with my hd 5670, does not matter if i disable the optimisations or not. At least i don't get the console flooded when it is disabled...
ได้รับการแก้ไขครั้งสุดท้ายโดย Kano; 7 ธ.ค. 2012 @ 7:26pm
Beelzebud 7 ธ.ค. 2012 @ 9:26pm 
Hey this really does work! Finally got my first enjoyable, completely playable match using the Linux client! I really hope AMD gets their drivers optimized soon, but the game doesn't look to terrible like this, and runs at full speed.

I'm using the very latest beta driver with a HD5770
ได้รับการแก้ไขครั้งสุดท้ายโดย Beelzebud; 7 ธ.ค. 2012 @ 9:26pm
Evil Penguin 8 ธ.ค. 2012 @ 12:41am 
I'm glad it worked for you.
lassmichrandadennsiewillja 8 ธ.ค. 2012 @ 4:30am 
โพสต์ดั้งเดิมโดย Kano:
You can disable the new optimisations as well (no x restart needed):
sudo sed -i s/hl2/hl3/ /etc/ati/atiogl.xml
To revert it:
sudo sed -i s/hl3/hl2/ /etc/ati/atiogl.xml


Disable the new optimisations made it playable on my 5770
Linux 8 ธ.ค. 2012 @ 6:59am 
I found an easy workaround, any file changes aren't needed. Before playing TF2, go to "ATI Catalyst Control Center" (amdcccle), next to "3D", then "More Settings" and uncheck "Enable Cataslyst A.I". Now game work as at 12.10 driver. After the game (or berfore other game) just revert all and check Catalyst A.I. for better performance.
Evil Penguin 8 ธ.ค. 2012 @ 8:02am 
โพสต์ดั้งเดิมโดย Linux:
I found an easy workaround, any file changes aren't needed. Before playing TF2, go to "ATI Catalyst Control Center" (amdcccle), next to "3D", then "More Settings" and uncheck "Enable Cataslyst A.I". Now game work as at 12.10 driver. After the game (or berfore other game) just revert all and check Catalyst A.I. for better performance.
Yeah, that would be the same as disabling 12.11 b11 specific optimization, but at a global scale.
I find beta 11 drivers to perform better unless specific settings are enabled.
GoldenStake 8 ธ.ค. 2012 @ 12:04pm 
Kano's script is also an apt work around for me.
HD7850
Beelzebud 8 ธ.ค. 2012 @ 12:40pm 
So with the command that kano suggests, can you run the game at full speed with Anti-Aliasing on and shaders on high?
Evil Penguin 8 ธ.ค. 2012 @ 12:41pm 
โพสต์ดั้งเดิมโดย Beelzebud:
So with the command that kano suggests, can you run the game at full speed with Anti-Aliasing on and shaders on high?
You can, but the performance may not be as high compared to having the settings like I recommend.
Megaknight 8 ธ.ค. 2012 @ 2:54pm 
Shader detail can be set to high. Running a 5870 with Catalyst 12.11 beta 11.
Muffinabus 8 ธ.ค. 2012 @ 3:20pm 
I just tried your optimizations and I'm averaging 200-300 FPS, up from 30-80. This was after turning HDR and shader detail off/low. AA was already defaulted to off on my setup.
กำลังแสดง 1-15 จาก 21 ความเห็น
< >
ต่อหน้า: 15 30 50