Rock86 Mar 23, 2013 @ 2:43pm
ATI Radeon HD 5670 - Performance problem
Hi all. I have a big problem with Steam games with my ATI Radeon 5670 card. The problem is: When I restart my PC and start game - game works fine. When I exit the game and use Chrome, Bashee player, Pidgin, Skype apps, and when I start game again (before I start the game, I close Skype, Pidgin, Chrome...), game is unplayable and some elements on map in Half Life 2: Deathmatch (beta) game are sometimes white. Only solution is to restart my PC and start Steam and game again.
I have this problem with Half Life 2: Deathmatch (beta), Shank 2, Team Tortress 2. I did not try other games. I am using Ubuntu 12.10 64bit, 13.3 beta 3 drivers. Same problem is on Ubuntu 12.04 and 13.04 and 13.1 and with all 13.2 beta drivers too.
On Windows 7 64bit, games work like a charm! When I play games on Windows, Skype is running, Chrome in running, AIMP3 is running, Windows LIive Messenger is running, and I have NO performance issues in this case on Windows.

My hardware specs:
MB: ASUS M4A87TD
CPU: AMD Phenom II X4 955 Black Edition
RAM: 8GB DDR3
VGA: Sapphire ATI Radeon HD 5670 with 512B GDDR5 memory

How to resolve this problem? Any idea?

Thanks a lot!
Showing 1-11 of 11 comments
< >
LOLCAT Mar 24, 2013 @ 2:46am 
Originally posted by Rock86:
How to resolve this problem? Any idea?

Thanks a lot!

Complain to AMD Support and wait for updated drivers.
Rock86 Mar 24, 2013 @ 2:48am 
I posted this messages on AMD forum too. Thank you!
Thyriel Mar 24, 2013 @ 2:48am 
That sounds like a pretty strange behavior, escpecially as you are using multiple Ubuntu versions all with the same problem.
What is your partition setup ? Perhaps a too small /tmp or swap partition ?
Rock86 Mar 24, 2013 @ 2:52am 
I have 1TB WD Black hard drive. / partiton is 80GB, swap is 8GB, /home partition is 904GB.
Thyriel Mar 24, 2013 @ 2:58am 
can you try "sudo swapoff -a" and see if that helps ?
that will turn off swap until next reboot
Rock86 Mar 24, 2013 @ 3:04am 
I will try this. I noticed that when I am using Skype before I played game, problem is 99% here it this case. I closed Skype before I started the game, but no luck. Only solution is rebooting PC.
Rock86 Mar 24, 2013 @ 3:49am 
Same situations is without swap too.
LOLCAT Mar 24, 2013 @ 5:47am 
Originally posted by Rock86:
I posted this messages on AMD forum too. Thank you!
AMD forum is not AMD support. Why bother/spam the community? Contact AMD the official way.
Rock86 Mar 24, 2013 @ 6:17am 
I sent report to AMD. Thank you.
Rock86 Apr 15, 2013 @ 10:57am 
I solved my problem. I bought NVIDIA GeForce 650 GTX with 2GB DDR5 memory and everything works fine!
I will never buy AMD card again! AMD drivers are crap!
LOLCAT Apr 15, 2013 @ 11:33am 
Though I agree that AMD linux drivers are bad if you look at their performance only, you bough a higher level card, so the comparison is not fair.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50