iFapToYourSister Mar 28 @ 3:32am
[Error] OpenGL is not using direct rendering
I installed Steam a few months back on my Xubuntu 13.10. I used the AMD Propretary Driver 14.3 beta. It worked but someday an update came and when I rebooted my laptop and it went black screen and I had to reinstall the drivers. After that Steam keeps showing this error message when I start it. Games also will not play.
OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457[/code
My specs:
Intel i7 4500U
AMD Radeon HD 8750M 2GB DDR3
Intel HD 4400 built in graphics
Xubuntu 13.10
Using fglrx-updates drivers from "Additional Drivers"

Also when I run
aticonfig
it outputs:
aticonfig: No supported adapters detected

When I run
glxinfo | grep "render"
it outputs:
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile

glxinfo | grep OpenGL
outputs:
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
OpenGL version string: 1.4 (3.0 Mesa 9.2.1)
OpenGL extensions:

ldconfig -p | grep libGL.so
outputs:
libGL.so.1 (libc6,x86-64) => /usr/lib/fglrx/libGL.so.1
libGL.so.1 (libc6) => /usr/lib32/fglrx/libGL.so.1
libGL.so (libc6,x86-64) => /usr/lib/fglrx/libGL.so

If any other information is needed please tell me. I tried all other similar discussions but nothing worked.
Last edited by iFapToYourSister; Mar 28 @ 3:39am
Showing 1-4 of 4 comments
< >
jonasan [#!] Apr 2 @ 9:55am 
tempted to suggest it's possible that your system is defaulting to the onboard intel rather than ati graphics chip and so your not getting proper opengl rendering.....

i'm not sure how switchabe graphics works these days on ubuntu (i think they have it sorted now) but on my older hardware i simply go into the bios and turn off the switchable graphics, forcing the system to use the amd card for all grpahics rendering.... with that and the ati driver installed things work fine for me....

so my suggestion is to look into switchable graphics and maybe even check if you can disable the onboard intel graphics in your bios.... best of luck
Last edited by jonasan [#!]; Apr 2 @ 9:55am
Letalis Sonus Apr 2 @ 2:54pm 
Haswell is still cutting edge, with a stock 13.10 system problems are guaranteed, even when ignoring the presence of the Radeon card.
iFapToYourSister Apr 6 @ 6:19pm 
Originally posted by jonasan #!:
tempted to suggest it's possible that your system is defaulting to the onboard intel rather than ati graphics chip and so your not getting proper opengl rendering.....

i'm not sure how switchabe graphics works these days on ubuntu (i think they have it sorted now) but on my older hardware i simply go into the bios and turn off the switchable graphics, forcing the system to use the amd card for all grpahics rendering.... with that and the ati driver installed things work fine for me....

so my suggestion is to look into switchable graphics and maybe even check if you can disable the onboard intel graphics in your bios.... best of luck
Thx the BIOS thing worked
jonasan [#!] Apr 27 @ 7:57am 
excellent, had forgotten about this thread... glad it worked for you ;)
Showing 1-4 of 4 comments
< >
Per page: 15 30 50