Steam for Linux > Non-Valve Games > Topic Details
Sirik Feb 15, 2013 @ 2:16pm
Bastion - In Game Menus
Does anyone else get the issue, where in-game menu's such as the inventory, armory etc.. instead of a selected item remaining selected, it behaves as if i am holding down the up arrow, which makes it very hard to select things....other than this its working great.
Showing 1-7 of 7 comments
< >
Dr0zD[SVK] Feb 16, 2013 @ 1:10am 
This (bug?) is affecting me also. Meanwhile I'm going to give a try to google this.

Ubuntu 12.04 64bit
Ati Radeon HD 6870 (13.2 beta 3)
Fluxbox
Last edited by Dr0zD[SVK]; Feb 16, 2013 @ 11:29am
Dr0zD[SVK] Feb 16, 2013 @ 1:15am 
So far: http://forums.steampowered.com/forums/showthread.php?t=2694727

However I don't have any controler and I have connected only mouse and keyboard.
Last edited by Dr0zD[SVK]; Feb 16, 2013 @ 1:16am
Sirik Feb 16, 2013 @ 1:26am 
I also only have a keyboard and mouse connected. I am running Ubuntu 12.04 64-bit Cinnamon with ATi 6870 using the 13.2 Beta drivers.
Dr0zD[SVK] Feb 16, 2013 @ 11:44am 
This is also affecting Unity DE. I messaged developer.
Dr0zD[SVK] Feb 19, 2013 @ 3:11am 
You probably have more-button mouse (as I do). Game probably recognize it as a controller.
After few tests, here is workaround which worked for me on my laptop. I will test it on my PC later this day. (laptop has touchpad, that could make difference)

WORKAROUND:
1. select Bastion in your Library (don't run it),
2. disconnect your mouse,
3. hit Enter, it should start the game (as if you clicked on Play button)
4. when menu shows, connect your mouse,
5. profit... :)
Mitko May 11, 2013 @ 6:56am 
I also suffer from this bug. I start playing with my controller and at first it seems ok, I can go into the in-game menus such as the inventory and select things. At some point though (I think it happens when I use the shield) it seems like something is constantly "pressing" the up arrow. The game menus always switch without me pressing any buttons and I can't control where the shield points to - it is ways pointing up.
kote-barbos Jul 21, 2013 @ 11:25am 
just remove /dev/input/js0 or other js (or all of them) - this fixes the issue
Showing 1-7 of 7 comments
< >
Per page: 15 30 50