Steam for Linux > Non-Valve Games > Topic Details
MikeDebian Jan 15, 2013 @ 7:11pm
Issue Report: Postal 2 Complete Linux - Very low FPS/Unplayable (Midrange system, AMD)
Ubuntu 12.10 AMD64
AMD FX-4100 @ 4.2 ghz
Asus Sabertooth AM3+ 990FX
4096 MB DDR3 1600 Corsair RAM
Saphire 7850 HD AMD Radeon
Catalyst 12.11 Beta 11
Software up to date.
VSYNC off, compiz undirect fullscreen windows option selected.

Before I get to the in-game menu the game runs smooth, but once it does it dips below 25~ FPS. After I've selected to start a new game and select a difficulty setting, the game runs smooth again.

Intro (after I've selected a new game) runs at about 5-15 FPS and once in-game I hit about 15-20 FPS.

Same rules applies if I go from medium settings (from 800x600) to full settings (1920x1080). Selecting hardware or software audio had no impact on these choices.

When I fire a machinegun, the FPS starts dropping until it hits 1 FPS and it's unable to go back up.

I have no other user applications running and I keep steam "minimized" (closed to Unity-bar) when running the game.

TF2, Amnesia, etc. runs smooth on max settings. Smooth for me is once it reaches 60 FPS.

The game is unplayable for me. If you need any more info, please ask. I couldn't find any other threads about it when googling it except for a windows problem where some people with dual core AMD machines experienced stuttering and the person with the problem was offered a few Windows programs to help with it. I set the affinity of the game using util-linux to use one core only, but this had no effect at all.