Steam for Linux > Non-Valve Games > Topic Details
cincon Dec 12, 2012 @ 5:00pm
[Solved] Issue: Cogs crashes after logo displayed
I can run Cogs with no problems from the command line in my user directory by

> Steam/SteamApps/common/Cogs/Cogs

Everything works including sound. If I run Cogs through Steam like this

>steam -applaunch 26500

Steam launches, then Cogs launches and I get this in the terminal window

AL lib: sdl.c:208: SDL_OpenAudio failed: No available audio device
Error creating OpenAL context. Error=0xA001

Black screen and I have to kill the process.

Not sure why Cogs runs fine on its own, but not when lauching through Steam?
I am using
-openSuse 12.2 64 bit, have all the 32 bit libs installed
-pulse audio is enable have the 32 bit pulse libs, also the ALSA pulse plugin

Also Cogs was working from Steam before, but I noticed and update to Steam happen Dec. 11 not sure if this has anything to do with it

Resolved by doing the following:
renamed Steam/SteamApps/common/Cogs/x86/libopenal.so.1 to libopenal.so.1.Backup
renamed Steam/SteamApps/common/Cogs/x86/libSDL-1.2.so.0 to libSDL-1.2.so.0.Backup

>ln -s /usr/lib/libopenal.so.1 libopenal.so.1
>ln -s /usr/lib/libSDL-1.2.so.0 libSDL-1.2.so.0

Cogs runs with sound and video settings to full
Last edited by cincon; Dec 28, 2012 @ 7:29pm