Steam for Linux > Non-Valve Games > 主題細節
12345678 2012 12 月 11 @ 3:18下午
Killing Floor initial report
There's 5 issues i'd like to report on:

1) The game always reverts to what I guess is the "default" character skin. The player has to change the skin every time he starts the game. See screenshot:
http://cloud.steampowered.com/ugc/1101392822569136052/B28900AEF108408FDB946E10C87A8A5D6F105FB7/

2) Stalkers have a silver texture, can be clearly seen from a far distance, the red glow does work when going Commando (silver replaced by red), and when the stalker is killed it looks normal. See screenshot: http://cloud.steampowered.com/ugc/1101392822569138984/F50EF6A2CE0CCA666D73B9182B0FEC0E6E3E0B61/

3) As you can see in the second screenshot, performance is pretty bad. Even though I'm on a g105m card, I should still be getting way more than 20 fps on lowest settings (which isnt even stable, if there is a flamethrower this occasionally drops to 10 fps).

4) The scrake with his chainsaw seems to be sort of glowing. His texture is brighter than all others.

5) One of the graphics options allows the player to select between Model (Low), Model (High), and Textured. The former two make scopes useless, as there simply is no vision. The textured setting does work.

Specs:
Ubuntu 12.10 64bit
default Unity
4gb ddr2
intel core 2 duo p8700 @ 2.53
nvidia geforce 105m 512mb
310.14 drivers
顯示 1-13,共 13 則回應
< >
marduk667 2012 12 月 12 @ 5:21上午 
Cannot confirm the problem with the stalkers, I am on an Intel Chip and I cannot see them until they are right in front of me...
12345678 2012 12 月 12 @ 7:07上午 
Must be a graphics driver thing then?

Another issue I want to add: perk levelling does work when in a game, but often as soon as the map changes the achieved progress is reset. I have reason to believe that this only happens when mutators are active, even simple mutators like the kill message one, as perk levelling does seem to work on a 100% vanilla server. Community maps without mutators also allow for levelling.
lurker 2012 12 月 12 @ 7:54上午 
I confirm it with nvidia-310.19 (geforce 630)

Westlondon:
1st load: http://s1.ipicture.ru/uploads/20121212/817bouTa.jpg
but have some bug with light: http://s1.ipicture.ru/uploads/20121212/x1LizjRo.jpg
stalker: http://s1.ipicture.ru/uploads/20121212/dFjDRTx3.jpg

but after effect "Motion blur" (monsters attack you when you dont have armor) textures disappear.
http://s1.ipicture.ru/uploads/20121212/1u3Ug3sE.jpg
lurker 2012 12 月 12 @ 10:05上午 
UP.
I'm tested it with 313.09.
Last issue fixed (textures are disapeared after "motion blur")
Stalker also "silver", but Husk texture fixed (he's now not black:))
That doesn't fixed: http://s1.ipicture.ru/uploads/20121212/x1LizjRo.jpg

Futhermore greatly decreased FPS =(
12345678 2012 12 月 12 @ 10:11上午 
Are you using the flashlight in that last screenshot? Cause I also had trouble getting the flashlight to work. Turning on Projectors yielded a solid grey projector trail, which I was going to report on but I couldn't reproduce it.
mikeym 2012 12 月 18 @ 10:07上午 
I think it's worth pointing out that there haven't been any updates to killing floor since I bought it on 21st Nov apart from the Christmas pack on the 13th Dec which as far as I can tell was just game content and contained no Linux fixes.

I assume icculus is still working on it, but I've not been able to get a peep out of Tripwire regarding it.
lurker 2012 12 月 18 @ 10:12上午 
They fixes brightness/gamma scrollers :) (they are not locked now)
But it's not enough...
[Linux] timopm 2012 12 月 18 @ 10:38上午 
I actually had 3 updates. One big one and 2 smaller, all in 2 or 3 days time.

The truck trailers and water falling down textures in one map (don't know the name) seem to be fixed. They used to show as full white/grey/silver-ish blocks.

There is one map, HilbillyHorror if I remember correctly, where I have serious lag when the waves appear. Even the first wave with about 20-30 zombies.
mikeym 2012 12 月 18 @ 11:04上午 
timopm 發表:
I actually had 3 updates. One big one and 2 smaller, all in 2 or 3 days time.

The truck trailers and water falling down textures in one map (don't know the name) seem to be fixed. They used to show as full white/grey/silver-ish blocks.

There is one map, HilbillyHorror if I remember correctly, where I have serious lag when the waves appear. Even the first wave with about 20-30 zombies.

Well, I'm still going to work on the assumption that the updates were related to the Christmas mods. At very least any updates have not fixed any of my issues.
12345678 2012 12 月 19 @ 5:20上午 
Maybe some updates don't get pushed through to the regular Killing Floor, but through an internal beta instead. Go to Killing Floor's listing, Properties, tab Betas, and you'll see there are a number of betas available including a Linux one (passworded). Might be worth pointing out that I'm not in that beta.
Niko 2012 12 月 19 @ 8:48上午 
The problem with low fps could be cause the 32bits version of nvidia-utils is different with the version of nvidia drivers, I had this problem yesterday on ArchLinux.
mikeym 2012 12 月 19 @ 9:10上午 
12345678 發表:
Maybe some updates don't get pushed through to the regular Killing Floor, but through an internal beta instead. Go to Killing Floor's listing, Properties, tab Betas, and you'll see there are a number of betas available including a Linux one (passworded). Might be worth pointing out that I'm not in that beta.

I am in the beta but unfortunately that does not mean that I have access the the KF beta. From what I can ascertain a number of games listed for Linux that don't have binaries yet have Linux betas with passwords. I suspect this setup is so developers can work on them. I assume KF is the same.
Juan 2012 12 月 22 @ 2:16下午 
I get really low fps as well, even on 640x480 the game renders unplayable when there's a bunch of enemies on screen. Both on an AMD E-350 APU and an Athlon X2 4400+ with an integrated GeForce 6150
顯示 1-13,共 13 則回應
< >
每頁: 15 30 50