Steam for Linux > Non-Valve Games > Ämnesdetaljer
ЫъГЬ 10 dec, 2012 @ 9:15am
Issue: Trine 2 fails to launch
It shows unsupported distro dialog (using zenity btw, which wasn't installed by default), resolution settings dialog (which is pretty garbled) and that's it, clicking Start Game just closes the window. TF2 and World of Goo both work perfectly.

The only errors it prints:
Game update: AppID 35720 "Trine 2", ProcID 25827, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
nohup: поток ошибок перенаправляются на стандартный вывод
Game removed: AppID 35720 "Trine 2", ProcID 25827
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Quick info: Debian testing x86_64, Nvidia blob 310.
Processor Information:
Vendor: GenuineIntel
Speed: 3058 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Debian GNU/Linux testing (wheezy) (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-2-amd64
X Server vendor: The X.Org Foundation
X Server release: 11204000

Video Card:
Driver: NVIDIA Corporation GeForce GT 520/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1040
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 16,14" x 9,06" (18,50" diag)
41,0cm x 23,0cm (47,0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1705

Memory:
RAM: 5983 Mb

Miscellaneous:
UI Language: English
LANG: ru_RU.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 258262 Mb
Largest Free Hard Disk Block: 26784 Mb

Installed software:

Recent Failure Reports:
Senast ändrad av ЫъГЬ; 10 dec, 2012 @ 9:16am
Visar 1-5 av 5 kommentarer
< >
OverratedPlot 10 dec, 2012 @ 11:33am 
I have the same problem on ArchLinux using nouveau.
Chocoboandmog 10 dec, 2012 @ 8:01pm 
While the message below is displayed it says "In-Game" on the Friends List. The game never actually starts. Then I click OK and it goes away and my Friends List displays "Online".

Message box:
Information

Trine 2 Launcher script

Unidentified Linux distribution.
If you have problems running the game, please see the game support web site for more info and ensure you have the required libraries installed.

System Info:
Computer
********

Summary
-------
-Computer-
Processor : 2x Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz
Memory : 3082MB (1144MB used)
Resolution : 1920x1200 pixels
OpenGL Renderer : GeForce 8600M GT/PCIe/SSE2
X11 Vendor : The X.Org Foundation
Audio Adapter : HDA-Intel - HDA Intel

Operating System
----------------
-Version-
Kernel : Linux 3.2.0-23-generic (x86_64)
Compiled : #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012
C Library : Unknown
Default C Compiler : GNU C Compiler version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
Distribution : Linux Mint 13 Maya
Desktop Environment : Cinnamon

Display
-------
-Display-
Resolution : 1920x1200 pixels
Vendor : The X.Org Foundation
Version : 1.11.3
-OpenGL-
Vendor : NVIDIA Corporation
Renderer : GeForce 8600M GT/PCIe/SSE2
Version : 3.3.0 NVIDIA 304.48
Direct Rendering : Yes

DMI
---
-BIOS-
Date : 11/19/2008
Vendor : Dell Inc.
Version : A12
-Board-
Name : 0D501F
Vendor : Dell Inc.
ЫъГЬ 11 dec, 2012 @ 12:11am 
Huh, I solved the issue by installing ia32-libs package (a bunch of i386 libs, I'm not exactly happy, but at least it works) as was suggested by Steam/SteamApps/common/Trine 2/bin/install_ubuntu_ia32_libs.sh
Wierd, no errors indicated anything like that.
Chocoboandmog 12 dec, 2012 @ 9:18am 
Ursprungligen skrivet av author:
Huh, I solved the issue by installing ia32-libs package (a bunch of i386 libs, I'm not exactly happy, but at least it works) as was suggested by Steam/SteamApps/common/Trine 2/bin/install_ubuntu_ia32_libs.sh
Wierd, no errors indicated anything like that.

Thanks a bunch! Now the game starts. I still get the message box saying "Unidentified Linux distribution". After I click OK the setting splash screen pops up. Then the game starts up after that. Sadly, I have to run the game on very low settings.
Senast ändrad av Chocoboandmog; 12 dec, 2012 @ 9:19am
dabbertorres 13 dec, 2012 @ 5:49pm 
I had the same issue too, but I manually ran the trine.sh once and the game played great. After that one time run, it now launches fine from Steam.
Visar 1-5 av 5 kommentarer
< >
Per sida: 15 30 50