Steam for Linux

Steam for Linux

Steam for Linux > Non-Valve Games > Topic Details
Pelo Dec 9, 2012 @ 12:12pm
Fix Killing Floor not running after splash screen
So I had KF installed and it runned well once, I changed some engine options and after that it didn't want to run, I only got the splash screen and then the game died. To fix this I had to delete "KillingFloor.ini" located at /home/.killingfloor/System instead of the one in /home/.steam/steam/SteamApps/common/KillingFloor/System

It is quite simple but I'm posting it because I may not be the only one who had this problem, and this could help more than one.
Last edited by Pelo; Dec 9, 2012 @ 12:13pm
< >
Showing 1-6 of 6 comments
Juan Dec 9, 2012 @ 5:09pm 
You probably changed the engine from OpenGL to Direct3D.
Pelo Dec 9, 2012 @ 7:22pm 
Originally posted by Juan:
You probably changed the engine from OpenGL to Direct3D.

Haha yes, that's what I did, but oh well... Curiosity isn't that bad sometimes
Fornax Dec 24, 2012 @ 8:10am 
Thank you, you saved my life!
masterr Dec 24, 2012 @ 6:10pm 
The smart fix would be to remove the D3D option completely from the Linux build. Hopefully they do that soon. In the mean time thanks for the tip for those that run into this accidentally.
Last edited by masterr; Dec 24, 2012 @ 6:10pm
Raspen Apr 3, 2013 @ 5:26am 
Thanks alot, i think i reinstalled the game 4-5 times before i found this :)
A Jaded Lizard Mar 2, 2014 @ 8:15pm 
I have this same issue on the PC. I've reinstalled twice and the game patently refuses to load, even though Steam INSISTS there is nothing wrong with it. Just downloaded some mods (all but one of which came form the workshop; probably the last time I use that), and now the game won't start. Not impressed.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Steam for Linux > Non-Valve Games > Topic Details