Steam for Linux > Non-Valve Games > 主题详情
skiesbleed 2012年12月8日上午12:09
Issue Report: Trine 2 Sometimes Doesn't Full Screen Over Unity
A few times now, I've noticed that, although configured to be full screen, Trine 2 will not take up the entire screen, leaving the Unity bar and top menu panel in-screen. This doesn't always happen, but it's happened about 50% of the time for me.

Picture: https://www.dropbox.com/s/fqlvrvibk5onv5v/2012-12-08%2000.48.19.jpg

Logs: http://pastebin.com/Akx860x5

System Information:

Processor Information:
Vendor: GenuineIntel
Speed: 2001 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-29-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 560M/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1251
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 15.04" x 8.46" (17.24" diag)
38.2cm x 21.5cm (43.8cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 3071 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC269VB

Memory:
RAM: 16026 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 340924 Mb
Largest Free Hard Disk Block: 297149 Mb
正在显示第 1 - 3 条,共 3 条留言
< >
notecx 2012年12月8日上午6:57 
You can try this:

go to ~/.frozenbyte/Trine2/options.txt, find this lines

.......
setOption(renderingModule, "MaximizeWindow", false)
.......
setOption(renderingModule, "ForceFullscreenWidth", 0)
setOption(renderingModule, "ForceFullscreenHeight", 0)
.......

and make them like this

.......
setOption(renderingModule, "MaximizeWindow", true)
.......
setOption(renderingModule, "ForceFullscreenWidth", 1920)
setOption(renderingModule, "ForceFullscreenHeight", 1080)
.......

1920 and 1080 your actual width and height, obviously.
Works for me.
Also, I blocked options.txt for edit, just in case.
最后由 notecx 编辑于; 2012年12月8日上午6:59
skiesbleed 2012年12月8日上午9:17 
I tried launching the game six times after applying those changes, and I didn't see the problem again. It looks like that workaround works. Thanks.
Melo 2013年2月22日上午1:25 
I have a problem that's related to this.

I applied the settings from this post to my options.txt file and the game starts up in fullscreen mode just fine.

BUT: Whenever I minimize the game, by pressing ALT, SUPER, CTRL+SUPER+D or whatever, and maximize it again, Unity remains on top, just like in your screenshot. This means, that you can start up the game in fullscreen, but as soon as you tab out and back in, Unity is in the way again and you need to restart the game to go back to fullscreen.

Do you guys also experience this problem?
Any ideas how to solve this?
正在显示第 1 - 3 条,共 3 条留言
< >
每页显示数: 15 30 50