Steam for Linux > Non-Valve Games > 主題細節
idle sign 2012 年 12 月 7 日 @ 下午 10 時 19 分
GitHub: Amnesia: Unable to start due to launcher issue
Launcher window appears with canvas filled with the contents of an underlaying window (e.g. steam), and from now the only way to close the launcher is killing its process. This behaviour prevents from launching the game.
最後修改者:johndrinkwater [🐧︀ 🎮]; 2013 年 01 月 3 日 @ 上午 6 時 54 分
顯示 1-15,共 20 則回應
< >
Decay 2012 年 12 月 8 日 @ 上午 12 時 06 分 
Seeing the same behavior. The Steam console log logs the following on creation of the dead launcher window:

X_ChangeProperty: BadValue (integer parameter out of range for operation) 0x0

I can kill the window with the window frame close button and the launcher will attempt to create a new one, logging the same error and displaying the same behavior.

EDIT: It works if I navigate to the SteamApps/common/Amnesia The Dark Descent directory and execute ./run_steam.sh manually. The same console error message is logged which would suggest it's spurious and unrelated to the incorrect behavior from inside Steam.
最後修改者:Decay; 2012 年 12 月 8 日 @ 上午 12 時 09 分
Veovis 2012 年 12 月 8 日 @ 上午 8 時 33 分 
Same problem here and same error.
It works also for me launching it manually, as you said.
Eduren 2012 年 12 月 8 日 @ 下午 7 時 41 分 
Confirmed. The amnesia launcher copies the underlying area. I was able to get the game to run by clicking in the launcher where the play button is located.
obedlink 2012 年 12 月 10 日 @ 上午 11 時 35 分 
confirmed, if you run the game from. / run_steam.sh or. / Launcher.bin, the launcher looks good.

but if you run the game from the Steam client looks like.
http://img571.imageshack.us/img571/6852/amnesiaiusseslauncher.jpg
Że Bro 2012 年 12 月 10 日 @ 上午 11 時 40 分 
Same problem. The non-steam version from Ubuntu Software Center worked fine.
Rick Regger 2012 年 12 月 10 日 @ 下午 12 時 30 分 
i have the same problem. launcher windows opens and freezes.
Vorron 2012 年 12 月 10 日 @ 下午 3 時 11 分 
Confirm the same. While game started by Amnesia.bin works fine.
oraknabo 2012 年 12 月 11 日 @ 上午 8 時 41 分 
I'm getting this too on Manjaro (ArchLinux). Seems like it's exactly the same. I get a frozen screenshot in the launcher window and clicking around at random in the lower middle of the launcher launches the game which works fine.
dancemasterglenn 2012 年 12 月 11 日 @ 上午 11 時 00 分 
I'm also experiencing this issue. Can post hardware specs if it is relevant, but it sounds like it is specifically a Steam issue?
danigpino 2012 年 12 月 12 日 @ 上午 12 時 55 分 
Same problem for me. I haven't tried running it from Launcher.bin, I'll try later.
powrtoch 2012 年 12 月 12 日 @ 上午 2 時 39 分 
This sounds related to a similar problem I have got with the Trine 2 launcher:

http://steamcommunity.com/app/221410/discussions/1/882966056893600208/

Have you tried disabling the Steam Overlay and then starting the game again?
Vorron 2012 年 12 月 12 日 @ 上午 3 時 29 分 
GNU/Leenooks 發表:
Have you tried disabling the Steam Overlay and then starting the game again?

Oh, that's right. Without Steam Overlay game launcher is OK. But anyway it's a bug.
WarBearFace 2012 年 12 月 12 日 @ 下午 6 時 56 分 
As annoying is it is, I can confirm if you blindly click where the play game button is, the game will launch. So if you need to do configuration just run the launcher seperately, run the game to save the settings, and then launch it through steam. Or just do it in game and restart the game.
Gabby Gums 2012 年 12 月 13 日 @ 上午 4 時 57 分 
i have the same problem. Launcher windows opens and freezes.

Pentium 4 HT 3.2
3 Gb Ram, NVIDIA 7600GT 256Mb AGP

EDIT: But the run_steam.sh works, good tip.
最後修改者:Gabby Gums; 2012 年 12 月 13 日 @ 上午 5 時 30 分
powrtoch 2012 年 12 月 13 日 @ 上午 5 時 37 分 
Vorron 發表:
GNU/Leenooks 發表:
Have you tried disabling the Steam Overlay and then starting the game again?

Oh, that's right. Without Steam Overlay game launcher is OK. But anyway it's a bug.
Indeed - but this means that the Steam developers know what's messing up the launcher.
We'll hopefully see a fix soon.
顯示 1-15,共 20 則回應
< >
每頁: 15 30 50