Steam for Linux

Steam for Linux

Steam for Linux > Non-Valve Games > Topic Details
≫HarZe Dec 7, 2012 @ 6:23am
Trine 2: Fullscreen on 2 monitors
I have 2 monitors, to play the game I have to run it on a window, with less than 1080p. To play with 1920x1080, running into fullscreen, it uses both screens in stead of one (just like TF2 does) and the start bar does not hide behind the game. It is fully playable but those details are annoying.

Processor Information: Vendor: GenuineIntel Speed: 3599 Mhz 8 logical processors 4 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Linux Mint 14 Nadia (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-17-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: NVIDIA Corporation GeForce GTX 670/PCIe/SSE2 Driver Version: 4.3.0 NVIDIA 310.14 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x10de DeviceID: 0x1189 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 3840 x 1080 Primary Display Size: 20,91" x 11,77" (23,98" diag) 53,1cm x 29,9cm (60,9cm diag) Primary Bus: PCI Express 16x Primary VRAM: 2048 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: Realtek ALC892 Memory: RAM: 18056 Mb Miscellaneous: UI Language: English LANG: es_ES.UTF-8 Microphone: Not set Total Hard Disk Space Available: 95997 Mb Largest Free Hard Disk Block: 66183 Mb Installed software: Recent Failure Reports:
< >
Showing 1-5 of 5 comments
evdubs Dec 7, 2012 @ 5:32pm 
I have a similar setup where I use nVidia's TwinView for my dual monitor 1920x1200 setup. You should be able to force your 1920x1080 resolution in ~/.frozenbyte/Trine2/options.txt. Find the options ForceFullscreenWidth and ForceFullscreenHeight to 1920 and 1080, respectively.

It looks like this is related to the trine2_bin_starter.sh script that sets the FB_FULLSCREEN_WIDTH and FB_FULLSCREEN_HEIGHT environment variables from the result of xwininfo output. xwininfo doesn't know about the TwinView setup, so it assumes your primary display resolution is 3840x1080. Either overriding those environment variables or setting the ForceFullscreen options should do the trick. These files don't seem to be overwritten during an update, so you shouldn't have to worry about modifying these files after each game update.
LorD_D'DooM Dec 8, 2012 @ 4:18am 
This problem started occurring somewhere between Ubuntu 11.10 and Ubuntu 12.04 LTS. In Oneiric fullscreen on multimonitor was functioning properly, You could specify the monitor for fullscreen app and the spanning did not occur, everthing worked fine. However in Precise, the handling with fullscreen apps has changed, so some programs are now broken in fullscreen. I am not sure what caused the issue, because some programs still work fine (HoN, UFO:AI, TF2, most wine apps), but majority of them do not. For me, Trine 2 also spans accross both monitors, regardless of set resolution.
However I am sure that I did not have those problems in Maveeric or Oneiric, first problems started in Precise.

My specs:
Processor Information: Vendor: GenuineIntel Speed: 3000 Mhz 2 logical processors 2 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-19-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: X.Org Gallium 0.4 on AMD REDWOOD Driver Version: 2.1 Mesa 9.0 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x1002 DeviceID: 0x68d8 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1680 x 1050 Desktop Resolution: 2960 x 1050 Primary Display Size: 18.50" x 11.81" (21.93" diag) 47.0cm x 30.0cm (55.7cm diag) Primary VRAM Not Detected Sound card: Audio device: Realtek ALC889A Memory: RAM: 3953 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 469353 Mb Largest Free Hard Disk Block: 352576 Mb
xrandr --current Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 8192 x 8192 HDMI-0 disconnected (normal left inverted right x axis y axis) DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 470mm x 300mm 1680x1050 60.0*+ 1600x1000 60.0 1680x945 60.0 1400x1050 74.9 59.9 1600x900 60.0 1280x1024 85.0 75.0 60.0 1440x900 84.8 75.0 59.9 1280x960 85.0 60.0 1366x768 60.0 1360x768 60.0 1280x800 84.9 74.9 59.9 1152x864 75.0 1280x768 84.8 74.9 60.0 1024x768 85.0 75.1 70.1 60.0 1024x576 60.0 832x624 74.6 800x600 85.1 72.2 75.0 60.3 56.2 848x480 60.0 640x480 85.0 72.8 75.0 60.0 720x400 85.0 70.1 640x400 85.1 640x350 85.1 VGA-0 connected 1280x1024+1680+0 (normal left inverted right x axis y axis) 376mm x 301mm 1280x1024 60.0*+ 75.0 1280x960 60.0 1280x800 74.9 59.8 1152x864 75.0 1280x768 74.9 59.9 1024x768 75.1 70.1 60.0 1024x576 60.0 832x624 74.6 800x600 72.2 75.0 60.3 56.2 848x480 60.0 640x480 72.8 75.0 66.7 60.0 720x400 70.1
direct rendering: Yes server glx vendor string: SGI server glx version string: 1.4 server glx extensions: client glx vendor string: Mesa Project and SGI client glx version string: 1.4 client glx extensions: OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD REDWOOD OpenGL version string: 2.1 Mesa 9.0 OpenGL shading language version string: 1.30 OpenGL extensions: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Redwood [Radeon HD 5670] Linux CENTURION 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Eric Dec 9, 2012 @ 3:36pm 
Originally posted by evdubs:
You should be able to force your 1920x1080 resolution in ~/.frozenbyte/Trine2/options.txt. Find the options ForceFullscreenWidth and ForceFullscreenHeight to 1920 and 1080, respectively.
Thanks so much! This made the game playable for me in fullscreen mode! I'm running a Radeon HD 6800 on a triple monitor setup.
≫HarZe Dec 9, 2012 @ 4:40pm 
Originally posted by EricL:
Originally posted by evdubs:
You should be able to force your 1920x1080 resolution in ~/.frozenbyte/Trine2/options.txt. Find the options ForceFullscreenWidth and ForceFullscreenHeight to 1920 and 1080, respectively.
Thanks so much! This made the game playable for me in fullscreen mode! I'm running a Radeon HD 6800 on a triple monitor setup.

Yeah, thanks eydubs for the trick.

Playing it on 2 monitors is not comfortable, character is in the middle, just where virtual screen "splits". 3 monitors is near to be cheating xDD
siyman Feb 20, 2013 @ 3:19am 
Thanks, saved me a lot of time. Although, I can't unterstand why trine2 is storing its config files under my home directory when there is a steam dir as well.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Steam for Linux > Non-Valve Games > Topic Details