Steam for Linux > Non-Valve Games > 主題細節
JD 2012 年 12 月 7 日 @ 上午 12 時 54 分
Issue Report: The Book of Unwritten Tales crashes immediately
I've never been able to run the game, it crashes immediately after clicking Play on the Steam client.

I guess the problem is related to this error:
*** Initializing OIS ***
X Error of failed request: BadAccess (attempt to access private resource denied)
Major opcode of failed request: 2 (X_ChangeWindowAttributes)
Serial number of failed request: 7
Current serial number in output stream: 9
Full log[]

Processor Information:
Vendor: GenuineIntel
Speed: 2301 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (32 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 670M/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1213
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3840 x 1080
Primary Display Size: 15,04" x 8,46" (17,24" diag)
38,2cm x 21,5cm (43,8cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 3071 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1802

RAM: 16168 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 432903 Mb
Largest Free Hard Disk Block: 4974 Mb

Installed software:

Recent Failure Reports:
最後修改者:JD; 2012 年 12 月 7 日 @ 上午 12 時 56 分
顯示 1-15,共 24 則回應
< >
nieknooijens 2012 年 12 月 7 日 @ 上午 1 時 11 分 
at my pc it fails to start from the steam client, but executing ~/Steam/steamApps/Common/The Book Of Unwritten Tales/ will start the game without any problems
Oniryck 2012 年 12 月 7 日 @ 上午 1 時 31 分 
I can confirm the problem AND the solution offered by nieknooijens. But if you try to go into the settings, the game crashes again it seems (segfault)
JD 2012 年 12 月 7 日 @ 上午 1 時 41 分 
nieknooijens 發表:
at my pc it fails to start from the steam client, but executing ~/Steam/steamApps/Common/The Book Of Unwritten Tales/ will start the game without any problems

Interesting, same here, but it will not start unless I run the script from within its directory:

jd@G75VW:~$ ~/Steam/SteamApps/common/The\ Book\ of\ Unwritten\ Tales/
/home/jd/Steam/SteamApps/common/The Book of Unwritten Tales/ row 22: ./bin/32/kAGE: File or directory not found

No problem with the Settings here.
最後修改者:JD; 2012 年 12 月 7 日 @ 上午 1 時 42 分
Oktoras 2012 年 12 月 7 日 @ 上午 3 時 34 分 
Uhh, first day in beta and I already ended up purchasing this game... I also got this crash problem.

I realized if I disable game overlay (Steam settings/IN-GAME - de-select Enable steam community in-game) the game runs perfectly.

I am running Fedora 18 beta x64, so not exactly supported configuration - I did modify the startup script little bit because it tried to run gksudo dpkg to install ia32-libs , but Fedora does not have gksudo, dkpg or ia32-libs... I installed the dependencies manually.
GettingMental 2012 年 12 月 7 日 @ 上午 4 時 18 分 
Exact same problem here on ubuntu 12.04 x64. With the stock Steam configuration, the game exits immediately. TF2 works like a charm on the other hand.
rudeboyskunk 2012 年 12 月 7 日 @ 上午 6 時 09 分 
Just bought this game cuz I saw it on sale, and having the same problem.
sh4nks 2012 年 12 月 7 日 @ 上午 8 時 20 分 
I can start it via but when I go to the settings, it crashes immediatly.
I'm using Arch (x86_64).
Oktoras 2012 年 12 月 7 日 @ 上午 9 時 38 分 
Me too - if I start the game via, it works, but going to settings will crash the game immediately.

Via steam client, it only works when game overlay is disabled.
sheehanje 2012 年 12 月 7 日 @ 上午 9 時 42 分 
I can get the game to run starting Steam with sudo, but the mouse jitters and is near impossible to click anything. Running Ubuntu 12.04 with the beta AMD drivers (Radeon HD6870).

On subsequent runs it CTD's unless I reboot my machine.
simskog95 2012 年 12 月 7 日 @ 上午 9 時 44 分 
The demo crashes for me. I managed to get into the game but when i pressed start it crashed. terminal displayed render problem i think. I will try to recreat it and copy the error massage and paste it here.
最後修改者:simskog95; 2012 年 12 月 7 日 @ 上午 9 時 45 分
Sir_Brizz 2012 年 12 月 7 日 @ 上午 10 時 17 分 
Disable the overlay and it should run fine now. I'm on ATI but I was able to go into settings and play the game.
最後修改者:Sir_Brizz; 2012 年 12 月 7 日 @ 上午 10 時 17 分
McRaia [Linux] 2012 年 12 月 7 日 @ 上午 11 時 27 分 
Disabling "Steam Community In-Game" in the general properties of the game did the trick.

fac3l3ss 2012 年 12 月 7 日 @ 上午 11 時 35 分 
I can confirm that the game works if the overlay is disabled. My machine runs Ubuntu 12.04 x64 with kernel 3.5 and amd proprietary drivers. No problems with the settings as well. Only "problem" I have is with the black bars on the sides, but that's totally unrelated with linux. The game just wasn't made for 16:9 screens :(
Jafinto 2012 年 12 月 7 日 @ 下午 12 時 32 分 
sh4nks, Oktoras, the problem you are having is covered by this issue report.
DarkStarSword 2012 年 12 月 9 日 @ 下午 9 時 56 分 
Same bug + workaround confirmed in The Critter Chronicles.
顯示 1-15,共 24 則回應
< >
每頁: 15 30 50