Steam for Linux > Non-Valve Games > Detalhes do tópico
Skomli 6 Dez, 2012 às 16:15
Issue Report: The Book of Unwritten Tales crashes when launching settings
After the last update The Book of Unwritten Tales starts, but when clicking on "Settings" ingame it crashes. Beside of that the game seems to work (but just tested it for a few minutes).

Command line output: http://pastebin.com/LUq9MyuW

Sysinfo:
Prozessor:
Hersteller: GenuineIntel
Geschwindigkeit: 3301 MHz
4 logische Prozessoren
4 technische Prozessoren
HyperThreading: Nicht unterstützt
FCMOV: Unterstützt
SSE2: Unterstützt
SSE3: Unterstützt
SSSE3: Unterstützt
SSE4a: Nicht unterstützt
SSE41: Unterstützt
SSE42: Unterstützt

Netzwerk-Informationen:
Netzwerk-Geschwindigkeit:

Betriebssystem:
Ubuntu 12.04.1 LTS (64 Bit)
Kernel-Name: Linux
Kernel-Version: 3.2.0-34-generic
X-Server-Vendor: The X.Org Foundation
X-Server-Release: 11103000

Grafikkarte:
Treiber: ATI Technologies Inc. AMD Radeon HD 6800 Series

Treiber-Version: 4.2.11978 Compatibility Profile Context
Desktop-Farbtiefe: 24 Bit per Pixel
Monitor-Aktualisierungsrate: 60 Hz
Anbieterkennung: 0x1002
Gerätekennung: 0x6738
Anzahl der Monitore: 1
Anzahl der logischen Grafikkarten: 1
Prim. Anzeigeauflösung: 1920 x 1080
Desktop-Auflösung: 1920 x 1080
Prim. Anzeigegröße: 52,1 cm x 29,3 cm (59,7 cm diag.)

Kein prim. VRAM entdeckt

Soundkarte:
Audiogerät: Realtek ALC892

Speicher:
RAM: 7958 MB

Weitere Daten:
UI-Sprache: Deutsch (Deutsch)
LANG: de_DE.UTF-8
Mikrofon: Not set
Verfügbarer Festplattenspeicher insgesamt: 86399 MB
Größter freier Festplattenspeicherblock: 52355 MB

Installierte Software:

Recent Failure Reports:
A mostrar 1-15 de 27 comentários
< >
Jafinto 7 Dez, 2012 às 12:29 
I can reproduce this issue. System info at the bottom of this page.

If I replace the RenderSystem_GL.so with one that I compiled[dl.dropbox.com] myself (taken from the Ubuntu 12.04 package source), I can access the settings menu. Note: I do not recommend running libraries one has downloaded from the internet.

System info:
Processor Information:
Vendor: AuthenticAMD
Speed: 2608 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. ATI Radeon HD 5700 Series

Driver Version: 4.2.11995 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x68be
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1440 x 900
Desktop Resolution: 1440 x 900
Primary Display Size: 16.14" x 10.12" (19.02" diag)
41.0cm x 25.7cm (48.3cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: ATI R6xx HDMI

Memory:
RAM: 3953 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 938900 Mb
Largest Free Hard Disk Block: 118512 Mb

Installed software:

Recent Failure Reports:
excieve 7 Dez, 2012 às 14:43 
I confirm that. Replacing RenderSystem_GL.so with the one provided by Jafinto stops settings from crashing for me as well.
sorath 8 Dez, 2012 às 12:01 
I confirm crashing while trying to enter Settings menu in Demo of game.
I tried to use RenderSystem_GL.so from ubuntu binary package (on my Gentoo system) of libogre 1.7.4 and 1.8.0 but unsuccessfully. It's strange that their size differ from library placed in game folder (1.4 mb of original and 1.0 mb of downloaded from repository)
sorath 8 Dez, 2012 às 12:38 
Originalmente postado por Jafinto:
I can reproduce this issue. System info at the bottom of this page.

If I replace the RenderSystem_GL.so with one that I compiled[dl.dropbox.com] myself (taken from the Ubuntu 12.04 package source), I can access the settings menu. Note: I do not recommend running libraries one has downloaded from the internet.

Jafinto, what version of ogre did you compile? And why chosen Ubuntu 12.04 package source instead native Ubuntu 12.10?
sorath 8 Dez, 2012 às 12:54 
I have download libogre-1.7.4-3 from Precise (Ubuntu 12.04) repository for i386[packages.ubuntu.com], took from this archive RenderSystem_GL.so library and place to '$gamepath$/lib/32/'. Now I can to reach Settings menu :)

I also try 1.7.4-5 and 1.8.0 from Ubuntu Quantal branch but gain Aborted error again trying go to Settings menu in game.
Jafinto 8 Dez, 2012 às 14:42 
Originalmente postado por sorath:
Jafinto, what version of ogre did you compile? And why chosen Ubuntu 12.04 package source instead native Ubuntu 12.10?

I used the libogre-1.7.4-3 package from the Ubuntu 12.04 repository. I used that one as I wanted to debug the library to find the error, and I didn't have a 12.10 VM around.
sorath 8 Dez, 2012 às 15:01 
I just saw at your system info
Operating System Version:
Ubuntu 12.10 (64 bit)
:)
So at least it's good news that game work with 'RenderSystem_GL.so' of 'libogre-1.7.4-3' (32bit) compiled and binary package replaced original that placed in game directory.
Lysius 8 Dez, 2012 às 17:23 
I had this crash only once. After restarting the game, I can now enter the settings menu without a problem. I did not have to modify any libraries.
I'm on Fedora 17 (64 bit).
[LINUX]FinCoder 9 Dez, 2012 às 2:55 
It doesn't even start on me. I tried to create a thread, but cannot see it nowhere!

ParticleUniverse: Particle Emitter Type 'Entity' registered
*** Initializing OIS ***
X Error of failed request: BadAccess (attempt to access private resource denied)
Major opcode of failed request: 2 (X_ChangeWindowAttributes)
Serial number of failed request: 7
Current serial number in output stream: 8
AL lib: ReleaseALC: 1 device not closed
Game removed: AppID 226540 "The Book of Unwritten Tales: The Critter Chronicles Demo", ProcID 2311
saving roaming config store to 'sharedconfig.vdf'
Jafinto 9 Dez, 2012 às 3:40 
FinCoder, your issue is covered here. You can work around it by disabling "Steam Community In-Game" from the properties menu of the game.
Última alteração por Jafinto; 9 Dez, 2012 às 3:41
[LINUX]FinCoder 9 Dez, 2012 às 5:28 
You are right that did fix my problem. The game is working after taking the ingame community off.
garisboing 9 Dez, 2012 às 7:33 
Originalmente postado por Lysius:
I had this crash only once. After restarting the game, I can now enter the settings menu without a problem. I did not have to modify any libraries.
I'm on Fedora 17 (64 bit).

I'm on Fedora 17 KDE 32 bit
The game segfaults when trying to access settings consistently.

Processor Information:
Vendor: GenuineIntel
Speed: 2499 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
"Fedora release 17 (Beefy Miracle)" (32 bit)
Kernel Name: Linux
Kernel Version: 3.6.9-2.fc17.i686
X Server vendor: Fedora Project
X Server release: 11204000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 560 Ti/PCIe/SSE2

Driver Version: 4.2.0 NVIDIA 304.64
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1200
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 19.45" x 12.60" (23.15" diag)
49.4cm x 32.0cm (58.8cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Analog Devices AD1989B

Memory:
RAM: 3284 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 165709 Mb
Largest Free Hard Disk Block: 121237 Mb

Installed software:

Recent Failure Reports:

DarkStarSword 9 Dez, 2012 às 21:56 
Same bug + workaround confirmed in The Critter Chronicles.
mannerov 11 Dez, 2012 às 4:19 
I played the Critter Chronicles demo with this fix, But I'm getting an issue:
When changing the resolution in Settings and restarting the game, the resolution is correctly set but the images are drawn as if the resolution was the same than before: If I set a lower resolution than my max resolution supported, The bottom and the right of the game are missing. That may be due to the fix.
Última alteração por mannerov; 11 Dez, 2012 às 8:15
Banshee 22 Dez, 2012 às 12:50 
Ubuntu 12.10 x86_64, same issue with settings, overlay is disabled. Did not try the workaround yet, probably works as for everyone.
A mostrar 1-15 de 27 comentários
< >
Por página: 15 30 50