Steam for Linux > Non-Valve Games > Topic Details
paol Dec 6, 2012 @ 3:31pm
GitHub: Superbrothers Sword & Sworcery EP - does not start due to missing libraries (with fix)
I'm leaving this here to help if anyone has the same problem. On my 64bit Ubuntu system the game didn't launch due to missing 32bit libraries. The following command installs the missing packages:

sudo apt-get install libcurl3:i386 libglu1-mesa:i386

Note: to diagnose this kind of problem look for lines like this in the Steam console output:
./swordandsworcery_pc: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory
Last edited by johndrinkwater [🐧︀ 🎮]; Jan 3, 2013 @ 7:42am
Showing 1-11 of 11 comments
< >
Recoil_84 Dec 6, 2012 @ 7:31pm 
Thanks for the helpful post! Same issue occurred for me on 64-bit Fedora x64. Installing the 32bit library solved it.

sudo yum install libcurl.i686
Max Power Dec 7, 2012 @ 4:33am 
Thanks for the fix!
Batousay Dec 7, 2012 @ 5:25am 
Thanks!.

It worked like a charm!.
Chocoboandmog Dec 8, 2012 @ 9:39pm 
Thanks! I had the same issue on Linux Mint 13 (Maya) cinnamon x64. Now it starts up fine.

FTW
sudo apt-get install libcurl3:i386 libglu1-mesa:i386
Last edited by Chocoboandmog; Dec 10, 2012 @ 8:20pm
Neeps Dec 9, 2012 @ 10:48pm 
Thank you, this helped me :)
kmh42 Dec 11, 2012 @ 12:58pm 
Thx for fix.
Works great on elementaryOS luna beta
PSeeCO Dec 23, 2012 @ 4:26pm 
Thank you so much, it worked!
capt. exe Dec 28, 2012 @ 9:20am 
Did anyone manage to fix the same problem in Arch Linux?
johndrinkwater [🐧︀ 🎮] Jan 3, 2013 @ 7:42am 
Github has a report for the libcurl issue now, https://github.com/ValveSoftware/steam-for-linux/issues/251
johndrinkwater [🐧︀ 🎮] Jan 3, 2013 @ 7:44am 
https://github.com/ValveSoftware/steam-for-linux/issues/439 is for libglu, but that is more likely the graphics drivers missing the library rather than the game
p.castro Dec 28, 2013 @ 10:11pm 
Originally posted by capt. exe:
Did anyone manage to fix the same problem in Arch Linux?

Here I have some 32bit libs installed:
lib32-curl
lib32-alsa-plugins
lib32-libpulse

All these were mentioned when I searched about issues with Superbrothers. Some reported that lib32-glu is also needed, but here it's not installed and the game is running well (so far).

To install one of these libs (e.g. lib32-libpulse):
* Enable the multilib repository
* Update the package list typing "sudo pacman -Syy" on a terminal
* Install the lib typing "sudo pacman -S lib32-libpulse" on a terminal

The first two itens you only need to do one time. Once they are done, you can install all packages mentioned in this post.

Check the ArchWiki if you run into more issues and good luck!
Last edited by p.castro; Dec 28, 2013 @ 10:12pm
Showing 1-11 of 11 comments
< >
Per page: 15 30 50