Steam for Linux > Non-Valve Games > Topic Details
GER | tuxator Dec 6, 2012 @ 2:01pm
Issue Report: Red Orchestra: Ostfront 41-45 throws error when trying to connect sometimes
Hi there,

in some cases I get an error when trying to connect to a server. The error message says "An unknown Steam error is preventing you from connecting to this server. If the problem persists please contact Valve for support"

The strange thing is, that I get the error on different servers and sometimes I can connect to those servers. I think the error is related to specific maps, because sometimes I get that error between map changes from the server I just played on.

As an example: Just yet I tried to connect to the 'The wild Bunch' server while RO-odessa was the active map. Above error popped up and I went straight back to the main menu.

Sadly I can't post on the official website of that game since my email provider (gmx.de) is blocked there (strange...).
Last edited by GER | tuxator; Dec 6, 2012 @ 2:09pm
Showing 1-6 of 6 comments
< >
/linuX/gitano Dec 7, 2012 @ 2:11am 
Hey, yeah this seems to be a general probem with RO:OST and it's mods at the moment, look here for further details and workarounds:

http://forums.tripwireinteractive.com/showthread.php?t=85457
http://forums.tripwireinteractive.com/showthread.php?t=85663
GER | tuxator Dec 7, 2012 @ 2:26am 
hi, thanks for the response. I read the thread in the first link some time ago, but didn't thought that was 'my' problem. I don't have those mods installed (will have to read about them, I'm kinda new to RO). Shouldn't the game says something like 'eh dude, you don't have that mod thingi installed so don't ever try to connect to this server again'? Is there a way to set up the server browser in a way that it doesn't display those 'modded' servers? I once got a game hint about a checkbox that should be below the server browser for exactly that, but there is no checkbox?!
/linuX/gitano Dec 7, 2012 @ 4:22am 
No, i think this issue does not seem to be related if you have the mods instaleld or not, it looks more like an issue of some servers not being correctly updated.

http://forums.tripwireinteractive.com/showpost.php?p=1156457&postcount=14

I actually don't know if this applies to the same error message on stock RO servers as well. Best bet for now on the client side is to use the suggested "verify game cache" workaround and see if this fixes the connection problems.
GER | tuxator Dec 7, 2012 @ 11:15am 
hmm, still doesn't work. Can you connect to that server? ("The Wild Bunch") it's a 50 slot server and currently RO-Odessa is the active map (there are only a few servers anyway so it shouldn't be a problem to find it)
/linuX/gitano Dec 8, 2012 @ 12:53am 
No, can not connect as well.
Kronk Dec 16, 2012 @ 4:15am 
I've just built a dedicated RO:OST Linux Server and I'm seeing the same error as above when I try and connect to it.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50