Jill Sandwich Sep 4, 2013 @ 5:34am
Dota 2 Alt Tabbing Yields Better Framerate
When a match starts in dota the game lags. It's still playable but it's noticably slower. I've found that if I alt-tab then go back into dota the lag is gone and I can happily contine playing for X amount of time before I have to alt-tab again. Eventually, after the third or so time, this trick no longer works and I have to close and re-open dota.

Does anyone else have this, is it a known issue? Starting to wish I went with a nVidia card then a radeon.
Showing 1-10 of 10 comments
< >
lathanderjk Sep 14, 2013 @ 8:44am 
I have same issue, Ubuntu 12.04.3, AMD catalyst 13.4-13.8.
Zippoxer Nov 17, 2013 @ 9:16pm 
I have a radeon and the exactly same thing happens to me too.
I also noticed that when I receive a notification from Skype while I'm in-game, the game goes low-FPS until it disappears.

It's so annoying I consider playing Dota 2 on my Windows only.
Aphotic Aug 4, 2014 @ 3:49am 
any thoughts on this!? its 2014 and this is still on...

any system specefic?

i find clicking and dragging the camera on the high graphical throne/anciint and scrolling again to the enemies ancient will fix this!
Jill Sandwich Aug 4, 2014 @ 2:12pm 
Originally posted by Aphotic:
any thoughts on this!? its 2014 and this is still on...

any system specefic?

i find clicking and dragging the camera on the high graphical throne/anciint and scrolling again to the enemies ancient will fix this!
I've kept using the latest catalyst drivers whenever they're released and although the framerate doesnt drop as much as it used to, the problem does still exist for me. I have seen it on their open bugs section so they are aware of it.

I currently have a radeon 7790 but will swap it out eventually for a Nvidia next chance I get. I read radeon 6000 series or older cards supposedly work well. Seems like you just have to pick the right card?
Aphotic Aug 4, 2014 @ 6:49pm 
found a solution:

head to:

DotA 2 Options>Video / Audio>General>Display>
set as:
Borderless Window


explanation:

Dota2 uses the Source Engine. If you don't have Dota2 as your active window you are probably doing something else and usually have Dota2 in the background.

Since you don't even use it, Valve decided it would be a good idea to limit the fps to 20 in order to give your CPU/GPU a relief. Now the problem is with a dual monitor setup and/or while streaming and alt tabbing your viewers will see the fps drop because of the engine sleep limiting the fps down and this is just a tad annoying.

So to come back to your question: It only lifts the fps limiter while not being the active window.


^___^
Jill Sandwich Aug 5, 2014 @ 8:46am 
Originally posted by Aphotic:
found a solution:

head to:

DotA 2 Options>Video / Audio>General>Display>
set as:
Borderless Window


explanation:

Dota2 uses the Source Engine. If you don't have Dota2 as your active window you are probably doing something else and usually have Dota2 in the background.

Since you don't even use it, Valve decided it would be a good idea to limit the fps to 20 in order to give your CPU/GPU a relief. Now the problem is with a dual monitor setup and/or while streaming and alt tabbing your viewers will see the fps drop because of the engine sleep limiting the fps down and this is just a tad annoying.

So to come back to your question: It only lifts the fps limiter while not being the active window.


^___^

My problem was not that the frame rate drops when I alt-tab out, it drops whilst I'm still in fullscreen playing the game. If I tab out and back in again to dota then I, temporarily, get my usual FPS back.

With recent updates to catalyst when the FPS does drop, it never does so to below 21 frames a second (used to). So it's always playable but after alt-tabbing I get the far smoother 60+ FPS. Which is rightfully so as the 7790 should be able to yield said performance.

I'll try it in borderless and see if it fixes it and post back. Thanks for suggestion.
Aphotic Aug 5, 2014 @ 8:52am 
i will w8 for your return ;)
Aphotic Aug 11, 2014 @ 6:03pm 
any progress?
Last edited by Aphotic; Nov 11, 2014 @ 9:26pm
GIR Nov 11, 2014 @ 2:04pm 
engine_no_focus_sleep 0 write it in the autoexec.cfg
Aphotic Nov 11, 2014 @ 9:19pm 
GIR what does that do exactly? explain plz :}

...and please all who have lag/fps problems and want a lots of tweaks check these out:

Tweaked Dota 2 Autoexec Config – Performance Boost, Quick Courier, Quick Rune and More!
http://imnotbermuda.com/2014/02/10/bermudas-dota-2-cfg/
http://imnotbermuda.com/category/life-program/%E2%96%B6-dota/

Solving Dota 2 Lag / FPS drop / Latency issues / High ping / Spikes
http://imnotbermuda.com/2012/12/22/solving-dota-2-lag/
Showing 1-10 of 10 comments
< >
Per page: 15 30 50