Ru.sh Feb 24, 2013 @ 5:14am
TF2 and Unity (Ubuntu 12.04)
I'm currently running into an issue while playing TF2 under Ubuntu 12.04 using the default Unity desktop. Nothing major but I was wondering if someone had seen similar behaviour and perhaps can offer a solution.

First I use the ALT key to crouch in TF2, have done so for years. However in the Unity desktop this brings up the dash hud even when TF2 has focus. Not being able to crouch makes stuff like rocketjumping impossible so I've rebound my crouch key for now, but I'd rather know how to make TF2 grab the key exclusively when it has focus.

Second, since I have a dual monitor set-up (nVidia TwinView) I run TF2 with the launchoptions -window -noborder so I can do stuff on my second screen in between rounds or respawns without having TF2 minimize. However running TF2 in a borderless fullscreen window like that keeps the Unity "menu bar" on top of the window. I would prefer to have TF2 on top, at least when it has focus.

I'm not new to Linux at all since I'm a Linux sysadmin, so any solutions you might have no matter how technical are appreciated. I would rather have had it work out of the box however, as Valve promisses (and usually delivers).

edit: ALT brings up the hud not dash, thanks for pointing that out.
Last edited by Ru.sh; Feb 24, 2013 @ 6:43am
Showing 1-7 of 7 comments
< >
Ru.sh Feb 24, 2013 @ 5:24am 
Just to clarify, the first issue is always there wether I run TF2 in full screen mode or in a borderless window
8 Dimensional Octagon Feb 24, 2013 @ 5:31am 
I don't think it needs to be in a borderless window to allow you to do other things, I can switch desktops via ctrl+alt+arrowkey when I have tf2 running with no issue.
Salivating monstah Feb 24, 2013 @ 5:48am 
install kde profit?
gutigen o) Feb 24, 2013 @ 6:00am 
Alt key in Unity is for Unity HUD (not Dash), you may rebind it in Keyboard options found in System Settings or Dash, just look for HUD.
Ru.sh Feb 24, 2013 @ 6:38am 
Originally posted by brpylko Ubuntu 12.10 64 bit:
I don't think it needs to be in a borderless window to allow you to do other things, I can switch desktops via ctrl+alt+arrowkey when I have tf2 running with no issue.
I was talking about doing things on my second monitor not a different virtual desktop, but it leads to the same result. When TF2 loses focus while it's in regular full screen mode, it minimizes and that isn't what I want. That's what borderless windowed mode is for.
Ru.sh Feb 24, 2013 @ 6:41am 
Originally posted by LinuxSalivating Monstah:
install kde profit?
Valve has chosen Ubuntu as their distro of choice for Steam, Ubuntu comes with Unity, so they should make this work with Unity. Also I forsee problems with other games, for example Dota 2 where you use the ALT key to turn on/off autocast spells.

Besides, I've never liked KDE much.
Ru.sh Feb 24, 2013 @ 6:44am 
Originally posted by gutigen o) Linux:
Alt key in Unity is for Unity HUD (not Dash), you may rebind it in Keyboard options found in System Settings or Dash, just look for HUD.
That's so obvious I should have thought of that myself, thanks!
Showing 1-7 of 7 comments
< >
Per page: 15 30 50