rudeboyskunk Jan 24, 2013 @ 5:00pm
*Half Life Problems Thread*
Ok, so since Valve has released a *beta* version of Half-Life on Linux, there are bound to be problems. I suggest instead of making 1,000 threads about the issues, we keep it to this thread.

My problem:

I just fired it up, and when I go to play multi-player, I'm always alone on the map even though it says there are 16 other people, or 18 other people, or 10 other people, etc etc.

Also, the highest resolution I can get is 12something x 780 (something like that), but when I played it on Windows or through wine years ago I could get 1600x900.
Showing 1-15 of 28 comments
< >
timetopat Jan 24, 2013 @ 8:35pm 
When I launch Half life, the screen turns light green. I can hear my mouse over the buttons in the background, but I cannot see anything. I am using ubuntu 12.10 with nvidia experimental drivers.
d10sfan Jan 24, 2013 @ 8:36pm 
For the resolution problem, you could try setting your resolution manually in the launch options. Example: -width 1600 -height 900

I used that to get the game to launch in 1920x1080 on my system
Beelzebud Jan 24, 2013 @ 9:35pm 
I can only play it up to where you pick up the crowbar, and then it crashes to the menu screen.
Jared/Staples Jan 24, 2013 @ 10:54pm 
Steam in game notifications like "friend has started playing Dota 2", etc, would not leave the screen until I quit Half Life.
rudeboyskunk Jan 25, 2013 @ 2:36am 
Originally posted by Jared/Staples:
Steam in game notifications like "friend has started playing Dota 2", etc, would not leave the screen until I quit Half Life.

For this you can just click on "Settings" and "Disable Steam Community in Game" or something along those lines. It works for me.
rudeboyskunk Jan 25, 2013 @ 2:38am 
Originally posted by =(eG)= d10sfan:
For the resolution problem, you could try setting your resolution manually in the launch options. Example: -width 1600 -height 900

I used that to get the game to launch in 1920x1080 on my system

You're a genius! That worked~ Thanks a bunch.
Jared/Staples Jan 25, 2013 @ 6:21am 
Sound effects when hitting bullet proof glass with the crowbar sound like a gun. I can't remember if this is normal or not, but it does seem odd to me.
MRWITEK Jan 25, 2013 @ 6:33am 
Game is running pretty good but I have only music. Sure installation of pulseaudio will fix this but I dislike that. So, I would be happy if someone could find workaround for alsa. SDL_AUDIODRIVER=alsa unfortunately is not working for me.
System: ArchLinux x64, alsa sound, catalyst 12.8
spl Jan 25, 2013 @ 7:42am 
I have a bug where VSync is stuck on. I have turned it off in nvidia-settings, and to prove that it is indeed off I tried running another game that does respond to the nvidia-settings and it has vsync off.

fps_max is also not the issue. It is vsync I can feel the mouse lag caused by it.

I've been trying to ask other people to test this but haven't gotten to many responses, but I have not yet heard of anybody who has observed an FPS higher than 60. If someone is able to get higher than 60 please let me know.
Kakarott Jan 25, 2013 @ 7:50am 
Runs good so far.
But I always see the mousecursor. And not just that but also it moves when I movees my mouse. And the worst: when the cursor is at a screenedge it won't go further and therefor I can't turn my view further. I'm stuck at a viewing angle of about 75°
It happens in fullscreen and windowed.
It also happens in Counter-Strike.

I'm on Debian 64bit, using the installer script from Kano.
spl Jan 25, 2013 @ 7:58am 
Originally posted by Kakarott:
Runs good so far.
But I always see the mousecursor. And not just that but also it moves when I movees my mouse. And the worst: when the cursor is at a screenedge it won't go further and therefor I can't turn my view further. I'm stuck at a viewing angle of about 75°
It happens in fullscreen and windowed.
It also happens in Counter-Strike.

I'm on Debian 64bit, using the installer script from Kano.

This happens in windows too but it's fixable by toggling the menu (pressing esc twice)
have you tried that?
Kakarott Jan 25, 2013 @ 8:12am 
Originally posted by spacelike Linux:
Originally posted by Kakarott:
Runs good so far.
But I always see the mousecursor. And not just that but also it moves when I movees my mouse. And the worst: when the cursor is at a screenedge it won't go further and therefor I can't turn my view further. I'm stuck at a viewing angle of about 75°
It happens in fullscreen and windowed.
It also happens in Counter-Strike.

I'm on Debian 64bit, using the installer script from Kano.

This happens in windows too but it's fixable by toggling the menu (pressing esc twice)
have you tried that?

Yes. Also tried opening console and closing it again.
Nothing.
Also switching windows via Alt-Tab. Nothing.
instabilis Jan 25, 2013 @ 11:52am 
Non-spinning fans kill me, is that normal? Other then that the game works fine on my system, both single player and multi-player.
spl Jan 25, 2013 @ 1:40pm 
Originally posted by instabilis:
Non-spinning fans kill me, is that normal? Other then that the game works fine on my system, both single player and multi-player.

Me and a few others have been noticing this as well. It's not just fans either.

I do remember some things like that happening in windows too but it was much more rare, it seems to happen all the time in Linux.
Although, the models all look different from when I played so it's possible they did updates that made the animations less reliable even on windows and that this isn't exclusively a Linux problem.
I'd boot into windows and test it... But it burns my skin.
Last edited by spl; Jan 25, 2013 @ 1:41pm
Showing 1-15 of 28 comments
< >
Per page: 15 30 50