C1eDoDe1 13. Dez. 2012 um 11:38 Uhr
[Solved] Issue Report: TF2 launch error - This game is currently unavailable
So, I have the "This game is currently unavailable. Please try again at another time." message at TF2 launch. Screenshot is here[i54.♥♥♥♥♥♥♥♥♥♥].

My system:
Linux Mint 14 Cinnamon x64 (based on ubuntu 12.10), AMD video (open source drivers), etc.

What I've already tried to do:
- Deleting ClientRegistry.blob
- Deleting everything in the "Steam" and "appcache" directory, except for bin_steam.sh and steam.sh (steam reinstalls itself after that).
- "Verify directory of game cache", it says everything is ok.

Also, I have this messages in terminal (when trying to launch TF2):
Steam error: SteamProcessCall(WaitForAppReadyToLaunch)(0xab0ce7,0xff9ad230,0xff9ad018) failed with error 1: Failed to set file attributes
SteamWaitForAppReadyToLaunch() error: SteamProcessCall(WaitForAppReadyToLaunch)(0xab0ce7,0xff9ad230,0xff9ad018) failed with error 1: Failed to set file attributes
CJoinGameDialog::OnSteamError() : launch game failed, with steam error:
SteamProcessCall(WaitForAppReadyToLaunch)(0xab0ce7,0xff9ad230,0xff9ad018) failed with error 1: Failed to set file attributes

By the way, I have no space left on /home partition, so ~/.local/share/Steam is a symbolic link to the folder on my NTFS partition. NTFS partition is mounted in the way every file has rwxrwxrwx attributes. If it matters.

Sorry for my engrish

Can I get some wise advices?
Zuletzt bearbeitet von C1eDoDe1; 28. Feb. 2013 um 7:35 Uhr
Beiträge 1 - 15 von 17
< >
z411 14. Dez. 2012 um 12:55 Uhr 
This happens because you have your files in a NTFS partition, which doesn't support setting file permissions (as Windows permissions aren't compatible with Linux's). Steam tries to set permissions and it fails with the error "Failed to set file attributes".

This still shouldn't happen though.

Valve should fix this by not having the operation fail completely just beacuse it couldn't set file permissions. It should just output a warning and continue anyway. Most programs do this when they encounter this situation.
C1eDoDe1 15. Dez. 2012 um 11:05 Uhr 
Thank you, z411!

Is there any bugtracker to report to, I wonder? Or it's ok to leave the bug right here?
metalhead 22. Dez. 2012 um 13:13 Uhr 
I have exactly the same issue, seems not fixed yet...
metalhead 22. Dez. 2012 um 13:32 Uhr 
Well, it's not valve's fault :) Check your access permissions: in my case NTFS drive was mounted as root, and as far as I logged in as normal user, I (and so steam) have not enough permissions to change anything on this partition.
/mnt/f/games/Steam$ ls -l
итого 4977
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 appcache
-rwxrwx--- 1 root plugdev 2785 дек. 23 01:25 AppUpdateStats.blob
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 Backups
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 bin
-rwxrwx--- 1 root plugdev 6680 дек. 22 10:55 bin_steam.sh
...
run steam as root (sudo steam, for me it worked) or set up proper file persmissions in /etc/fstab.
z411 23. Dez. 2012 um 20:49 Uhr 
From what I know Linux NTFS driver doesn't support setting permissions as Windows permissions work differently.

Yo-ho-ho, what game did you try it with? I think this happens only with TF2.
metalhead 23. Dez. 2012 um 23:49 Uhr 
Yes, I encountered this with TF2 only.
I also have Trine 2 and it is working fine.
C1eDoDe1 24. Dez. 2012 um 10:25 Uhr 
Ursprünglich geschrieben von Yo-ho-ho:
Check your access permissions

Ursprünglich geschrieben von C1eDoDe1:
NTFS partition is mounted in the way every file has rwxrwxrwx attributes.
`ls -l` agrees with me.

Ursprünglich geschrieben von Yo-ho-ho:
run steam as root (sudo steam, for me it worked)
I tried this too and got the same error.
iQTest™ 16. Feb. 2013 um 15:35 Uhr 
I have this problem as well....
NTIMESc 16. Feb. 2013 um 16:56 Uhr 
TF2 worked for me by using a bind mount instead of a symlink. Example:
mount --bind /mnt/f/games/Steam ~/.local/share/Steam

But in the end, I wound up repartitioning to allow plenty of space for TF2 (and now CS:S too) in home, and the NTFS drive is just added as a Steam Library Folder for everything else. This has proved less of a hassle and more stable.
Darth Jigglypuff 16. Feb. 2013 um 18:42 Uhr 
hey i may sound like a noob here but i just got linux so how to you access steam commands so you can change the permissions so it is playable
NTIMESc 16. Feb. 2013 um 21:17 Uhr 
@Jigglypuff
I'm not sure what you mean by "steam commands so you can change the permissions". Describe your situation in a little more detail. Did you symlink your steam folder to an NTFS partition the same as C1eDoDe1?
Darth Jigglypuff 17. Feb. 2013 um 4:47 Uhr 
Well, it's not valve's fault :) Check your access permissions: in my case NTFS drive was mounted as root, and as far as I logged in as normal user, I (and so steam) have not enough permissions to change anything on this partition.
/mnt/f/games/Steam$ ls -l
итого 4977
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 appcache
-rwxrwx--- 1 root plugdev 2785 дек. 23 01:25 AppUpdateStats.blob
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 Backups
drwxrwx--- 1 root plugdev 0 дек. 16 18:51 bin
-rwxrwx--- 1 root plugdev 6680 дек. 22 10:55 bin_steam.sh
...
run steam as root (sudo steam, for me it worked) or set up proper file persmissions in /etc/fstab.


*this
Darth Jigglypuff 17. Feb. 2013 um 5:17 Uhr 
because when i open steam in linux ubuntu 12.10 it says error this game is currently unavalible and i really want to get tux but tf2 wont launch so do any of you know how i may fix this through the terminial or something
Darth Jigglypuff 17. Feb. 2013 um 5:27 Uhr 
and when i type in sudo steam in the terminal it says cannot run as root user but i installed root?
Harime Nui 17. Feb. 2013 um 13:36 Uhr 
You guys have got it wrong, I think. I'm pretty sure that it's because everyone is trying to launch TF2 at the same time to get the Tux. The Steam servers are full because everyone is trying to launch at the same time.
Beiträge 1 - 15 von 17
< >
Pro Seite: 15 30 50