Squidamatron Dec 10, 2012 @ 8:53pm
Overlay causes great amount of lag
I noticed that when I had the overlay enabled I would get 20-40 fps with huge dips below that. Then, when it crashed while I was playing, I noticed a HUGE rise in my FPS. On the order of dipping down to 60, rarely going down to 30 and averaging close to the 100's. So now I've left it disabled and I've been riding with phenomenal fps.

I've got a 5870 with the 12.11 beta drivers [not beta8], a Q6600 @ 2.4GHz, 6GB DDR2 800MHz RAM and kernel 3.6.9-1. I'm using AwesomeWM as well.
Showing 1-5 of 5 comments
< >
Haikarainen Mar 19, 2013 @ 9:12am 
I have too been noticing this. It is a huge issue for me since it renders the overlay completely useless. I get ~13 FPS with it active, and >60 FPS with it inactive. I suspect it has to do with antialiasing.

I have 2x XFX 6870 Black Edition (Double dissipation) in Crossfire, running ArchLinux x86_64.
Squidamatron Mar 19, 2013 @ 7:17pm 
After upgrading to an i5-3570K and a newer X11, that 13.1 actually supports, I notice less lag while playing with the overlay enabled, but I still get pretty horrific slowdowns when I open it up with Shift+Tab.
Spuzaw Mar 19, 2013 @ 10:52pm 
Yep, when I use the Steam overlay the framerate tanks.
ヲ! Mar 23, 2013 @ 7:45pm 
yeah, drops to about 20fps.
I think it's a bug in ATI's fglrx-experimental driver.
Comrade msw1 May 27, 2013 @ 12:19pm 
This happens to me too with 13.4 Properietary AMD drivers on Kubuntu 13.04.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50