Steam for Linux

Steam for Linux

(bumped) Issue Report: [TF2] Sudden FPS drop, only fixable by completely restarting the game.
I have reported this one for the first time over a week ago but it didn't get a very big response, much less an official response, yet it continues to make the game practically unplayable for me to this day (unless I play on another map but dustbowl :).

this is my original post with a longer description, but I'll summarize it again:

On most maps, after a while (or instantly on join), TF2 suddenly drops framerate from a smooth 150 - 200 to unplayable 15 - 30. I say most maps because it virtually never happens on cp_dustbowl (only once in 2 weeks) yet almost immediately or within an hour on any other map I tried. The only fix that works for me is to completely exit out of the program and restart it.

Since my first report, there were some updates to Steam itself and I believe also one to TF2, but the problem remains.

Except for Steam, nothing changed on my end, but I'll repost my sysinfo for the sake of completeness:
Processor Information:
Vendor: GenuineIntel
Speed: 3301 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-20-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 560 Ti/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1200
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3600 x 1080
Primary Display Size: 20,51" x 11,54" (23,50" diag)
52,1cm x 29,3cm (59,7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: 20K2

RAM: 7956 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 679553 Mb
Largest Free Hard Disk Block: 196886 Mb

Installed software:

Recent Failure Reports:
Fri Dec 7 18:24:37 2012 GMT: file ''/tmp/dumps/crash_20121207192432_1.dmp'', upload yes: ''CrashID=bp-292c40a0-72db-4141-a9ed-6fda42121207''
Fri Dec 7 18:37:09 2012 GMT: file ''/tmp/dumps/crash_20121207193704_1.dmp'', upload yes: ''CrashID=bp-d8cdcdd2-6e83-45a8-9c80-68c492121207''
Fri Dec 7 22:42:50 2012 GMT: file ''/tmp/dumps/crash_20121207234246_1.dmp'', upload yes: ''CrashID=bp-918ebc98-fd2a-488a-8fee-ab2012121207''
Sat Dec 8 14:12:33 2012 GMT: file ''/tmp/dumps/crash_20121208151230_1.dmp'', upload yes: ''CrashID=bp-48ea7ae8-a3b8-4cde-9915-2e9772121208''
Sat Dec 8 14:52:04 2012 GMT: file ''/tmp/dumps/assert_20121208155201_1.dmp'', upload yes: ''CrashID=bp-ea443ee6-b600-45e5-ba17-971192121208''
最近の変更はGNU.Interior Crocodile Alligatorが行いました; 2012年12月10日 8時56分
< >
1-15 / 21 のコメントを表示
I reported this bug as well as other ppl, so its duplicated.
Well, at least there now is one in this subforum, I did look through here before I reposted just to be sure.
Kokoro 2012年12月10日 13時06分 
It's unplayable, I can't enter a server without staying 10FPS. And even restarting the game doesn't help to stabilize the FPS.
最近の変更はKokoroが行いました; 2012年12月10日 15時13分
Olavo の投稿を引用:
It's unplayable, I can't enter a server without staying 10FPS. And even restarting the game doesn't help to stabilize the FPS.

Maybe your problem is another one then, because for me it runs absolutely fine with >150 FPS until the bug hits.
Olavo: Absolutely same here, but on some maps and community servers it is running with 200FPS witout any issue.
mikesart 2012年12月11日 10時10分 
Can you this and let me know the "total" results:

pmap $(pidof hl2_linux)

mikesart 2012年12月11日 10時23分 
To be clear - I'm trying to figure out whether low memory condition are causing this issue or not. So knowing the results of the pmap command when there isn't a problem, and then when there is would be great...
Here is output from command, when TF2 was OK:
I can't reproduce this bug today, because instead of FPS drop I getting crash every time if game is not running as should.
Very interesting is, I can play all maps offline with bots without any issues.
When I first play offline game, then later, game is running well online as well with all maps. When I play online on official servers first, mostly game crash.
It crashing in this way: I see menu for team select, I can see FPS around 50 (but it is around 0.1FPS in reality), then sounds and video lags for second, then there is some refresh in video and sound and then game is down.
I'll try to post log with slow FPS if I can enter into LOW FPS state again.

My PC contain 4GB ram
最近の変更はZeXx86 [Linux]が行いました; 2012年12月11日 11時16分
Couldn't for the life of me reproduce it today for some reason, I'll get to it again tomorrow. Meanwhile, this is what I got for memory usage on start and in a clean gameplay:

Start: 1010396K
Clean gameplay: 2391684K, 2442584K, 3087568K, 3153624K (taken on different maps in the same "session")
I think it could be low memory related issue, since game is loading so long in online. Still game is crashing in team selection with lagged screen at 55FPS + some sound loops and then TF2 go down. In wine, all is running OK and loading times are much faster.
Alright I got a pmap after the lag occured: 2927540K, which is on par with all the other samples so it does not appear to be an out of memory thing. I also grabbed a cpu usage sample.

Steam itself used 100% CPU while playing TF2 (already reported bug) and TF2 itself used another 120%. Maybe something is up with that.

Something I noticed, I could play for days on any map without the bug occuring, but after I changed my graphics settings (enable Motion Blur & Anti Aliasing) it happened basically instantly. Might be connected or not.
最近の変更はGNU.Interior Crocodile Alligatorが行いました; 2012年12月14日 18時17分
Update: I was able to fix it by (I assume) forcing a graphics reinitialization. The bug kicked in earlier and I just tried setting AA and Filtering to the absolute maximum. The game hangs for a short time while it applies the settings and the bug was gone, once I set the values back to their old value it was playable again.
I think this is probably the same issue reported here:

We haven't been able to repro this issue yet. I will try again this week though. Sorry...
Well, Steam is always using 100% while playing TF2, so much is true, but most of the time I still get a playable framerate until it decides to go haywire. But maybe the one will fix the other, I'll just wait and see. Thank you for your efforts!
最近の変更はGNU.Interior Crocodile Alligatorが行いました; 2012年12月15日 8時40分
I just had the same bug. It appears after approx. 4-5 map changes - might be something with Multicore Rendering (I had similar issues with wine when enabling it), but I'm not sure yet.
最近の変更は<VEX> D.Centが行いました; 2012年12月15日 13時30分
< >
1-15 / 21 のコメントを表示
ページ毎: 15 30 50

投稿日: 2012年12月10日 8時54分
投稿数: 21