Steam for Linux

Steam for Linux

biltong#2626 10. dec 2012 kl. 8:00am
Solved: Special characters in player names cause weird glitches
If a player has special characters in their name, when they join and it displays "player x has joined" in chat, it will display characters only up to the special character. So if someone else was named "bìltong" (notice the grave accent) it would display only "Player b" in chat.

Further, on the scoreboard the player name AFTER that character keeps changing. It usually changes the remainder to other player's names from the index of that character, if that makes sense. If I could record a video I would.
Processor Information:
Vendor: GenuineIntel
Speed: 3701 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Arch Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 3.7.1-2-ck
X Server vendor: The X.Org Foundation
X Server release: 11301000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.19
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.04" x 11.26" (22.95" diag)
50.9cm x 28.6cm (58.3cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC889

RAM: 9965 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 187272 Mb
Largest Free Hard Disk Block: 126853 Mb

Installed software:

Recent Failure Reports:
Wed Dec 19 16:38:04 2012 GMT: file ''/tmp/dumps/assert_20121219183756_1.dmp'', upload yes: ''CrashID=bp-b8b4219b-ecaa-4331-95cc-9ceb22121219''

EDIT: Here are some screenshots demonstrating the problem:
Sidst redigeret af biltong#2626; 19. dec 2012 kl. 12:44pm
< >
Viser 1-12 af 12 kommentarer
Frank 18. dec 2012 kl. 3:00pm 
Are you still seeing this issue with the latest client (released yesterday)? This might have been fixed by related work.
biltong#2626 19. dec 2012 kl. 5:36am 
Will check asap, I haven't been in linux for a bit.
biltong#2626 19. dec 2012 kl. 9:27am 
I can confirm the issue is still there.
I also don't know what that gradient on the right hand side there is.
This issue also seems to appear in Big Picture mode:
I think the Big Picture mode issue is strange because special characters display fine in Steam itself now. I've updated my system info in the OP as well.

Oh and one quick unrelated issue, the console font size in TF2 has been increased but cl_showfps 1 still has TINY fonts.
Sidst redigeret af biltong#2626; 19. dec 2012 kl. 9:28am
mikesart 19. dec 2012 kl. 9:36am 
I can't repro this here at all. Are you using bitmap fonts by any chance? (The cl_showfps font will be larger in the next update).
biltong#2626 19. dec 2012 kl. 10:29am 
How do I check if I use bitmap fonts? I think I only have TTFs, but I could be wrong.

EDIT: I searched for bitmap in my package manager and the only things that came up were xbitmaps and xorg-bdftopcf. xbitmaps is a dependency of xterm so it can't go. I don't believe I have anything else bitmap font related installed.
Sidst redigeret af biltong#2626; 19. dec 2012 kl. 10:42am
mikesart 19. dec 2012 kl. 10:40am 
Can you do "vgui_spew_fonts" in the console and copy that information here? Also "showschemevisualizer", select fonts on the top right and scroll through. Are any of the fonts messed up there? And then "showschemevisualizer Resource/SourceScheme.res" - check for anything that looks broken there and post a screenshot please. Thanks.
biltong#2626 19. dec 2012 kl. 11:00am 
This even happens in the menu when looking at server details:

I just noticed this shows up in the console when I start tf2:
m_face->glyph->bitmap.width is 0 for TF2 Build

As for vgui_spew_fonts:

In showschemevisualizer most of the fonts seemed to display correctly until the letter N, after which parts of words or random characters appeared, as in the screenshots:
mikesart 19. dec 2012 kl. 12:10pm 
That's horribly broken. It should be display A-Za-z0-9 and then some punctuation. I replaced the capital O with an O' (accent above it) to test intl characters. So yours has random characters and strings >= that though - like name or secondary or shadow. Garbage. It looks like the utf8 to wchar conversion is failing. Does running Steam in German or French work? Is anyone else seeing this?
biltong#2626 19. dec 2012 kl. 12:24pm 
I can try switch my locale to en_US or en_GB if you'd like. en_ZA is pretty much en_GB anyway.
I'm also about to try running Steam in French.

EDIT: Or not. Upon switching to French Steam wants me to download TF2 again. Great.
Sidst redigeret af biltong#2626; 19. dec 2012 kl. 12:29pm
biltong#2626 19. dec 2012 kl. 12:42pm 
Fixed it. I had to enable either en_US.UTF8 or en_GB.UTF8 on my system (for arch readers, that means uncommenting them in /etc/locale.gen and then running # locale-gen). Then I started Steam with LANG="en_GB.UTF8" and now everything seems to be displaying correctly. I'll try running with normal en_ZA now.

EDIT: en_ZA works with intl characters now. :D finally!
Sidst redigeret af biltong#2626; 19. dec 2012 kl. 12:46pm
mikesart 19. dec 2012 kl. 12:52pm 
TF2 uses en_US.utf8. Guess I should figure out whether that's installed or not. Hm. Thanks for tracking that down.
biltong#2626 19. dec 2012 kl. 12:59pm 
No problem, just glad it wasn't anything major. Just a shame we didn't figure it out earlier.
< >
Viser 1-12 af 12 kommentarer
Per side: 15 30 50

Dato postet: 10. dec 2012 kl. 8:00am
Indlæg: 12