spencercw Dec 7, 2012 @ 9:43am
TF2 appears on the wrong monitor
I have two monitors set up with the primary monitor on the right (I guess this is a fairly unusual configuration). However, TF2 seems to assume the left-most monitor is the primary, so it appears in the wrong place. Additionally, it reads the cursor as being in the wrong place, presumably because my secondary monitor is smaller than my primary monitor (1440x900 and 1920x1080). See: http://i.imgur.com/BfwlC.jpg Notice the cursor is level with 'create' but is highlighting the button above it.
Showing 1-12 of 12 comments
< >
spencercw Dec 7, 2012 @ 9:45am 
System info:

Processor Information:
Vendor: GenuineIntel
Speed: 3501 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 550 Ti/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x1244
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3360 x 1080
Primary Display Size: 18.78" x 10.55" (21.54" diag)
47.7cm x 26.8cm (54.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 15945 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 318264 Mb
Largest Free Hard Disk Block: 5030 Mb

Installed software:

Recent Failure Reports:

The Slippery One Dec 9, 2012 @ 7:01am 
I can second this; I have the same problem with a Radeon HD 5770. My primary (rightmost) monitor is 1920x1080 and the secondary (leftmost) is 1600x1200; TF2 picks 1920x1080 as its resolution even though it's displaying on the 1600x1200 one, which leads to both aspect ratio issues and the above-mentioned mouse position issue.
The Slippery One Dec 9, 2012 @ 7:30am 
I think also part of the problem is that there isn't a consistent way to determine the "primary" monitor in Linux as a whole; over the years, I've seen many different window managers do it different ways. I still can't get Ubuntu's Unity to treat my right-hand monitor as "primary" in that all the desktop icons are still on the left hand side, even though the launcher is on the right.
Jan Dec 9, 2012 @ 2:20pm 
I can confirm this problem. Using Kubuntu 12.10 with KDE 4.9.2. The right monitor is the primary with a resolution of 2560x1440, left one has a resolution of 1920x1080.

TF2 starts on the second monitor with the resolution of the primary, the window is somehow scaled down to fit the smaller resolution.
HerrGnatz Dec 9, 2012 @ 3:05pm 
I'm also using Kubuntu 12.10 with KDE 4.9.2 but with three monitors. The primary monitor in the middle has a resolution of 1920x1200 and the monitors on the sides 1600x1200. TF2 always starts on the left screen with the resolution of the primary monitor.
I have an Nvidia GTX 670 and use Twinview. The screen in the middle is checked as primary monitor in the nvidia settings.

Solution for now: start the game in windowed mode and disable the window decoration.
Last edited by HerrGnatz; Dec 9, 2012 @ 3:08pm
[Linux] RobbieThe1st Dec 9, 2012 @ 5:31pm 
I also have this 'issue' - I have two monitors in a vertical configuration, and the top is smaller(1280x1024 and 1920x1080). Bottom monitor is default in my KDE prefs, yet Steam appears on the top monitor.
Using the '-windowed -noborder -w1920' options, it appears at the correct size, and I can drag it into position on the bottom monitor, but I have to do that at each startup.

So, I vote for this to be fixed as well - Hopefully by asking KDE which monitor is the one I have selected as default, and appearing on that, moved to the correct location by the X/Y location in the prefs.

DERPZERKER Dec 9, 2012 @ 5:37pm 
i have this same problem. no obvious way to make game fullscreen onto the desirable monitor of choice. nvdia-experimental-310, gtx460, kubuntu 12.04, right=primary = 1680x1010 left = 1920x1080,.. always shows on left monitor. want to show on right monitor.
Einshrek Dec 10, 2012 @ 6:44pm 
I also have this issue. AMD Catalyst 12.11beta11, ubuntu 12.04, left=1024x1280(rotated display), middle=1920x1600=primary, right=1280x1024. Always shows up on the right display with the middle's resolution settings.
Half-Shot Dec 12, 2012 @ 8:15am 
Originally posted by The Slippery One:
I can second this; I have the same problem with a Radeon HD 5770. My primary (rightmost) monitor is 1920x1080 and the secondary (leftmost) is 1600x1200; TF2 picks 1920x1080 as its resolution even though it's displaying on the 1600x1200 one, which leads to both aspect ratio issues and the above-mentioned mouse position issue.

I also have a radeon 5770 but 2 1920x1080 monitors. The right one is the primary monitor but tf2 starts on the left.
mikesart Jan 17, 2013 @ 3:17am 
You should be able to pick which display TF2 will start up fullscreen on now in the options dialog. There is also a new command line option which will allow you to pick as well: "-displayindex #" where # is the sdl display index, 0 being the primary.
HerrGnatz Jan 17, 2013 @ 4:44am 
Tried it out right away and it works like a charm. Thank you very much!
mikesart Jan 18, 2013 @ 1:20pm 
Good to hear. Thanks!
Showing 1-12 of 12 comments
< >
Per page: 15 30 50