Scarlett Johanson Dec 7, 2012 @ 12:12am
TF2: Can't change resolution in-game
When I attempt to change the resolution via the menu in-game, it does nothing. Set the new resolution, hit Apply, but it remains the same. Ubuntu 12.04 LTS with Gnome3

Processor Information:
Vendor: GenuineIntel
Speed: 2400 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.3.6-030306-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce 8800 Ultra/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x194
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3360 x 1080
Primary Display Size: 20.51" x 11.54" (23.50" diag)
52.1cm x 29.3cm (59.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 768 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC1200

Memory:
RAM: 7985 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 233565 Mb
Largest Free Hard Disk Block: 156410 Mb
Showing 1-15 of 19 comments
< >
mikesart Dec 7, 2012 @ 11:06pm 
Can you explain what you're changing? Ie, fullscreen 1280x1204 to fullscreen 800x600? Thanks.
Artemis3 Dec 8, 2012 @ 2:12am 
Its the same for me with nvidia. As a workaround, i change the desktop resolution before running tf2.
remm Dec 8, 2012 @ 4:22am 
Same for me, it only runs at the desktop resolution. I don't think it is possible to really change the resolution now with kms, Trine 2 for example can render at lower resolutions, which is then stretched to the native desktop resolution (that's still much faster, and it doesn't look too bad).
exxxie Dec 8, 2012 @ 4:31am 
same issue with this reported in console: "ConVarRef hap_HasDevice doesn't point to an existing ConVar"

Going form 1920x1080 fullscreen > 1280x720 fullscreen

Processor Information:
Vendor: GenuineIntel
Speed: 2800 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Linux Mint 14 Nadia (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-17-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTS 250/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 304.43
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x615
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1280 x 720
Desktop Resolution: 1280 x 720
Primary Display Size: 18.90" x 10.63" (21.65" diag)
48.0cm x 27.0cm (55.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 512 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Realtek ALC889A

Memory:
RAM: 3198 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 164273 Mb
Largest Free Hard Disk Block: 132205 Mb

Installed software:

Recent Failure Reports:
Sat Dec 8 12:14:12 2012 GMT: file ''/tmp/dumps/crash_20121208121407_1.dmp'', upload yes: ''CrashID=bp-5a5a51ee-26da-483f-9b6c-cc17e2121208''

Scarlett Johanson Dec 8, 2012 @ 4:59am 
As others above have said, it renders at desktop resolution (1920x1080, I've turned my other monitor off to play due to a dual monitor issue that I have posted about in another thread) fullscreen by default. I try to change it to any other fullscreen resolution (1600x900, 1280x720, etc) but it doesn't change. It doesn't really give any feedback at all. I haven't tried windowed yet.
Last edited by Scarlett Johanson; Dec 8, 2012 @ 5:04am
normalex Dec 8, 2012 @ 11:05am 
Same here.
SS3 BFE works without problems on < 1280 width with medium settings.
OilRush works even better.
TF2 is lagging hard on desktop's default 1680 x 1050.
p0s Dec 14, 2012 @ 10:29am 
I also cannot change the resolution ingame (fullscreen mode).
- Kubuntu 12.10 amd64
- Nvidia drivers:
Package: nvidia-experimental-310
Version: 310.14-0ubuntu1

Dragonsbrethren Dec 15, 2012 @ 1:25am 
Originally posted by mikesart:
Can you explain what you're changing? Ie, fullscreen 1280x1204 to fullscreen 800x600? Thanks.
In my case, 1920x1440 (my desktop res) fullscreen to 1280x960 fullscreen. When I click apply, nothing happens. If I leave the video tab and come back, the resolution is (correctly) listed as being 1920x1440. Changing into a windowed mode works fine.

Edit: It's worth noting that I can't force a lower resolution via the launch options either. For example:

-full -w 1280 -h 960

Still starts me at 1920x1440. If I do the same with -sw in place of -full, it launches at the correct resolution. If, after that, I try changing to fullscreen mode in the video tab, I get changed back up to 1920x1440.
Last edited by Dragonsbrethren; Dec 15, 2012 @ 1:58am
Bromide Dec 16, 2012 @ 12:30am 
I did some experimentation and got similar results; Fullscreen resolutions always match the desktop native regardless, but windowed can be anything it wants. I *have* successfully changed the resolution in windowed mode (which is nice, because while my desktop is 1080p, a lot of games run better at 720p).
JBravo Dec 16, 2012 @ 6:44am 
This is really annoying for me. I have a dual head setup where the monitors have different resolutions in nvidia twinview mode. For games I work around this by configuring twinview to disable one of the monitors in certain resolutions leaving the app capable of reaching fullscreen status on just one monitor in stead of getting split in the middle on two. This does however require that I be able to set the game into a specific resolution... :)
p0s Dec 17, 2012 @ 8:17am 
I was trying to reduce the fullscreen resolution. Did not work.
I also tried to add a reduced resolution via commandline -width/-height which did not work as well.
Changing the desktop resolution in the control panel before starting the game DOES work, the ingame resolution will be changed as well then.
Dragonsbrethren Dec 17, 2012 @ 3:00pm 
I'm not on my Linux partition right now to try it out, but I remembered seeing these console commands in the patch notes a while back. If anyone's having performance issues from having to run in too high of a resolution, they'll probably help:

Added mat_viewportupscale and mat_viewportscale to enable rendering the world at a reduced resolution. ("mat_viewportupscale 1" and "mat_viewportscale 0.5" will downscale world rendering by 50%.

It's better than having to change your desktop res every time you want to play TF2 fullscreen.
mikesart Dec 17, 2012 @ 4:14pm 
TF2 should come up on the primary display right now. And we don't change resolutions - tried that initially and it was not good. We are going to add scaling support, and we are also going to add support for selecting which monitor to come up on. Until we get that in, a possible workaround would be to use xrandr to switch your primary display?
survient Dec 25, 2012 @ 12:32pm 
But... but... I want to run TF2 at 5760x2160... lol no biggie if you guys are planning on supporting it down the road. What kind of issues were you getting changing the resolutions previously?
Artemis3 Dec 26, 2012 @ 7:08am 
The game simply runs at the desktop resolution, even 2048x1536 works. This is about changing the resolution in-game, you can always do it outside before launching the game, or use a small window.

Wine games can change full screen resolution, also many console emulators and other native games in linux/X11, you might want to check how is done in these projects.

Don't see much need to add scaling in-game, at least the nvidia driver already does it when the screen resolution is different, to avoid the ugly built-in resizing or a smaller viewport of some monitors.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50