Avalanche Mar 21, 2013 @ 6:46pm
libGL error: failed to load driver: swrast
OK just to get all of the usual fixes out of the way.

YES i have mesa-utils and libgl1-mesa-glx:i386 installed
YES I have export LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH in a shell file that i use to launch steam

YES I can get glxgears to run

YES I have made symbolic links to ~/.steam/bin


this is the errors that I get when I start steam

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast

and when i start CS:S

Game update: AppID 240 "Counter-Strike: Source", ProcID 12185, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Xlib: extension "RANDR" missing on display ":0".
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.


Showing 1-13 of 13 comments
< >
Avalanche Mar 21, 2013 @ 6:50pm 
And glxinfo information

glxinfo | grep "version"
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 3.3.0 NVIDIA 313.18
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
towo01 Mar 22, 2013 @ 12:30am 
You have not installed the 32bit glx part of the nvidia-driver.
If you have used the installer from the nvidia-website, that must fail.
Avalanche Mar 23, 2013 @ 12:52pm 
I have just installed the 310 Driver from Nvidia here is the output for CS;S

Game update: AppID 240 "Counter-Strike: Source", ProcID 6531, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
(steam:6385): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
...
Xlib: extension "RANDR" missing on display ":0.0".
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 0.0.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
instabilis Mar 23, 2013 @ 1:07pm 
Which distribution are you using? Ubuntu?

Where are you getting the driver from? Your distribution's repository?
Avalanche Mar 23, 2013 @ 6:07pm 
I am using Ubuntu 12.04 I was using the xorg-edgers repo. But just installed 310 from the nvidia website as per towo01 instructions
towo01 Mar 24, 2013 @ 8:27am 
Where you read, i have instructed you to install the driver from the website?
Avalanche Mar 24, 2013 @ 2:20pm 
then what did you mean by "If you have used the installer from the nvidia-website, that must fail." I installed it from nvidia site and it did not fail
Last edited by Avalanche; Mar 24, 2013 @ 5:24pm
arc| Gps Apr 23, 2013 @ 5:25pm 
I am on opeSUSE 12.3 64 bit HD 5750 Catalyst 13.3 beta 3
I might have the same problem.

But as soon as steam starts it complains about direct rendering.

Have mesa and mesa 32bit installed.

output of glxinfo

name of display: :0
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_create_context, GLX_ARB_create_context_profile,
GLX_ARB_create_context_robustness, GLX_ARB_get_proc_address,
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_framebuffer_sRGB,
GLX_EXT_create_context_es2_profile, GLX_MESA_copy_sub_buffer,
GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control,
GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGI_make_current_read,
GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap, GLX_INTEL_swap_event
GLX version: 1.4
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_MESA_multithread_makecurrent, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 1.4 (2.1 (4.2.12173 Compatibility Profile Context 12.10.17))
OpenGL extensions:
and allot more
Last edited by arc| Gps; Apr 23, 2013 @ 5:29pm
towo01 Apr 23, 2013 @ 11:47pm 
> Have mesa and mesa 32bit installed.

Why? You need the nvidia-gl-libs in 32bit versions.
arc| Gps Apr 24, 2013 @ 8:11am 
Originally posted by towo01:
> Have mesa and mesa 32bit installed.

Why? You need the nvidia-gl-libs in 32bit versions.

When using an amd card ?
towo01 Apr 24, 2013 @ 8:34am 
Oh, then sorry i have overread this. The thread-starter was a guy with nvidia card.
For ATI it does even not make any sense if fglrx is used in the system, so even here must be the 32bit fglrx libs installed.
arc| Gps Apr 28, 2013 @ 2:22pm 
For now my problem is solved by a re install of opensuse, leaving home partion in tact.
Then installed latest catalyst from the repo's 13.1

Before beta 6 was working well besides know bugs,

I am now going to install 13.4 which was released this week.
The Wounded Apr 28, 2013 @ 2:53pm 
Well swrast is the software fallback renderer which will never produce anything that would be playable. but it sure looks like it is a driver issue here, looking at your last post where it states opengl 0.0.0 is usually something that happens when drivers get mixed up, you could try to uninstall the drivers and reinstall the most recent one. Also check that you system is not loading the DRI drivers from the nouveau package at boot time.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50