Steam for Linux

Steam for Linux

Robotnik Nov 22, 2013 @ 9:37pm
Source games wont run - black textures (Mint 16, HD4000)
Well, today I decided to give Steam on linux another try, since it should have matured quite a bit by now. TF2 used to run back a few months ago in Linux Mint 15, although with a 70% performance reduction from Windows.

Hardware:
ThinkPad x230
Core i5 3210m
8gb DDR3 Memory
Intel HD 4000 - Intel Mesa Driver
LM16 Petra - RC1

Both TF2 and Day of Defeat:Source start up. You can see the menu items, although the backround is black, and the buttons are not rounded and are glitched. If you log into a server, there is nothing visible except for wireframe player models on a black screen.

This error shows up in Console:
Error: Material "debug/debugluxels" uses unknown shader "DebugLuxels"
Error: Material "___fillrate_0" uses unknown shader "FillRate"
Error: Material "___debugnormalmap_1" uses unknown shader "DebugNormalMap"
Error: Material "___debugdrawenvmapmask_2" uses unknown shader "DebugDrawEnvmapMask"
Error: Material "___debugdepth_3" uses unknown shader "DebugDepth"
Error: Material "___debugdepth_4" uses unknown shader "DebugDepth"s

I could not find much information on this issue, nor anyone else with the same symptoms (wireframe player models)

Here is some more diagnostic info:
glxinfo: http://pastebin.com/b42mbPL0
Steam System Information:http://pastebin.com/GyXZJbNY

Looking forward to any sugestions.
< >
Showing 1-6 of 6 comments
Rusek Dec 28, 2013 @ 12:07pm 
I had this same problem.
This worked for me: launch steam from terminal with this parameter "force_s3tc_enable=true steam"
Last edited by Rusek; Dec 28, 2013 @ 12:07pm
Rohnathan Jan 3, 2014 @ 2:11pm 
Yep, thanks! That fixed it for me as well.

Is there any way to assign this to a launcher so I don't have to type it via the terminal every time?
nfgSpaz Oct 28, 2014 @ 9:49pm 
Another option is to install the s3tc libs:

sudo apt-get install libtxc-dxtn-s2tc0:i386
xfragmanx Jan 5, 2015 @ 5:02pm 
Originally posted by KillerSpaz:
Another option is to install the s3tc libs:

sudo apt-get install libtxc-dxtn-s2tc0:i386
this work for me. thanks dude!!
Aranel Feb 2, 2015 @ 10:22am 
Originally posted by Rusek:
I had this same problem.
This worked for me: launch steam from terminal with this parameter "force_s3tc_enable=true steam"
WORKS FOR ME, thanks!
Padded Gamer Aug 19, 2017 @ 12:23pm 
This issue now exists in the latest version of Linux Mint as well as Ubuntu 17.04.

Anyone still suffering should install the s3tc libs. As stated above.
Sorry for nekroing a thread. I normally wouldn't do this but the issue still exists so therefore, this has to be pinned at some point.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50