DrIvoRobotnik5 Nov 22, 2013 @ 9:37pm
Source games wont run - black textures (Mint 16, HD4000)
Well, today I decided to give Steam on linux another try, since it should have matured quite a bit by now. TF2 used to run back a few months ago in Linux Mint 15, although with a 70% performance reduction from Windows.

Hardware:
ThinkPad x230
Core i5 3210m
8gb DDR3 Memory
Intel HD 4000 - Intel Mesa Driver
LM16 Petra - RC1

Both TF2 and Day of Defeat:Source start up. You can see the menu items, although the backround is black, and the buttons are not rounded and are glitched. If you log into a server, there is nothing visible except for wireframe player models on a black screen.

This error shows up in Console:
Error: Material "debug/debugluxels" uses unknown shader "DebugLuxels"
Error: Material "___fillrate_0" uses unknown shader "FillRate"
Error: Material "___debugnormalmap_1" uses unknown shader "DebugNormalMap"
Error: Material "___debugdrawenvmapmask_2" uses unknown shader "DebugDrawEnvmapMask"
Error: Material "___debugdepth_3" uses unknown shader "DebugDepth"
Error: Material "___debugdepth_4" uses unknown shader "DebugDepth"s

I could not find much information on this issue, nor anyone else with the same symptoms (wireframe player models)

Here is some more diagnostic info:
glxinfo: http://pastebin.com/b42mbPL0
Steam System Information:http://pastebin.com/GyXZJbNY

Looking forward to any sugestions.
Showing 1-2 of 2 comments
< >
Rusek Dec 28, 2013 @ 12:07pm 
I had this same problem.
This worked for me: launch steam from terminal with this parameter "force_s3tc_enable=true steam"
Last edited by Rusek; Dec 28, 2013 @ 12:07pm
Jeol32 Jan 3 @ 2:11pm 
Yep, thanks! That fixed it for me as well.

Is there any way to assign this to a launcher so I don't have to type it via the terminal every time?
Showing 1-2 of 2 comments
< >
Per page: 15 30 50