Irrelium Nov 18, 2013 @ 5:21pm
Steam Not Working After System Upgrade
I am using Arch Linux 64 bit. Steam has always worked well for me, until a recent system upgdade. I now get this error when I attempt to start it.

Running Steam on arch 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1383158641_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20131118192745_1.dmp
/home/ryan/.local/share/Steam/steam.sh: line 717: 2392 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/ryan/.local/share/Steam/bootstrap.tar.xz
Restarting Steam by request...
Running Steam on arch 64-bit
STEAM_RUNTIME has been set by the user to: /home/ryan/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(1383158641_client)
No minidump written, nothing to upload.
/home/ryan/.local/share/Steam/steam.sh: line 717: 2477 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

Any suggestions as to how to fix this?
Showing 1-2 of 2 comments
< >
serge Nov 19, 2013 @ 3:18am 
you could try to update the drivers of your graphic card.
you could also try steam --reset
Last edited by serge; Nov 19, 2013 @ 3:18am
Irrelium Nov 19, 2013 @ 3:28pm 
I have fixed the problem. It turns out the 3D accelaration of my video drivers (AMD Catalyst) was screwed up when I updated my Linux kernel, and this was preventing Steam from starting. Reinstalling the driver fixed the issue.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50